1. kfehling's Avatar
    So I bought a Red Passport for my wife for Christmas trying to convert her from her Note 3 and there is one big problem that I cannot seem to fix for her: She cannot receive photos via text (SMS) messages. At first, I was blaming her friends iPhone 6 which was sent for iChat and not SMS but once I changed that on the iPhone; the same issue. We get a "General Problems" error message. See the included photo. So I tested it by sending her a photo via SMS from my Passport and we get the same issue. Sending just a plain text seems to work fine as in the "Test2" in the same photo below. She cannot text photos either in case that helps. I cannot seem to resolve this as we are both on AT&T and both on software 10.3.0.908. Mine works perfectly and I receive text photos just fine and from iPhone users. Any thoughts on how to resolve this?

    Thanks in advance.

    Kurt

    SMS photo issue-error.jpg
    12-17-14 01:00 AM
  2. Dodger52's Avatar
    You can't send photos via SMS anyway it's a text messaging service, I believe any photos would be send via MMS.

    Posted via CB10
    12-17-14 02:18 AM
  3. marshalla99's Avatar
    Compare the MMS settings between your phone and hers. Chances are that hers isn't properly configured for the MMS message centre (MMSC).
    12-17-14 03:32 AM
  4. riph's Avatar
    You need to check on the MMS configuration.

    Posted via the CrackBerry App for Android
    12-17-14 05:49 AM
  5. PhonePuddin's Avatar
    You can't send photos via SMS anyway it's a text messaging service, I believe any photos would be send via MMS.
    SMS/MMS conversion should be seamless. Any given Text conversation should be able to handle both text and media without user intervention. Unless the "Show SMS/MMS Mode Notification" has been turned on.

    OP -- if you can get to your HUB settings, look under the Text Messages item. There's an Auto Retrieval Mode that might be the culprit in particular.
    12-17-14 10:32 AM
  6. kfehling's Avatar
    SMS/MMS conversion should be seamless. Any given Text conversation should be able to handle both text and media without user intervention. Unless the "Show SMS/MMS Mode Notification" has been turned on.

    OP -- if you can get to your HUB settings, look under the Text Messages item. There's an Auto Retrieval Mode that might be the culprit in particular.
    Good thought. I checked the settings and her's were all the same as mine with the exception of under the "advanced" tab, her routing preference was set to "circuit switch preferred" I changed it to match mine at "circuit switched". No effect though. The really odd thing is that under the basic hub, settings, Text Message tab, her PP has many more options than mine. Here are screen shots of all of her settings if this helps:

    SMS photo issue-1.jpgSMS photo issue-2.jpgSMS photo issue-3.jpgSMS photo issue-4.jpgSMS photo issue-5.jpg
    12-17-14 10:55 AM
  7. kfehling's Avatar
    Here are screen shots of my PP settings. Notice how many fewer items I have vs. her PP.

    SMS photo issue-.jpgSMS photo issue-b.jpg
    12-17-14 10:58 AM
  8. PhonePuddin's Avatar
    Well that's weird. She has a lot more settings than I do as well.

    Have you checked the Parental Controls under her Security Settings? Mine doesn't have an option for disabling MMS, but hers might. There is also an option for Content Restrictions.

    Parental Controls should default to Off. But it's something to check, anyway.
    12-17-14 11:11 AM
  9. PhonePuddin's Avatar
    Also -- you may want to turn on "Allow Delivery Confirmation" and "Allow Read Confirmation". Neither of us have those, and the iPhone might be having fits if it doesn't get confirmations.

    The only other option I can think of is to turn on "Show SMS/MMS Mode Notifications". At least then we'll see if her Passport is automatically recognizing multimedia. If it's trying to display the image outside of an MMS message, then that's a problem.
    12-17-14 11:16 AM
  10. kfehling's Avatar
    Posted via CB10
    12-17-14 12:15 PM
  11. kfehling's Avatar
    Also -- you may want to turn on "Allow Delivery Confirmation" and "Allow Read Confirmation". Neither of us have those, and the iPhone might be having fits if it doesn't get confirmations.

    The only other option I can think of is to turn on "Show SMS/MMS Mode Notifications". At least then we'll see if her Passport is automatically recognizing multimedia. If it's trying to display the image outside of an MMS message, then that's a problem.
    I turned on all of these and when I compose a text message with photo from her phone and send, the phone pops up with a "entering MMS mode" message but it still fails. I am going to try to get BB tech support and will report back.
    PhonePuddin likes this.
    12-17-14 12:55 PM
  12. kfehling's Avatar
    Checked with AT&T to see if there is any setting on their end that was not correct and it appears that everything with AT&T is correct. Calling Blackberry now to see if they can figure it out.
    12-17-14 01:56 PM
  13. kfehling's Avatar
    We have a resolution but we are not quite sure which specific item fixed it. In any case, the combination of going to Settings, Networks and Connections, Mobile Network, APN and Reset Defaults plus turning off the phone, then removing the sim card, replacing the sim card and turning it back on, has resolved the issue. I have a feeling it was resetting the APN to defaults is what did it. I should note that straight out of the box, I updated her PP with a Rogers sim to get the 908 software. The strange part is that I did that with mine as well. In the intervening weeks from when I received my phone to when I bought her's, I suppose 908 may have been tweaked so that it was different in some way. Who knows.The important thing is that it now works. Another interesting aspect is that in the Hub settings for text messages, that her options are now consistent with mine. That is, she has a much shorter list versus what was in the screen shots I previously posted.

    I really appreciate all the thoughts that everyone provided.

    Happy Holidays Crackberry Nation!

    Kurt
    PhonePuddin likes this.
    12-17-14 02:46 PM
  14. seemsixty7's Avatar
    My son ran into this same issue on their Z10 and it was the APN Settings had gotten out of whack when I updated the OS to a later version. Once the APN settings were fixed all was fine. Oddly enough though I have 2 son's and I did the same process on both phones, bit only one had the problem.
    12-17-14 03:50 PM
  15. zman12000's Avatar
    How do you reset the APN settings back to default?

    Posted via CB10
    12-17-14 04:22 PM
  16. kfehling's Avatar
    How do you reset the APN settings back to default?

    Posted via CB10
    Go to:
    Settings
    Networks and Connections
    Mobile Network
    APN (at the bottom middle)
    Restore Defaults (at the bottom again)
    12-17-14 07:59 PM
  17. kfehling's Avatar
    Would a Mod be so kind as to change the title from SMS to MMS so that any searching in the future will have better luck finding this thread if they have a similar issue?

    Thanks.

    Kurt
    12-17-14 08:00 PM

Similar Threads

  1. Blackberry 10 - Broadcast Messages via SMS/MMS complaints
    By Paul Callahan in forum General BlackBerry Discussion
    Replies: 36
    Last Post: 04-22-15, 11:37 PM
  2. Snap10 issues
    By Jonny-R in forum BlackBerry 10 Apps
    Replies: 27
    Last Post: 01-17-15, 01:42 AM
  3. Strange Charging Issue with Z10 STL-01
    By ramrakhio in forum BlackBerry Z10
    Replies: 7
    Last Post: 12-17-14, 06:53 AM
  4. Apps available for transferring iphone sms to Blackberry passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-16-14, 08:07 PM
  5. Strange charging issue with Z10
    By ramrakhio in forum BlackBerry Z10
    Replies: 1
    Last Post: 12-16-14, 04:25 PM
LINK TO POST COPIED TO CLIPBOARD