10-08-17 10:57 AM
97 ... 234
tools
  1. joshska's Avatar
    Any official word from BlackBerry Passport? It can't just be some random anomaly, not with this many people chiming in.

    Posted via CB10
    BlackBerry is aware of the issue, they've stated so on their troubleshooting page for the Passport. Last I checked it just said that they're working on a solution but that was months ago. I doubt they'll do anything for anyone whose Passport is out-of-warranty. Pity, I thought I'd have that phone for a few years but now I'm back on my Q10 in the meantime.

    Posted via CB10
    03-04-17 06:31 AM
  2. jpwill's Avatar
    BlackBerry is aware of the issue, they've stated so on their troubleshooting page for the Passport. Last I checked it just said that they're working on a solution but that was months ago. I doubt they'll do anything for anyone whose Passport is out-of-warranty. Pity, I thought I'd have that phone for a few years but now I'm back on my Q10 in the meantime.

    Posted via CB10
    Thank you! Out of warranty or not, the device still should work. There are no other issues with the device, albeit mine is within warranty. This is frustrating if what you are saying is indeed true. There should be an official announcement/statement with the opportunity for us as consumers to be compensated since this is not an isolated issue in the least.
    Notwithstanding, thank you Joshska!

    Posted via CB10
    03-04-17 06:35 AM
  3. mjcharata's Avatar
    Same problem

    Posted via CB10
    03-04-17 08:38 AM
  4. jerryb88's Avatar
    hi guys

    just bought passport silver edition in indonesia
    got the same problem here.. so sad considering i just bought it few days ago. i loved the phone and hope blackberry will fix this issue.. really hope so
    03-04-17 09:45 PM
  5. Old_Mil's Avatar
    BlackBerry is aware of the issue, they've stated so on their troubleshooting page for the Passport. Last I checked it just said that they're working on a solution but that was months ago. I doubt they'll do anything for anyone whose Passport is out-of-warranty. Pity, I thought I'd have that phone for a few years but now I'm back on my Q10 in the meantime.

    Posted via CB10
    Yeah, I am back on my Z10. I would recommend the Z10/z30/leap/q10/classic to anyone who wants a long term BB10 handset given what is an obvious design flaw in the passport.
    03-07-17 10:00 AM
  6. unclebanglin's Avatar
    yea...i love BB10...but it's really hard to think of buying a device right now...the support for web and network standards is only going to get worse...i don't want to spend $200 to get a used passport just to have it happen again

    i would LOVE to find my z10 but i can't for the life of me remember where i left it. right now I'm rocking my mom's old iPhone 4 (hatez it so slow) but I can't really see myself buying anything other than a budget android or waiting out for the KEYone as BB10 is just deader and deader everyday.

    i will forever miss the one TRUE hub and all its features. and the battery life of the passport was unrivaled.
    03-08-17 01:25 PM
  7. Old_Mil's Avatar
    Have you used a chendroid yet? I think that you'll find the hib...disappointing.
    03-18-17 10:57 PM
  8. unclebanglin's Avatar
    yeah i played on the priv in store when it first came out, instantly could see its hobbled compared to the BB10 hub...but, there aren't exactly new BB10 phones coming out
    03-20-17 10:10 AM
  9. Sam-Tech's Avatar
    I have an at&t. Passport and it has the Emergency Calls Virus. Also the antenna is not located on the back cover, that's the wireless charging coil. The antenna is located on the speaker assembly behind the keyboard.

    Posted via CB10
    03-20-17 02:22 PM
  10. tegar ramadhanu kariadinata's Avatar
    Have you used a chendroid yet? I think that you'll find the hib...disappointing.
    Chendroid... LOL

     BlackBerry Passport SE SQW-100-4 / 10.3.3.2205
    03-21-17 01:22 AM
  11. Dmd74's Avatar
    Interesting DMD. Are both the red and black passport on the same OS?

    I switched back to my Z10 and installed 10.3.3. No issues at all. So I am starting to think this is a hardware problem endemic to the passport.
    Yes, both on the same OS. I think that there is a systemic issue with the Passport randomly losing signal. Some Passports are more inflicted than others is all.
    03-21-17 07:22 PM
  12. Sam-Tech's Avatar
    My At&t Z10 still has 10.3.2.556. I wouldn't want to chance upgrading the z10 considering the Passport has the signal issue now possibly after the 10.3.3 upgrade. Today I was able to make calls and text on the Passport only if LTE and 4 bars were displayed on the screen, And that happens only when outdoors. I looked kinda foolish walking around the yard watching the signal meter until it reached a minimum of 4 bars of signal, It did display LTE with only 2 signal bars though. So I'm unsure if it's software upgrade related or not. I would assume a hardware failure would not be intermittent. And yes the Z10 performs great in the same environment so it's not a Sim Card or Signal issue. I was going to attempting to reload the previous version of the OS, But I read you cannot go back to 10.3.2 once you gone to 10.3.3
    03-24-17 08:30 PM
  13. Old_Mil's Avatar
    Bump.
    03-25-17 02:01 PM
  14. Old_Mil's Avatar
    FYI, my z10 has been running 10.3.3. (nondestructive Sachesi upgrade) without a problem for three months.

    The passport failures seem to be independent of the version of BB10 you are running.
    03-26-17 09:41 AM
  15. Drenegade's Avatar
    I'm convinced it's a hardware issue. Really unfortunate.

    Posted via CB10
    03-26-17 09:42 AM
  16. leeiling's Avatar
    I have the same issue with my Passport No.1. It is dead. Changing the back cover won't help. It is simply dead.

    Posted via CB10
    03-26-17 10:32 AM
  17. siung6's Avatar
    Might be caused by prolonged use of any type of casing. The heat from passport imho is considered abnormal, the heat got trap. It might damaged the hardware even faster.

    Posted via CB10
    03-26-17 10:49 AM
  18. TXBBguy's Avatar
    I have an at&t. Passport and it has the Emergency Calls Virus. Also the antenna is not located on the back cover, that's the wireless charging coil. The antenna is located on the speaker assembly behind the keyboard.
    I, too have the AT&T Passport with the same issue. Haven't found a fix, yet, so I'm back to using my Z30 (unlocked) which only gets LTE in certain areas, but not at my house - OK because I'm always on Wi-Fi at home.

    A side effect to the no signal issue is that my OS updated to 10.3.3.1463 when it couldn't detect AT&T signal.

    So... like so many of you, my Passport has become a WiFi only device.
    06-30-17 01:00 PM
  19. LazyTabbyCat's Avatar
    Brought my Passport to the service with same problems. A SoC has partially desoldered, that's the reason. It's impossible to repair the phone. SoC is covered with compound, there is a flash memory chip nearby and it's covered with compound too. They could try, but it would break the phone more.

    Posted via CB10
    07-02-17 02:40 PM
  20. EchoTango's Avatar
    I'm also a member of this sad club.

    I'm updating on another thread entitled "Passport Antenna" which I detailed out my recent conversation with Blackberry support.
    07-02-17 08:49 PM
  21. anand kumar26's Avatar
    Does anyone have problem with the signal on Passport?
    This morning I came to T-mobile store to get a nano sim for my Passport. After activated, my Passport still "SIM not dectected". Then I tried that sim on my iPhone 5s and it worked. Then I tried another sim card from T-mobile, and it worked on my Passport. I don't know why my nano sim card worked on other phone but didn't work on my Passport. And I don't know why my Passport worked with another sim card but not the new one I got.
    then I came to T-mobile store and replaced the sim card to take the new one. Now, it worked on my Passport but when I came home, it still "SIM not detected". I took out then put the sim card again and I had signal. Many times the Passport doesn't get the signal of the sim card, I have to take the sim out for a while and plug it in later. Is it phone problem or OS problem?
    10-01-17 08:16 PM
  22. siung6's Avatar
    Yes, both on the same OS. I think that there is a systemic issue with the Passport randomly losing signal. Some Passports are more inflicted than others is all.
    Does anyone installing Google play store are more inflicted than others? I install Google play store and I have the issue. I also use the WiFi Hotspot on a daily basis for hours. Have drop the phone a few times. I am quite sure it's the hardware. Can it be repaired? Hope those with this issue are still around.

    Posted via CB10
    10-08-17 10:57 AM
97 ... 234

Similar Threads

  1. No Synchronization to Outlook 2013 on Windows 8.1
    By jgrobertson in forum BlackBerry Passport
    Replies: 8
    Last Post: 02-22-15, 12:28 PM
  2. Call quality issue on Z30
    By msedaros in forum BlackBerry Z30
    Replies: 8
    Last Post: 11-20-14, 09:18 PM
  3. Soft Glass on Passport?
    By jgrobertson in forum BlackBerry Passport
    Replies: 14
    Last Post: 10-31-14, 09:54 AM
  4. Is the BB password keeper 'app' on the BB Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-25-14, 05:45 PM
  5. Best Buy and Future Shop offering the BlackBerry Passport for $199.99
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-25-14, 05:12 PM
LINK TO POST COPIED TO CLIPBOARD