10-08-17 10:57 AM
97 1234
  1. Old_Mil's Avatar
    Interesting DMD. Are both the red and black passport on the same OS?

    I switched back to my Z10 and installed 10.3.3. No issues at all. So I am starting to think this is a hardware problem endemic to the passport.
    02-10-17 11:17 AM
  2. kunz1925shooter's Avatar
    Same sad state here...just emergency calls only...it just makes me wonder if a real emergency arises, will I really be able call any one? Calling BlackBerry...Hello? Anyone there? Help! It is an emergency, my passport can only make "emergency calls only"...please help us BlackBerry....LoL...Peace.

    Via a sick Passsport infected with the "emergency calls only" syndrome...sigh,sad,sigh,sad,sigh,sad...
    02-10-17 07:29 PM
  3. Old_Mil's Avatar
    Only more question...does anyone who is having this problem using the AT&T (rounded corners) version of the device or is that particular version immune?
    02-11-17 11:01 AM
  4. idrisshehu43's Avatar
    Does anyone have problem with the signal on Passport?
    This morning I came to T-mobile store to get a nano sim for my Passport. After activated, my Passport still "SIM not dectected". Then I tried that sim on my iPhone 5s and it worked. Then I tried another sim card from T-mobile, and it worked on my Passport. I don't know why my nano sim card worked on other phone but didn't work on my Passport. And I don't know why my Passport worked with another sim card but not the new one I got.
    then I came to T-mobile store and replaced the sim card to take the new one. Now, it worked on my Passport but when I came home, it still "SIM not detected". I took out then put the sim card again and I had signal. Many times the Passport doesn't get the signal of the sim card, I have to take the sim out for a while and plug it in later. Is it phone problem or OS problem?
    The signal of my phone is pretty bad, I don't use it with Sim right now! I use WiFi with it
    02-12-17 04:01 PM
  5. Sandrot's Avatar
    My passport just started having no signal and when I get the signal I can't call out

    Posted via CB10
    02-12-17 05:25 PM
  6. Sandrot's Avatar
    I am wondering if I change the back cover will fix the problem since the antenna is on the back cover

    Posted via CB10
    02-12-17 05:43 PM
  7. Old_Mil's Avatar
    I don't know...Maybe someone who has a spare back cover can try it. I don't know that I would buy a new back cover to test that theory simply because the phone is saying emergency calls only instead of a red x.
    02-13-17 06:48 AM
  8. Sandrot's Avatar
    I got a passport for 50 that has that signal problem I will try it and see

    Posted via CB10
    02-13-17 07:13 AM
  9. kunz1925shooter's Avatar
    This is the weirdest thing. I went to my neighborhood mall to watch the new John Wick movie. While waiting near the cinema entrance and strolling around near my carrier's business center, low and behold, there is a 4g-lte signal on my beloved passport! I could not believe it after months with no network connection to the carrier, I suddenly have a signal connection signal! It was 2-3 bars. The farther I move away from the carrier's office the weaker the signal gets, vice versa if I move closer to the said office. Unfortunately, as I left the mall after the movie, it is back to square one. Having experiencing this, I believe it may indeed be a hardware issue with my unit. It could be the antenna. I hope that it is the issue. As I might find a shop/technician some where down town to repair or replace the antenna, if indeed that is really the problem. Crossing my fingers, I will report here if any progress or failure with the outcome of the down town trip. Hopefully before the end of the week. Peace.

    Via a WIFI only BlackBerry Passport infected with the "Only Emergency Calls". A zombie like state. LoL. Peace.
    02-13-17 08:00 AM
  10. Sandrot's Avatar
    OK so an update on changing the back cover to see if the signal would get fix it doesn't fix the problem it's most likely the spring things that connect to the entenna on the back cover aren't working properly any more I change the mother bored on my passport with another one that had problems problems with buttons and the camera and my passport works again

    Posted via CB10
    02-13-17 06:23 PM
  11. Andrew4life's Avatar
    Just started having problems with my Passport....
    Can't connect to the network!!
    All I get is SOS...

    I'm on Rogers in Canada

    Posted via CB10
    Last edited by Andrew4life; 02-13-17 at 06:58 PM.
    02-13-17 06:33 PM
  12. Old_Mil's Avatar
    Welcome to the dead passport club Andrew. It is a hardware issue of some sort. Beyond that, nobody has a solution.
    02-13-17 08:07 PM
  13. Old_Mil's Avatar
    Has anyone had one of these devices that they have managed to get working again?
    02-20-17 08:11 AM
  14. Sandrot's Avatar
    I had one it is a hardware problem all I did was buy a passport for 50 on Kijiji and took the mother board from it

    Posted via CB10
    02-20-17 07:35 PM
  15. GoatPL's Avatar
    Any news in this topic? My BB passport signal is also dead
    02-23-17 03:05 PM
  16. Sandrot's Avatar
    It's a hardware problem

    Posted via CB10
    02-23-17 06:12 PM
  17. kunz1925shooter's Avatar
    I wish that a video guide could be posted as a the said solution to the back cover/antenna thingy...?

    My apologies in advance if this request is some what unreasonable and rude...I guess it is just the despair of not being able to use and enjoy the greatness of what the passport is as a whole...peace.

    Posted via CB10
    Last edited by kunz1925shooter; 02-24-17 at 02:20 AM.
    02-24-17 02:10 AM
  18. Sandrot's Avatar
    It's not the back cover the the connection on the mother bored I changed the back cover to check to see if that was the problem but it not

    Posted via CB10
    02-24-17 06:47 PM
  19. kunz1925shooter's Avatar
    It's not the back cover the the connection on the mother bored I changed the back cover to check to see if that was the problem but it not

    Posted via CB10
    Would love to see a reference video, if possible? Thanks in advance...

    Posted via CB10
    02-24-17 11:10 PM
  20. Sandrot's Avatar
    I don't have a video all I did was change the mother bored I got a used passport for 50 with a broken screen and took the mother bored out and put it in mine passport that's all I did

    Posted via CB10
    02-25-17 12:50 AM
  21. Andrew4life's Avatar
    I have tried to check the contacts on the antenna and I have also heard of others who have had no luck trying to change the entire antenna module as well to no avail.

    I think the consensus is that this is a circuit board/motherboard issue.

    Posted via CB10
    03-02-17 06:25 PM
  22. Sandrot's Avatar
    It is the mother board issue

    Posted via CB10
    03-02-17 07:56 PM
  23. johnny_bravo72's Avatar
    Upgrade to the KEYone.
    Problem solved.
    03-03-17 04:42 AM
  24. unclebanglin's Avatar
    my infected pp is AT&T
    03-03-17 05:59 PM
  25. jpwill's Avatar
    Any official word from BlackBerry Passport? It can't just be some random anomaly, not with this many people chiming in.

    Posted via CB10
    03-04-17 06:20 AM
97 1234

Similar Threads

  1. No Synchronization to Outlook 2013 on Windows 8.1
    By jgrobertson in forum BlackBerry Passport
    Replies: 8
    Last Post: 02-22-15, 12:28 PM
  2. Call quality issue on Z30
    By msedaros in forum BlackBerry Z30
    Replies: 8
    Last Post: 11-20-14, 09:18 PM
  3. Soft Glass on Passport?
    By jgrobertson in forum BlackBerry Passport
    Replies: 14
    Last Post: 10-31-14, 09:54 AM
  4. Is the BB password keeper 'app' on the BB Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-25-14, 05:45 PM
  5. Best Buy and Future Shop offering the BlackBerry Passport for $199.99
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-25-14, 05:12 PM