1. RichardHBB's Avatar
    Brand new Passport SE, no SIM installed, connected to my wifi. Did not log into BBID yet. It automatically checked for software updates, told me was available (and mandatory) - naturally, I chose to update.

    It got through downloading and installing, then prompted for restart. On restart the progress indicator has reached 100% if I touch the screen, but it's stuck on the text at the bottom alternating between "Finalizing device setup" and "Installing updates" ...

    It's been like this a good 15 minutes, which is considerably longer than I remember 2836 taking on either of my Z30's. Really don't want to try powering it down yet as I figure the results could be unpredictable.

    Any ideas?

    EDIT - as a side note, I set up my other one (bought 2) and only changed my method slightly - finished going through setup and cancelled the automatic update. Restarted the phone 1 time and then manually updated the OS. The step where the first phone is still stuck, the second phone finished around 5 minutes. First one still stuck...second one updated successfully.

    Last edited by RichardHBB; 11-27-16 at 09:01 AM.
    11-27-16 08:08 AM
  2. AshokGov's Avatar
    I hope the Update for the 1st Phone completed successfully! I did the same thing earlier today with a OG - no SIM and no BBID - just used WiFi. It went through the Download, Install and Update Process for 2836 and I accepted the restart request, when prompted. The last step, after reaching 100%, took some time - I think it was lesser the 15 minutes and then went to the Home Screen and displayed a message of successful completion.
    11-27-16 09:02 AM
  3. RichardHBB's Avatar
    About 5 minutes on the second phone for it to complete the restart - after it reached 100% on the boot process.

    For the first phone, at the 30 minute or so mark I decided it's either going to be OK with a power cycle or it's getting sent back anyway, so I shut it off and restarted it. When it came back up, it took that same 5 minutes or so, announced the update completed, and seems fine.

    Go figure!

    11-27-16 09:14 AM
  4. AshokGov's Avatar
    Well - good to know that it seems to have successfully updated! All the best with your 2 new 'buddies'!!
    11-27-16 09:52 AM
  5. AshokGov's Avatar
    Incidentally, how did you execute the Power Cycle - with the Power Button or with the Up/Down Volume Buttons?
    11-27-16 09:53 AM
  6. RichardHBB's Avatar
    The phone was still showing the boot process on the screen, so I didn't bother with the volume buttons - didn't know if they would do anything. I just held the power button until it turned off.

    11-27-16 10:10 AM
  7. AshokGov's Avatar
    Ok, thanks!
    11-27-16 11:24 AM

Similar Threads

  1. WhatsApp video problem
    By viraj soni in forum BlackBerry Z3
    Replies: 5
    Last Post: 12-01-16, 02:16 AM
  2. I want to disable the green indicator on my BlackBerry Passport
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 11-29-16, 11:50 PM
  3. Passport slow and battery doesn't last long
    By berrydeck in forum BlackBerry Passport
    Replies: 5
    Last Post: 11-27-16, 01:27 PM
  4. Can I exchange Blackberry 10 with Blackberry Android on my passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-27-16, 08:41 AM
  5. Replies: 3
    Last Post: 11-27-16, 07:10 AM