1. SteelBerry86's Avatar
    Has anyone had issues with the SD card in there passport? I have a 32GB card that I used for over a year with my Q10 and it works fine in my passport but I noticed that it's starting to lose connection, meaning it isn't seen, when I go into pics or anything related to the card it shows as empty. A quick pull of the card and re insertion works but it's quite annoying when trying to save a pic or take one and also when trying to attach to email, text, etc I'm always pulling off the cover.

    Any ideas?

    Posted via CB10
    12-12-14 08:10 AM
  2. BigBadWulf's Avatar
    Try cleaning the contacts on the SD with a pencil eraser, or text with a different SD. It's possible it's the port, but that can't be assumed, regardless other's experiences.
    12-12-14 08:21 AM
  3. ahelluvabruva's Avatar
    Just inserting the SD card will not securely connect it to the device. Push it in the slot until you hear a click/snap. There is a mechanism in the slot that receives the SD card, unlike most smartphones. To remove the SD card, push the card into the slot and it will bounce out.

    Posted via CB10 on the BlackBerry Passport
    12-12-14 08:57 AM
  4. alicepattinson's Avatar
    I do experience this many times before but when i tried to replace my sd card it didn't disconnect anymore.
    12-12-14 09:05 AM
  5. SteelBerry86's Avatar
    Great. Thank you. I will try cleaning the contacts and see. I'm aware of the press in-out feature on the passport. I'm thinking the port is okay, as it's really sporadic and I can't duplicate it at all. I'll pop in another card if cleaning doesn't help. Thanks all

    Posted via CB10
    12-12-14 11:19 AM
  6. Protocol 2001's Avatar
    I will try cleaning the contacts and see ... I'm thinking the port is okay, as it's really sporadic and I can't duplicate it at all. I'll pop in another card if cleaning doesn't help.
    I've also had this issue from day 1 when switched to the Passport. Were you able to find a resolution?
    12-18-14 09:40 AM
  7. SteelBerry86's Avatar
    Actually I cleaned the contacts on the card with an eraser and it's been okay since then. I should probably buy a new card soon anyway but so far it's been working.

    Posted via CB10
    12-18-14 12:38 PM
  8. crowning73's Avatar
    I have this issue too, card is 8GB and brand new, I have no contacts in there, just photos and videos, and sometimes the Passport won't see the external media, a reboot fixes it but terribly annoying! Any solutions?
    09-06-15 04:16 AM
  9. SteelBerry86's Avatar
    I'm not sure I'm understanding, but by contacts I'm talking about the copper strips on the SD card. I know they are sometimes shipped with a light coating of oil to prevent any corrosion in storage/shipping. I used a pencil eraser on them and have not had the issue again. I hope this helps.

    Posted via CB10
    09-06-15 03:58 PM
  10. crowning73's Avatar
    Right, silly me, when I read 'contacts' the only thing I could think of was the actual contacts of the phone.. anyhow, i'm not a technical person, but how can it be the contacts when rebooting the phone makes it read the media again, I understand if I would remove then plug in again the SD card but I don't even touch it, weird no?
    09-07-15 05:10 AM
  11. SteelBerry86's Avatar
    Very weird, but I had same issue and have never had it again, still using same SD Card. Anyway worth a try and hopefully it gets worked out for you. Good luck

    Posted via CB10
    09-28-15 05:18 PM
  12. crowning73's Avatar
    Very weird, but I had same issue and have never had it again, still using same SD Card.
    Well I must say that's so far this has been the case for me too, never had it again (except some sporadic disconnection and almost immediate auto-reconnection), I didn't do anything to fix it, and still using the same SD card too, weird indeed.
    09-29-15 01:21 AM
  13. crowning73's Avatar
    Spoke too soon, still disconnecting
    10-29-15 05:31 AM

Similar Threads

  1. Memory Card those not show files on Z3
    By ibawon in forum BlackBerry Z3
    Replies: 1
    Last Post: 12-14-14, 08:45 PM
  2. Hw to make card s default storage for BlackBerry z3
    By Amar Yadav in forum Ask a Question
    Replies: 4
    Last Post: 12-14-14, 03:16 AM
  3. Does the Blackberry 9350 US have a sim card slot?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-12-14, 04:41 PM
  4. Replies: 2
    Last Post: 12-12-14, 02:04 AM
  5. How do I copy music from my device to a micro sim card?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-11-14, 03:39 PM
LINK TO POST COPIED TO CLIPBOARD