07-10-15 06:28 PM
36 12
tools
  1. Susan Parker's Avatar
    I bought my Blackberry Passport via the Blackberry site. I am returning it becuase the Link/Blend software doesn''t work properly and becuase the device gets too hot. I have 30 days to return via Fed Ex. The item and useage accompaniments are clearly faulty. On the paperwork Blackberry sent me, the returns invoice total sum is far less than I actually paid for the item - by a large margin. Will I get a full reimbursement? The other payments are for shipping and taxation for delivery in the first place, which amounted to over 70, w hich I don't want to lose. I don't see why I should meet these costs myself if the item is faulty. It is going back to Slovakia.

    Please advise. I have rung Blackberry but never seem to be put through to a customer services rep. I have emailed River but have had no response as yet. I just want to know what I can expect.

    Thanks
    07-07-15 07:11 AM
  2. jaydee5799's Avatar
    I don't believe anyone is ever reimbursed for shipping costs and taxes. But that's here in the US
    07-07-15 07:13 AM
  3. Trauma Surgeon's Avatar
    Send to: John Chen, 2200 University Ave. East, Waterloo, ON, Canada

    Posted via CB10
    07-07-15 07:41 AM
  4. habs_fan's Avatar
    Most likely you won't get back shipping and the taxes ect. That's your risk. If you tell us your problem then maybe we can help, care to explain what's wrong with blend? My blend works as its supposed to.

    Posted via CB10
    07-07-15 07:44 AM
  5. Baked's Avatar
    Have to update to the beta zone version of blend I think it's 1.3

    Posted via CB10
    07-07-15 07:58 AM
  6. Poi25's Avatar
    I bought my Blackberry Passport via the Blackberry site. I am returning it becuase the Link/Blend software doesn''t work properly and becuase the device gets too hot.
    User error and normal thermal dissipation.
    mkelley65 likes this.
    07-07-15 10:23 AM
  7. CFFrost's Avatar
    You specified that Link/Blend don't work properly, but what exactly does not work in them? Also it's normal for the device to get hot; until micro-fans get invented phones today have to make do with heat dissipation the classic way. Today there were 38 degrees (Celsius) in my city and my PP got extremely hot, particularly the upper half of the screen and the side edges, in my pocket! In the car it was even worse, and if I use something like Google Maps it does get noticeably hot too in that case.

    TL;DR you didn't say anything specific about your problem, you returned a potentially functional phone without asking anyone (not even this community) about your issues and think that the device heating up is abnormal.
    07-07-15 05:32 PM
  8. shawnreum's Avatar
    Blend also doesn't work on all versions of Windows PC's. Keep that in mind also.

    Posted via CB10
    07-07-15 06:54 PM
  9. Susan Parker's Avatar
    Thanks for the responses. The BB Passport is supposed to be compatible with Win7. There is a download link for it. Yet when I installed Blend and Link I found that the interface drag and drop didn't happen and if I set the device up with interact wirelessly it no longer recognised my USB cable when syncronising Outlook calander and Contacts (which can only be done by USB cable.). I tried dis and re-installing it and that didn't work. Basically, the software is a lemon. It is not nearly as good or reliable as the old 0S7 software for older BB devices, which are fully functional on my machine.

    If someone can post a way around these problems bar what I have done already I will be grateful. I have reinstalled it, re-set the device back to factory settings and the software once reinstalled still doesn't recognise my USB link and connect up. The software is simply saying 'not connected' even when the device is saying that it is connected.

    I will want all of my money back if this can't be resolved. I fail to see why I should pay anything at all for a fault device. So I don't agree that it is my risk. I have consumer rights and intend to exercise them.
    07-07-15 07:12 PM
  10. Poi25's Avatar
    Blend also doesn't work on all versions of Windows PC's. Keep that in mind also.

    Posted via CB10
    Ummm? Blend is running on my PC right now.

    Posted via CB10 // Passport SQW100-1 // 10.3.2.2339 // Cricket Wireless
    07-07-15 07:19 PM
  11. shawnreum's Avatar
    I've seen this once before happen to someone where blend wouldn't recognize the Passport. It turned out that the initial time they hooked up to there computer they selected, "connect as mass storage device".

    Unfortunately I don't recall what they did to fix it.

    Posted via CB10
    07-07-15 07:25 PM
  12. shawnreum's Avatar
    Ummm? Blend is running on my PC right now.

    Posted via CB10 // Passport SQW100-1 // 10.3.2.2339 // Cricket Wireless
    It's not designed to run on Vista

    Posted via CB10
    07-07-15 07:26 PM
  13. RoseBud68's Avatar
    It's not designed to run on Vista

    Posted via CB10
    With good reason....
    07-07-15 07:28 PM
  14. Poi25's Avatar
    It's not designed to run on Vista

    Posted via CB10
    Well can I run it on Windows ME than?
    mkelley65 likes this.
    07-07-15 07:29 PM
  15. shawnreum's Avatar
    Well can I run it on Windows ME than?
    I don't know. Can you?
    I have Vista on my computer, can't use it.

    Posted via CB10
    07-07-15 07:39 PM
  16. Susan Parker's Avatar
    Can someone post a proper solution please?
    07-07-15 07:45 PM
  17. ZeroBarrier's Avatar
    I don't know. Can you?
    I have Vista on my computer, can't use it.

    Posted via CB10
    Let me give you some advice; update your Windows. It's neither BlackBerry's fault nor Blend that's the issue; the issue is you deciding to use an outdated, archaic and unsupported OS.

    Posted via CB10
    07-07-15 07:52 PM
  18. Zeratul57's Avatar
    Thanks for the responses. The BB Passport is supposed to be compatible with Win7. There is a download link for it. Yet when I installed Blend and Link I found that the interface drag and drop didn't happen and if I set the device up with interact wirelessly it no longer recognised my USB cable when syncronising Outlook calander and Contacts (which can only be done by USB cable.). I tried dis and re-installing it and that didn't work. Basically, the software is a lemon. It is not nearly as good or reliable as the old 0S7 software for older BB devices, which are fully functional on my machine.

    If someone can post a way around these problems bar what I have done already I will be grateful. I have reinstalled it, re-set the device back to factory settings and the software once reinstalled still doesn't recognise my USB link and connect up. The software is simply saying 'not connected' even when the device is saying that it is connected.

    I will want all of my money back if this can't be resolved. I fail to see why I should pay anything at all for a fault device. So I don't agree that it is my risk. I have consumer rights and intend to exercise them.
    A big mistake is to first download link and blend into a computer. DELETE THOSE INSTALLATION S. Reboot computer. Now plug in passport and it will ask if you want to install software. Say yes and everything will work correctly. I have helped people solve this.

    Ps. For the record this can be caused by your computer motherboard bios, Ms USB drivers or MB drivers. There is a lot going on here and it will only work if there are no computer issues. Borrow a friend's laptop or computer. Plug in passport by USB and load software. BlackBerry software works fine. It the computer and sometimes install procedure that causes your exact problem.

    Posted from a Z30. Get one!
    07-07-15 07:58 PM
  19. shawnreum's Avatar
    Let me give you some advice; update your Windows. It's neither BlackBerry's fault nor Blend that's the issue; the issue is you deciding to use an outdated, archaic and unsupported OS.

    Posted via CB10
    @ZeroBarrier I don't care that blend doesn't work on my computer.

    It's Susan that's asking for assistance.
    I was just informing her that it won't work on all Window versions.

    Posted via CB10
    07-07-15 08:06 PM
  20. Detective M Downs's Avatar
    Also, check the USB mass storage option.
    07-07-15 08:11 PM
  21. anon(153966)'s Avatar
    I'm guessing you've also tried different USB ports on you computer?
    You might have to disconnect the BlackBerry from your computer, then go to device manager and check the USB section. Look for either BlackBerry or even RIM. Delete it, reboot the computer THEN reconnect the BlackBerry. That should force it to reinstall the drivers. It should solve most of your issues.

    With regards to Windows, you really want to have Windows 7, 8 or 8.1.

    Keep us posted.
    07-07-15 08:22 PM
  22. Susan Parker's Avatar
    Also, check the USB mass storage option.

    What do you mean by USB Mass Storage Option? How do I check that and what do I need to do exactly? I'm not very technically minded.

    I read on here somewhere that you should go into Settings, click 'Windows' on your BB devices to connect up with Blend/Link rather than let the device choose, but when I tried to do that I couldn't find that option under the right Setting Menu.

    Also, when connecting BB Passport to a PC (I have Win7 64 bit) before installing the software, as suggested a couple of posts back, do you have to restore the device back to factory settings first?
    07-07-15 08:23 PM
  23. shawnreum's Avatar
    What do you mean by USB Mass Storage Option? How do I check that and what do I need to do exactly? I'm not very technically minded.

    I read on here somewhere that you should go into Settings, click 'Windows' on your BB devices to connect up with Blend/Link rather than let the device choose, but when I tried to do that I couldn't find that option under the right Setting Menu.

    Also, when connecting BB Passport to a PC (I have Win7 64 bit) before installing the software, as suggested a couple of posts back, do you have to restore the device back to factory settings first?
    Try this.....
    Go to system settings
    Network and connections
    Go down to USB and select it
    In there every thing should be turned off. (no blue)

    And then get back to us


    Posted via CB10
    07-07-15 08:46 PM
  24. Poi25's Avatar
    @ZeroBarrier I don't care that blend doesn't work on my computer.
    Are you seriously using Vista?
    07-07-15 09:30 PM
  25. Susan Parker's Avatar
    Try this.....
    Go to system settings
    Network and connections
    Go down to USB and select it
    In there every thing should be turned off. (no blue)

    And then get back to us


    Posted via CB10
    I did that and everything had been turned off. So that can't be the solution either.

    I restored the device to factor settings, reinstalled Blend/Link with the device already plugged into the computer - as suggested a few posts back. When I clicked on Blend it worked and asked me to verify the device and Blend codes for connectivity matching, but Link is a different story. It still won't recognise my device at all, even though their is an audible ping sound when I stick my device USB cable into the computer and I re-enter the BB ID. The device says 'connected' but there is not even a picture of the device on the Link home screen. Instead the left hand panel reads 'connect a device to begin managing it'. There is, however, a tickbox recognition of the device on the Blackberry ID page but that is no good because I can't syncronise my Microsoft Outlook calandar entries to the device using that page and searching under folders. I have to use the home screen for that so that I can configure my options properly. BTW when I first installed Link it did work and did syncronise it was only when I disinstalled it and reinstalled it again because I discovered that the other drag and drop features on the Link Home page didn't work, even though my Outlook was syncronising. Before my Blend didn't open either. Now everything is in reverse. What worked before now doesn't and what didn't work before now does. It is all so odd.

    Any more suggestions before I Fed Ex it back tomorrow? I can't be doing with these problems. Thanks
    07-07-15 09:47 PM
36 12

Similar Threads

  1. BlackBerry World not working in the Philippines
    By gerokeroro in forum Ask a Question
    Replies: 5
    Last Post: 08-01-15, 03:37 AM
  2. Why isn't my new BlackBerry ID being accepted?
    By doris78 in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 07-08-15, 06:44 AM
  3. Why BlackBerry choose Android and not Windows?
    By The_Passporter in forum BlackBerry 10 OS
    Replies: 8
    Last Post: 07-07-15, 07:44 AM
  4. Nemory Ending BlackBerry 10 Development
    By Johnny Dollar in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 07-07-15, 06:44 AM
  5. How to install Google play store on my BlackBerry passport? Please guide me
    By Shahrukh Ali2 in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 07-07-15, 06:34 AM
LINK TO POST COPIED TO CLIPBOARD