1. jumxlee's Avatar
    Hi all

    Anyone having similar issues?

    1) the emails which i read are still showing up in the locked screen. I am using IMAP (gmail).
    2) messages in draft mode are also showing up in the locked screen.
    3) when I send an email, and BCC myself, my email will show up in the locked screen, but instead of showing myself as the sender, it shows my intended recipient as the sender in the locked screen. This was not how it behaved in my Z30.

    It's weird!
    10-29-14 12:59 PM
  2. Ecm's Avatar
    That's an odd one, for sure.

    I'm not sure what to suggest other than to check your sync settings on your device: Settings > Accounts > Your Gmail account. Ensure "Push if Supported" is ON, and try reducing your Sync Interval.

    At the Gmail end, I'd suggest matching your settings to the ones shown here: How to Setup Gmail on your BlackBerry 10 Device




    This may also be of interest: How to prevent deleted Gmail messages from archiving when synced using IMAP. For an IMAP account (such as Gmail), you have to select the sync period option when setting up the account -- so you'd have to delete and re-add it. Use the standard email setup, until you get to the screen that gives you the option to toggle on/off contact/calendar sync. Tap "Advanced" at the bottom. Scroll to the very bottom, and set the "Initial Retrieval amount" to "Forever" (or your preferred sync period). You can also set your sync interval here as well.
    Note that if you'll be syncing a lot of messages, you should be on WiFi, unless you have a very generous data plan.

    A last note. If you enable "Append messages to Sent folder", you could forgo BCC'ing yourself. A copy of all the sent messages will be availabler on your device and in Gmail.

    Hope something here helps.
    jumxlee likes this.
    10-31-14 07:42 PM
  3. jumxlee's Avatar
    Hi guys

    Found the root cause. It's actually due to what I have been doing for point (3) above.

    It seems that gmail somehow marked some of the sent messages as "Unread", that's why they are showing up. Interesting thing is that if I read them in my Passport, they are not switched to "Read". Perhaps a bug somewhere.

    To solve the problem, go to your Gmail settings, create a filter to mark all emails sent by you as "Read". That will serve as a workaround.
    11-02-14 01:42 AM

Similar Threads

  1. Which email service do you use?
    By blueburk in forum General BlackBerry Discussion
    Replies: 95
    Last Post: 06-13-15, 05:59 PM
  2. where to buy the passport in Hong Kong ?
    By darkbull in forum BlackBerry Passport
    Replies: 3
    Last Post: 10-29-14, 07:23 PM
  3. Anyone else having issues with Blackberry in Canada or the US
    By Will Bondy in forum Service Outages
    Replies: 6
    Last Post: 10-29-14, 02:39 PM
  4. Memory card bug in 10.3.0.1418 (passport)?
    By Mansoor2 in forum BlackBerry Passport
    Replies: 6
    Last Post: 10-29-14, 12:47 PM
  5. When is the official 10.3.1 update releasing in India?
    By akshay95nigam in forum Ask a Question
    Replies: 3
    Last Post: 10-29-14, 11:41 AM
LINK TO POST COPIED TO CLIPBOARD