1. xueyaotianxia's Avatar
    I installed chrome but every time I open it, it shuts down automatically...and then I rebooted the device. Problem here comes, when I open chrome again, the whole screen shows a loading bar and it stops before completion. If I try to open any other android app again, they will do the same thing now with the loading bar...

    The solution was to hold the power button for more than ten seconds to soft reset the device. After reset all other apps will be fine but I still cannot use chrome. I believe there are people out there got chrome working normally on passport?

    Can any pro explain it to me why the phone does this? And I installed chrome before it was working. But not on the same passport...the other one was broken under warranty so this one I'm using is the one they changed for me...the previous one couldn't turn on by any chance after 4 days of purchase...I put it on charge the other night....the 2nd morning when I woke up it was dead...

    Posted via CB10
    01-24-15 12:02 PM
  2. Viet Ton's Avatar
    Which version of bb10 are you on?

    Posted via CB10
    01-24-15 08:29 PM
  3. xueyaotianxia's Avatar
    Passport 10.3...

    Posted via CB10
    01-24-15 11:59 PM
  4. aTrueBbLover's Avatar
    Chrome works perfectly on 10.3.1.

    Posted via readers chamber on 14 th street.
    01-25-15 12:01 AM
  5. rebroker2009's Avatar
    I would delete chrome, reboot, install chrome via another procedure. I used snap

    Blackberry Passport running 10.3.1.1151
    01-25-15 12:02 AM
  6. xueyaotianxia's Avatar
    I tried from google play, snap and 1mobile...same result. Whenever I open the app it closes. Maybe something is wrong with the phone? I was wondering why there is a bar loading after I reboot and try to open the app...and the bar stops. Then all android apps will not be working unless I reset the device...

    Posted via CB10
    01-25-15 01:31 AM
  7. tremor1's Avatar
    Happy with the BlackBerry browser. I know that a lot of the android apps are really not 100% with BB10. I don't even get notifications with Groupme for my work.

    Posted via CB10
    01-25-15 01:47 AM
  8. Phone Guy 4567's Avatar
    My experience with Android apps on BB10 has been the same, the notifications not coming through I find very annoying.
    01-29-15 01:08 AM

Similar Threads

  1. The Android Fan
    By BriniaSona in forum Rehab & Off-Topic Lounge
    Replies: 3
    Last Post: 01-30-15, 11:04 PM
  2. Problem with BBM ID
    By Loc22 in forum General BBM Chat
    Replies: 4
    Last Post: 01-24-15, 09:16 PM
  3. App to silence notifications but not text
    By mmarksx19 in forum BlackBerry 10 Apps
    Replies: 7
    Last Post: 01-24-15, 04:43 PM
  4. Replies: 3
    Last Post: 01-24-15, 01:55 PM
  5. What happened to my BBM app? I tried to move it and it vanished.
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-15, 11:45 AM
LINK TO POST COPIED TO CLIPBOARD