1. giper54's Avatar
    I have a Passport on AT&T and LTE works. I had a Z10 and I always had two bars of LTE. The Z10 had rock solid LTE reception. My LTE reception on the Passport is worse. I have a hard time getting or holding an LTE signal. When I do get one it is only one bar. While on 4 G my bars fluctuate all over the place and I will even lose reception and the phone will search for a signal. None of that ever happened on my Z10. I had AT&T put in my Z10 IMEI in the system and no improvements. Any suggestions or is it time to return the phone for a new one?
    10-16-14 05:51 PM
  2. AnimalPak200's Avatar
    Maybe try getting an adapter and put your sim card into the Z10, just out of curiosity.

    I'm in a pretty tough area and my Passport gets solidly good 4G and LTE coverage. There are still some towers around here that don't have LTE (confirmed with other AT&T LTE devices), but the 4G is so solid that sometimes I wonder if the indicator is broken.
    10-16-14 05:59 PM
  3. Risky_KillMoves's Avatar
    Yea I have this same problem but with the recent 10.3 OS that Rogers has released and is floating around CB it seems to address the radio issue, haven't gotta around to it but possibly this weekend. Give it a go yourself, I've heard nothing but good about it also address some of the virtual keyboard issues too

    Posted via CB10
    10-16-14 09:17 PM
  4. 3800's Avatar
    nope. my passport on AT&T gets great reception.

    Posted via CB10
    10-16-14 10:05 PM
  5. nbaliga's Avatar
    Getting solid LTE on AT&T in SF bay Area, California.

    Posted via CB10
    10-16-14 11:22 PM
  6. Lobwedgephil's Avatar
    No problem with my LTE reception on att.

    Posted via CB10
    10-16-14 11:56 PM
  7. kfehling's Avatar
    On my Z10 on AT&T and then my Z30 on both AT&T and Verizon lost reception at one point on my long driveway. This Passport on AT&T has never dropped a call yet. Best reception of any phone yet. Sorry to hear of your troubles and perhaps the radio or antenna is defective and you can get a replacement under warranty. Hope you get it resolved.

    Posted via CB10
    10-17-14 12:04 AM
  8. netwerx1's Avatar
    Mine is good in California, but I updated to the new Rogers OS version before I even set it up...

    Posted via CB10
    10-17-14 12:22 AM
  9. rai187's Avatar
    I seem to have a worse connection on my passport compared to my z10 on the rogers / Fido network. Definitely not happy about this.

    Posted via CB10
    10-17-14 03:45 PM
  10. giper54's Avatar
    I returned the Passport and ordered a new one today. I hope that helps. I did notice that the box my phone came in had double tape. Makes me think it may have been a refurb if that is possible.
    10-17-14 03:54 PM
  11. Azensun's Avatar
    I have the opposite results. My Z10 rarely got more than three bars of reception while at the house. Meanwhile, my Passport has been getting nothing but five bars. It never drops below that.

    I hope your issue gets resolved with the replacement device.
    10-17-14 04:01 PM
  12. giper54's Avatar
    Thanks. I will post when I get my new one. I am not sure if it is shipping today or on 10/29.
    10-17-14 04:16 PM
  13. fudabb's Avatar

    Ive had the passport for about a month and I love it, except for the call signal strength. 95% of the time it only gives me one to two bars of signal where my z10 was a steady 4 to 5 bars always. The strange thing is that, when I make a call, or answer an incoming one the reception shoots up to full bars. As soon as I hang up, reception goes back down to one to two bars. Call quality is fine always, but Ive had about 5 calls in the past month go straight to my voicemail, which rarely happened on my z10. Im on the Rogers network in Mississauga, Ontario, Canada. The phone wasnt purchased through Rogers but instead through blackberry direct, so it is unlocked. Ive called Rogers, Blackberry, tried another sim, hard reset all to no avail. Sounds like some of you might be having similar issues. Can you please share how you resolved this.

    12-12-14 07:57 AM
  14. thedose's Avatar
    As weird as this sounds, I'm actually getting better service than when I had Verizon on the iPhone 5S

    Weird as hell as Verizon is supposed to be "the carrier" for the east coast?!

    Curious to see how it will be once I go back home (SF bay area) this coming week...
    12-12-14 10:48 AM
  15. doubleplusgood's Avatar
    I'm not an AT&T but up here in Canada have observed the same thing on Bell Canada when my partner switched from a Q10 to the Passport. Despite living in a semi-rural area she never experienced dropped calls with the Q10. With the Passport she gets a couple of dropped calls each day (as confirmed by Bell records). The phone is also unusable on her ferry commute whereas her Q10 and my Z30 are typically fine. We installed Signal Tracker on her Passport which typically reads an 8-10 dBm lower signal than my Z30. However, my Z30 is on Telus and although they share the same infrastructure with Bell I can't rule out some network tuning differences also contributing to the observed power differences.

    We have had conversations with Bell and BlackBerry but I have not heard an explanation that makes sense to date. Given that occasionally (5% of the time) the Passport shows better reception than the Z30 my guess is that this is not a hardware problem but is due to some peculiarities of the radio software. I'm hoping this will get fixed or the Passport will be replaced by a Z30 which to date has the best reception of any phone I have used.
    12-20-14 09:05 PM
  16. jthep's Avatar
    I cannot get ATT service since my Passport won't recognize an ATT sim card for some strange reason. I have gone to two stores and both times ran into the same problem.

    Another odd flaw is how Amazon app stores always crashes and has never worked from day 1?

    I really hope ATT gets this phone officially soon and has its own software update, so I can return to ATT. I currently use Tmobile and their service is spotty in Manhattan believe it or not!!!

    I know ATT will likely gimp some features with an official software update, but I would rather have that than Tmobile's spotty service.

    Posted via CB10
    12-22-14 06:16 PM
  17. DCMack's Avatar
    I'd return the device. I use AT&T in the Dallas area and have a strong LTE signal.

    Posted via CB10
    12-22-14 06:28 PM
  18. dcwbearsaint's Avatar
    For me the service has been solid. The bars not always at full strength, but the reception has need good without a problem.

    Posted via CB10 on the awesome Passport
    12-22-14 07:03 PM

Similar Threads

  1. Help. i Think My z10 is Hard Bricked. (Stuck at Boot Logo)
    By Ghostluxury in forum BlackBerry Z10
    Replies: 34
    Last Post: 01-21-15, 05:18 PM
  2. Telus BB Q5 on sale at FS for $154
    By VR6 in forum BlackBerry Q5
    Replies: 10
    Last Post: 11-21-14, 01:04 PM
  3. For anyone on the New BB10 OS?
    By Berricnightmare in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 10-17-14, 07:30 PM
  4. I don't have a refresh button on my history Page. How else do I refresh?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-14, 01:27 PM
  5. Why has my screen frozen with software updates at 18?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-14, 09:17 AM