1. Trini-Shan's Avatar
    I've had my Polk Audio Noise Cancelling headphones for about 3 years. I never experienced any problems when I used them with my 9900, 9790, or Z10. I've been trying to use them with my Passport since Nov 2014, but the device doesn't recognize the headphones (i.e. audio continues to play through the loudspeaker) even after the software updates (now running 10.3.1.2708 on Telus).

    Anyone else experiencing this problem? Or, is there a reason why my headphones aren't recognized? Thanks in advance!
    04-13-15 03:41 PM
  2. thecsman's Avatar
    Does the device even pair with your Passport? Show us a screenshot.

    Posted via CB10
    04-14-15 05:11 PM
  3. Trini-Shan's Avatar
    Pair as in using bluetooth? I don't need to because I'm just plugging into the headphone jack.
    05-05-15 01:53 PM
  4. mad_mdx's Avatar
    Do any other headphones work when you plug them? Your headphone port may be broken
    05-05-15 01:57 PM
  5. Trini-Shan's Avatar
    factory headphones and using my male-male audio connector both work as expected. I only have issues with these headphones.
    05-07-15 12:23 PM
  6. anon(2313227)'s Avatar
    Perhaps it is not sitting in all the way? How are the plugs? do you use a case?
    I had other issues with headset not plugging in right because of the case.
    05-07-15 02:35 PM
  7. Trini-Shan's Avatar
    Problem is still there with no case on the phone.
    Plug on the headphones is in good condition; I plug it into my laptop and other (and older BB devices) and it works fine.
    Last edited by Trini-Shan; 05-13-15 at 01:42 PM. Reason: typo
    05-13-15 01:42 PM
  8. firstknight_eg's Avatar
    I used to have a problem like this with another phone, where the phone doesn't recognise this specific headset, nobody knows why? Ended up buying a short extension cord and oops, problem solved. But till now I have no clue why.

    Posted via CB10
    05-14-15 12:51 AM
  9. RexdaleNap's Avatar
    try hard reset or os update, you never know..
    05-14-15 11:28 AM
  10. Trini-Shan's Avatar
    I've had the problem ever since I got the Passport and I've updated 2 or 3 times since then. @RexdaleNap I'm still having the problem.

    @firstknight_eg was this issue with a BB phone?
    05-14-15 04:12 PM

Similar Threads

  1. Work-Around for Motorola IP Cams on Passport??
    By RLC3780 in forum BlackBerry Passport
    Replies: 23
    Last Post: 12-15-15, 03:18 PM
  2. How can I fix a faulty charging port on my Blackberry Passport?
    By lovecoaster in forum BlackBerry Passport
    Replies: 13
    Last Post: 04-16-15, 07:39 AM
  3. Deezer brings enhanced audio quality with their latest update
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 1
    Last Post: 04-13-15, 03:14 PM
  4. Screen shot not saving to pictures
    By dawnja5402 in forum BlackBerry Z10
    Replies: 2
    Last Post: 04-13-15, 03:04 PM
  5. Nightly Clock updated with improved Passport support and brightness control
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 04-13-15, 02:40 PM
LINK TO POST COPIED TO CLIPBOARD