1. domolsz's Avatar
    My Passport, while in dial pad and in Calls tab of the Phone app, as well as in the Calls section of the Hub displays phone numbers in an strange way - 9 digit numbers are displayed as XX XXX XX XX rather than XXX XXX XXX. So, a mobile phone number of 444 555 666 is displayed as 44 455 56 66.

    My guess is that this is a format meant for fixed numbers where there is a two digit area code and a 7 digit number, but at least in my case most of the numbers I call and am called from are mobile and this display looks very confusing.

    Any ideas how to change this? I do not recall this problem on my Q10 which I used before Passport.

    Thanks for your help!
    09-30-14 06:32 PM
  2. ZeroBarrier's Avatar
    Phone -> Settings pull down -> Smart Dialing

    Posted via CB10
    09-30-14 06:35 PM
  3. domolsz's Avatar
    Phone -> Settings pull down -> Smart Dialing

    Posted via CB10
    Thanks, already tried to alter settings under smart dialling but it does not change the number formatting. Also, I can't see a way to turn it off.

    Posted via CB10
    09-30-14 07:03 PM
  4. nah.uhh's Avatar
    Thanks, already tried to alter settings under smart dialling but it does not change the number formatting. Also, I can't see a way to turn it off.

    Posted via CB10
    Fwiw
    "National number length" should include the area code and phone number but not the country code.

    For example, 1 504 222 2222 is a 10 digit national number
    09-30-14 07:42 PM
  5. Andrew4life's Avatar
    Have you tried making sure your regional settings are correct?
    Maybe some countries have the number formatted differently.

    Posted via CB10
    09-30-14 07:54 PM
  6. domolsz's Avatar
    Have you tried making sure your regional settings are correct?
    Maybe some countries have the number formatted differently.

    Posted via CB10
    I found that the setting for numbering format for my country (Poland) is incorrect. Changing the country to Germany has resolved this issue. Looking for a way to report this to Blackberry. I also double posted this problem in another thread with the same title by mistake for which I apologise.

    Thanks for help everyone!
    09-30-14 08:15 PM
  7. Gris12's Avatar
    I have the same with my z10 stl2

    Posted via CB10
    01-16-15 05:28 PM
  8. kbz1960's Avatar
    I don't know why they want to add the +1 for the USA. You don't need to dial 1 on a cell phone.
    01-16-15 07:36 PM
  9. lideek's Avatar
    I'm from Poland too, and changing regional to Germany dont fix this issue. My telefon format is still xx Xxx xx xx....

    Any ideas?

    Posted via CB10
    01-18-15 11:00 AM
  10. PatrickMJS's Avatar
    Check your settings under Phone / Smart Dialing.
    .

    Phone number formatting in Passport-img_20150118_094636.png
    .
    These are my settings here in Canada.

    In Poland, make sure the country code is set to +48. You might want to try leaving the field blank for the area code. Also, set the national number length to "9".
    01-18-15 11:53 AM
  11. lideek's Avatar
    Ok. Now is ok(set to germany) but call history is stil in xx Xxx xx xx. Delete call history doesnt fix this problem. New call is still in bad format....


    Posted via CB10
    01-18-15 02:04 PM
  12. lswist's Avatar
    Any news on that issue? Has anyone resolve it.
    After upgrading to 10.3.1 also the format is wrong.
    02-20-15 04:34 PM
  13. kad6's Avatar
    Just updated my z30 to 10.3.1 and get the same problem with numbers formatting.

    Also Poland. All set right - +48 country code + 9 digits.

    Posted via CB10
    02-20-15 04:40 PM
  14. Nika Cubertin's Avatar
    same here - we've got change the country, not country settings then
    02-22-15 06:12 PM
  15. lswist's Avatar
    same here - we've got change the country, not country settings then
    Does it fix the problem? What have you done in general?
    03-05-15 05:43 AM
  16. thymaster's Avatar
    I don't know why they want to add the +1 for the USA. You don't need to dial 1 on a cell phone.
    You do. Your phone just does it automatically for you.
    03-05-15 05:56 AM

Similar Threads

  1. Snapchat on passport
    By jelle_57 in forum BlackBerry Passport
    Replies: 33
    Last Post: 02-09-15, 11:59 PM
  2. A look back on the BlackBerry Passport event in London
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 1
    Last Post: 09-30-14, 11:17 PM
  3. What's covering camera on Passport?
    By 1979dfa in forum BlackBerry Passport
    Replies: 9
    Last Post: 09-30-14, 08:58 PM
  4. Phone number formatting in Passport
    By domolsz in forum BlackBerry Passport
    Replies: 2
    Last Post: 09-30-14, 07:54 PM
  5. Replies: 2
    Last Post: 09-30-14, 06:00 PM
LINK TO POST COPIED TO CLIPBOARD