1. la_curva_scirea's Avatar
    Hey guys, recently got the Passport and i'm very happy with the phone itself, however, phone calls do not come through sometimes, and it just shows up as a missed call, regardless whether or not they are in my contact list or not, connected or not connected to wifi, vibrate or ring tone

    has anyone else had this problem?

    FYI, the sim card was cut from my previous card, which was a micro sim to fit the nano sim slot, do you guys think it could be from this that i am having a problem?

    any help would be appreciated, called t-mobile and you can guess how far that got me!
    mookieson likes this.
    11-24-14 03:12 PM
  2. Carl Estes's Avatar
    I have found that the telephone support from almost any carrier to be lacking. Best bet is to go down to your carrier storefront and have the sales rep handle your issue.
    11-24-14 03:16 PM
  3. la_curva_scirea's Avatar
    thx, will be doing that in few hrs, hopefully its a sim issue otherwise even the sales reps are clueless when it comes to bbry these days!
    11-24-14 03:17 PM
  4. doxa sub750T's Avatar
    I am also using the Passport with TMO and this happens to me too with people not in my contact list (address book). I did get a new nano sim from TMO so perhaps sim is not the issue. From thinking half cup full, I kinda like it as I have an auto call blocker kinda built in to my phone :-).

    Anyhow, I don't know how to help you and my guess is that this has to do with TMO system doesn't recognize the Passport IMEI. But this is just a pure guess. Are you sure that it happens randomly not just with people not in your address book?
    11-24-14 03:20 PM
  5. surgeon1919's Avatar
    I would buy a nano sim for the Passport. I don't know how old your micro sim is, but they have versions eg v1, v2, v3.

    By also registering a new sim on your account, you'll refresh your line.

    Posted via CB10
    11-24-14 03:22 PM
  6. la_curva_scirea's Avatar
    well it's also doing it with people on my phonebook too, but this is random! it's quite weird as never had this issue...how would i get TMO to get the Passport IMEI added? or is this not even possible?
    11-24-14 03:27 PM
  7. la_curva_scirea's Avatar
    ok yes, perhaps it is a sim issue, i hope! will keep you guys posted on how things progress with this, interesting that doxa is having same issue as well
    11-24-14 03:29 PM
  8. tfp's Avatar
    My brother-in-law is having a similar issue with his Passport on Rogers. He will get a voicemail notification and when he checks it, the call will be from 2 mins ago but nothing came through. Its a fresh sim card from Rogers, received and activated the day he got his Passport, so I don't think its a sim issue. I have a Passport on Rogers as well and I have not experience this yet, so I don't know what the problem could be.
    11-24-14 03:41 PM
  9. la_curva_scirea's Avatar
    i am running OS version 10.3.0.908, could this be the issue? maybe i'll try to load a newer version?
    11-24-14 03:48 PM
  10. freeway393's Avatar
    11-24-14 03:50 PM
  11. doxa sub750T's Avatar
    The issue happened to me on both OSs. For me wow great I now have a call blocker build into my PP!

    Again, my issue only happens with people not in my address book. I did get a new nano sim from TMO and it is brand new and fresh from the start.

    Let us know it you get yours resolved with the new sim. You could ask TMO to use your old phone IMEI as I don't think TMO can put PP IMEI into their system.

    I remember someone posted long procedures how to fix this issue actually. You will need to use Search above.

    Good luck.
    Last edited by doxa sub750T; 11-24-14 at 04:36 PM.
    11-24-14 03:53 PM
  12. freeway393's Avatar
    I had the same issue, do a quick search "missed calls voicemall" or go on the blackberry knowledge base site and look up kb36391

    Posted via CB10
    jpvj likes this.
    11-24-14 04:05 PM
  13. la_curva_scirea's Avatar
    freeway393....did the workaround correct the issue? i just followed the instructions you posted the link for, looking for someone to call me! lol
    11-24-14 04:08 PM
  14. clsaah's Avatar
    I had the same issue with my phone on T-mobile. It happened to be a sim card issue...something about not being provisioned correctly for VoLTE because the passport defaults to VoLTE and t-mobile hasn't released that technology in all the markets. I'm not a 100% sure, but the fix was to get a new sim card and everything has worked smoothly since.
    11-24-14 04:21 PM
  15. la_curva_scirea's Avatar
    ok so i guess i'll be getting a new sim regardless in addition to the workaround on the link posted by freeway393, hopefully it works out one way or the other as i use this number for business and need all calls to come through regardless

    thank you guys for all the help, much appreciated
    11-24-14 04:30 PM
  16. chrispmoto's Avatar
    Mine also seems to miss the odd call as well.
    Telus.
    Possibly from numbers not in my contacts...

    Former 9900, Z10, and Z30 user and lover, but now Passport rocker!
    11-24-14 05:14 PM
  17. tfp's Avatar
    I will try the parental control solution mentioned in the link posted later today when I have access to my brother-in-law's Passport. Hope it helps. I love being the IT department for my family lol


    Posted via CB10
    11-25-14 08:30 AM
  18. graxyq's Avatar
    You might also want to consider the possibility that the your carrier might be doing it deliberately so you make a return call.

    I say this from experience. Recently I had someone calling me while I was on another call. It did show as a missed call after I disconnected the active call, which is to be expected.

    The strange thing was when I returned the call to the same person and while I am on the call I get a call from the same guy and it shows as a missed call after I disconnect.

    Posted via CB10
    11-25-14 08:44 AM
  19. la_curva_scirea's Avatar
    Ok guys....just an update for anyone interested.....i did the workaround posted by freeway393 as well as changed my sim card and things seem to be working just fine now, not sure if it was one or the other or both, just glad it worked, as a side note, I did restore my q10 details onto my passport and maybe it had something to do with that as well in terms of not getting calls, but works now

    Posted via CB10
    11-25-14 10:36 AM
  20. la_curva_scirea's Avatar
    Also wanted to say thank u to all u guys, great help in getting this resolved

    Posted via CB10
    surgeon1919 likes this.
    11-25-14 11:06 AM
  21. surgeon1919's Avatar
    Also wanted to say thank u to all u guys, great help in getting this resolved

    Posted via CB10
    Try not to restore from a previous BlackBerry 10 device.

    Posted via CB10
    11-26-14 11:31 PM

Similar Threads

  1. Why does my red alert light not flash for some messages?
    By blackberry4good in forum BlackBerry Q10
    Replies: 5
    Last Post: 11-25-14, 01:05 PM
  2. Why is my phone stuck on agreement lines?
    By Osama Ismaile in forum BlackBerry Z10
    Replies: 0
    Last Post: 11-24-14, 02:37 PM
  3. Contact based call recording and blocking comes to Phone Tap in the latest update
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 11-24-14, 02:12 PM
  4. [Not the] Official OS 10.3.1.1151 on Z30
    By Ibegbulem Onyebuchi in forum BB10 Leaked/Beta OS
    Replies: 8
    Last Post: 11-24-14, 12:14 PM
  5. Why am I not able to get onto Facebook with my new iPad?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-24-14, 10:33 AM
LINK TO POST COPIED TO CLIPBOARD