03-14-15 10:01 PM
125 ... 345
tools
  1. kamarov's Avatar
    Something fixed the battery problem- It's one of two things because I made the changes back to back on consecutive days- Either
    - 2480/2481 OS "patch" (Passport) or
    -latest T2W Pro update.
    But now I don't "reset" the BT connection daily as I used to. Around 20% or so drain a day.

    Anyone concur with this?
    What Pebble firmware version are you on? With the latest T2W pro and 2480, I'm getting about 10 hours or so battery life.
    03-07-15 12:18 AM
  2. garpt's Avatar
    What Pebble firmware version are you on? With the latest T2W pro and 2480, I'm getting about 10 hours or so battery life.
    This one: Version: 30.0.2.5

    There were two updates in three days. Maybe you missed the second one?
    03-07-15 09:41 AM
  3. kamarov's Avatar
    This one: Version: 30.0.2.5

    There were two updates in three days. Maybe you missed the second one?
    Same version of T2W pro here, with Pebble firmware version 2.9. I hope this issue with Bluetooth is fixed soon.
    03-07-15 02:03 PM
  4. Sarek1701's Avatar
    This is why I have held off on reinstalling 10.3.1 this week. I'm on a work trip and didn't bring my Pebble charger, but with 10.3.0 it easily lasted. Hoping to find a good version this weekend to allow 10.3.1 to work with the Pebble without draining. Strange that some are able to get a good life.

    Luckily I like to tinker.

    Posted via CB10
    03-07-15 03:05 PM
  5. chrislamuk's Avatar
    Yep if you have a pebble then don't install 10.3.1!!!

    Posted via CB10
    03-07-15 04:04 PM
  6. -Puck-'s Avatar
    The latest T2W update and 10.3.1.2480 is giving me the best battery life on my pebble I have ever had...and I've been using it for over a year from my Z10 to my Passport. I'm getting 7 full days out of it now!

    I'm on my 4th day without charging my pebble and still sitting at ~50%.

     Posted in CB10 from my amazing SQUARE OG Passport 
    03-07-15 04:28 PM
  7. kamarov's Avatar
    The latest T2W update and 10.3.1.2480 is giving me the best battery life on my pebble I have ever had...and I've been using it for over a year from my Z10 to my Passport. I'm getting 7 full days out of it now!

    I'm on my 4th day without charging my pebble and still sitting at ~50%.

     Posted in CB10 from my amazing SQUARE OG Passport 
    How did you go to 2480? Flash over 2267? I'm curious if doing a wipe then doing the OTA to 2267 then 2480 will make the difference.
    03-07-15 07:24 PM
  8. -Puck-'s Avatar
    I installed with sachesi right on top of the official 10.3.1.

     Posted in CB10 from my amazing SQUARE OG Passport 
    03-07-15 08:03 PM
  9. garpt's Avatar
    The latest T2W update and 10.3.1.2480 is giving me the best battery life on my pebble I have ever had...and I've been using it for over a year from my Z10 to my Passport. I'm getting 7 full days out of it now!

    I'm on my 4th day without charging my pebble and still sitting at ~50%.

     Posted in CB10 from my amazing SQUARE OG Passport 
    Very close to what I'm getting as well on .2480. No other 10.3.1 came close (usually under a day battery.) Wonder why the discrepancy with many others?
    03-07-15 08:25 PM
  10. Sarek1701's Avatar
    I just finished installing the .2480, going to flash the Pebble firmware and see how it goes over the next few days. I'm optimistic that the issue has been fixed!
    03-07-15 08:54 PM
  11. Sarek1701's Avatar
    BTW, if I haven't said it already, thanks to garpt for keeping us all of us Pebble/Passport users up to date!
    garpt likes this.
    03-07-15 08:54 PM
  12. -Puck-'s Avatar
    Very close to what I'm getting as well on .2480. No other 10.3.1 came close (usually under a day battery.) Wonder why the discrepancy with many others?
    Yea, I'm not sure if it's the new Pebble firmware properly utilizing low power bluetooth, or the new OS files being more efficient with its bluetooth communication...but I love it!

     Posted in CB10 from my amazing SQUARE OG Passport 
    garpt likes this.
    03-07-15 10:19 PM
  13. kamarov's Avatar
    Did a security wipe, autoloader to 2267 then Sachesi to 2480. I'll see how the battery life works out to be
    garpt likes this.
    03-07-15 11:55 PM
  14. garpt's Avatar
    Yea, I'm not sure if it's the new Pebble firmware properly utilizing low power bluetooth, or the new OS files being more efficient with its bluetooth communication...but I love it!

     Posted in CB10 from my amazing SQUARE OG Passport 
    Agreed!
    03-08-15 12:41 AM
  15. garpt's Avatar
    Did a security wipe, autoloader to 2267 then Sachesi to 2480. I'll see how the battery life works out to be
    Please let us know!
    I think Passport users have seen the most success, with a few Z-10's as well. I don't believe the model however should make any difference assuming the same OS and T2W Pro version/ firmware.
    I followed the same update procedure, by the way.
    03-08-15 12:45 AM
  16. Sarek1701's Avatar
    Day 2, and both days the Pebble battery has drained to 50% by the end of the day. I'm using the current Pebble firmware and have 10.3.1.2480 installed. The only thing I can think of is that I did an in-place upgrade to 10.3.1.2267 then upgraded via Sachesi to .2480 instead of using the autoloader to .2267.

    At least my Passport isn't flickering! I will continue to tinker...
    03-09-15 07:48 PM
  17. KingRohan's Avatar
    Day 2, and both days the Pebble battery has drained to 50% by the end of the day. I'm using the current Pebble firmware and have 10.3.1.2480 installed. The only thing I can think of is that I did an in-place upgrade to 10.3.1.2267 then upgraded via Sachesi to .2480 instead of using the autoloader to .2267.

    At least my Passport isn't flickering! I will continue to tinker...
    Same issue here, but I did do the Autoloader and patched with Sachesi and my battery life is below 50% today. Big difference before upgrade, very odd issue.
    03-09-15 08:53 PM
  18. -Puck-'s Avatar
    Very strange how big the discrepancy is. I charged on day 5 at 30%. Are you leaving just T2W open, and not the Pebble app as well?

    I would try to let the battery on the Pebble run out until it turns off, then fully charge it to "reset" the battery stats. If that doesn't work, try a factory reset from the watch.

     Posted in CB10 from my amazing SQUARE OG Passport 
    03-09-15 10:16 PM
  19. Sarek1701's Avatar
    Very strange how big the discrepancy is. I charged on day 5 at 30%. Are you leaving just T2W open, and not the Pebble app as well?

    I would try to let the battery on the Pebble run out until it turns off, then fully charge it to "reset" the battery stats. If that doesn't work, try a factory reset from the watch.

     Posted in CB10 from my amazing SQUARE OG Passport 
    I did the factory reset on the watch prior to updating the Passport. Until I installed 10.3.1, I was getting close to a week's worth of battery on the Pebble. Now on 10.3.1 I'm seeing the same poor battery life I saw when I installed the leak a while ago. T2W is running, Pebble app deleted as soon as the firmware was updated. There's something in the radio file on the 10.3.1 installs killing the battery...
    03-09-15 10:22 PM
  20. kamarov's Avatar
    Battery seems better, getting about 20 hours or so on my Pebble after autoloader to 2267 then 2480.
    03-09-15 10:52 PM
  21. -Puck-'s Avatar
    I did the factory reset on the watch prior to updating the Passport. Until I installed 10.3.1, I was getting close to a week's worth of battery on the Pebble. Now on 10.3.1 I'm seeing the same poor battery life I saw when I installed the leak a while ago. T2W is running, Pebble app deleted as soon as the firmware was updated. There's something in the radio file on the 10.3.1 installs killing the battery...
    Only difference I see is that my pebble app is still installed, just not running. I get 4-5 days.

    Same .2480 OS, 2.9 pebble firmware.

     Posted in CB10 from my amazing SQUARE OG Passport 
    03-12-15 10:08 PM
  22. kamarov's Avatar
    I have a good feeling about the new 2558, few hours now and Pebble still at 100%. Passport battery also seems better with Bluetooth on.
    Sarek1701 likes this.
    03-13-15 04:04 PM
  23. Sarek1701's Avatar
    I have a good feeling about the new 2558, few hours now and Pebble still at 100%. Passport battery also seems better with Bluetooth on.
    Good to hear. I'll be pulling the trigger on. 2558 this weekend. Just noticed that the Passport battery itself wasn't lasting as long with my current OS.

    Posted via CB10
    03-13-15 10:44 PM
  24. KingRohan's Avatar
    I have a good feeling about the new 2558, few hours now and Pebble still at 100%. Passport battery also seems better with Bluetooth on.
    I have also upgraded to 2558 as well. My Pebble seems to be back to normal battery after a day of use.
    03-14-15 06:56 PM
  25. Sarek1701's Avatar
    I have also upgraded to 2558 as well. My Pebble seems to be back to normal battery after a day of use.
    After a full day, I've still got 90% battery on my Pebble. Looks like. 2558 fixed the drain after all!

    As a plus, my notification volume is back to normal as well.

    Posted via CB10
    03-14-15 10:01 PM
125 ... 345

Similar Threads

  1. Fire Chest Backup Pro - Multiple Licenses required?
    By jdanham in forum BlackBerry Z10
    Replies: 7
    Last Post: 01-02-15, 08:48 AM
  2. Why does BeWeather Pro keep crashing on my Q?
    By prplhze2000 in forum BlackBerry Q10
    Replies: 4
    Last Post: 12-24-14, 12:32 AM
  3. Hush Mail and Gmail Question
    By Noles26 in forum BlackBerry Classic
    Replies: 3
    Last Post: 12-24-14, 12:07 AM
  4. Dummy questions, change browser
    By crystal dream in forum Ask a Question
    Replies: 8
    Last Post: 12-23-14, 11:16 PM
  5. iGrann Pro gets an important update in the BlackBerry Beta Zone
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 12-23-14, 10:30 AM
LINK TO POST COPIED TO CLIPBOARD