05-28-16 12:49 AM
71 123
tools
  1. papped's Avatar
    It works on 10.3.1, but i have issues with the speed of it... Also AF can get confused pretty easily with certain types of content in the background.
    11-10-14 02:14 PM
  2. q10newguy's Avatar
    It works on 10.3.1, but i have issues with the speed of it... Also AF can get confused pretty easily with certain types of content in the background.
    I'll try that and see what happens. Mine doesn't just have a problem with auto focus, it plain won't focus at all, ever. I've never seen the square go green even manually focusing and no matter how many times I touch the screen or where it gets brighter or darker but always fuzzy.

    Posted via CB10
    11-10-14 03:37 PM
  3. Renwick's Avatar
    I'll try that and see what happens. Mine doesn't just have a problem with auto focus, it plain won't focus at all, ever. I've never seen the square go green even manually focusing and no matter how many times I touch the screen or where it gets brighter or darker but always fuzzy.

    Posted via CB10
    Exactly the same here. It worked fine from day one, and then suddenly the focus is gone.

    I've tried the following, with no luck:

    -reboot
    -hard reset
    -full device wipe
    -installing the latest 10.3.1 leak
    -installing an android app, which also uses the camera

    I got blurry images and no focus at all. Kinda pissed off... :s
    11-10-14 04:55 PM
  4. joewoo's Avatar
    Attachment 313419

    Same thing, tried different modes, HDR, flash on and off...it plain will not focus

    Posted via CB10
    Every camera has a minimum focusing distance... as in... you can only get so close before it's not in the range of being able to focus.....

    This coke shot looks like you were too close... I can't explain the phone picture though
    11-10-14 07:12 PM
  5. q10newguy's Avatar
    Every camera has a minimum focusing distance... as in... you can only get so close before it's not in the range of being able to focus.....

    This coke shot looks like you were too close... I can't explain the phone picture though
    It was about the same distance as the pic I tool while in video mode and that one turned out fine...

    Posted via CB10
    11-10-14 08:58 PM
  6. joewoo's Avatar
    It can be "about the same distance" and have different results....

    If the lens on my dslr has a minimum focus distance of 6" and I take a photo at 5.5"... it's "about the same distance" yet one results in a clear photo while the other is blurry....

    After looking at your photos again, I think that's the issue here... I bet if you take a photo outside of a building or something, it will focus just fine
    11-11-14 08:10 AM
  7. q10newguy's Avatar
    It can be "about the same distance" and have different results....
    After looking at your photos again, I think that's the issue here... I bet if you take a photo outside of a building or something, it will focus just fine
    If you guys want I can post a bunch more pics--inside, outside, night, daylight, different modes...it will not focus period. Ever. The focus box is always white, I've never seen it go green. That's why I think it's a hardware issue. I submitted a ticket to BlackBerry support so I'll see what they say...



    Posted via CB10
    11-11-14 10:57 AM
  8. Tornado99's Avatar
    Well sounds like you have a software issue since mechanics all work during video.
    Are you running a leaked os?
    You might need to restore the camera components...there were details on doing partial restores someplace on the leaked os forums.
    Or, try a complete os restore to the current official release....full security wipe.


    Flicked out via Zed30
    11-11-14 11:28 AM
  9. robitaille93's Avatar
    So do we know if this is a hardware or software problem? Interested in getting a passport but not it'll have a non-functional camera.

    Posted via CB10
    11-11-14 12:31 PM
  10. Tornado99's Avatar
    Have you confirmed there's no crude on the cam lens? What about the forward facing can, does it focus properely?


    Flicked out via Zed30
    11-11-14 01:36 PM
  11. q10newguy's Avatar
    Well sounds like you have a software issue since mechanics all work during video.
    Are you running a leaked os?
    You might need to restore the camera components...there were details on doing partial restores someplace on the leaked os forums.
    Or, try a complete os restore to the current official release....full security wipe.


    Flicked out via Zed30
    No I'm running 10.3.0.1418 downloaded OTA when I opened the box and I've tried a security wipe and didn't restore...no change

    Posted via CB10
    11-11-14 02:22 PM
  12. q10newguy's Avatar
    Have you confirmed there's no crude on the cam lens? What about the forward facing can, does it focus properely?


    Flicked out via Zed30
    I have tried cleaning the lens thoroughly and no change and I removed the protective film when I took it out of the box. The front facing camera does work just fine

    Posted via CB10
    11-11-14 02:23 PM
  13. The Big Picture's Avatar
    Are you guys using the official software?

    Posted via CB10
    11-11-14 02:36 PM
  14. zhdanovboris's Avatar
    I used official Rogers os and now got leaked. No difference to camera's focus. It's dead noway to take sharp photo or video! Looks like hardware issue. But phone didn't fall very safty usage! So sad!

    Posted via CB10
    11-11-14 04:14 PM
  15. jnak00's Avatar
    Mine is also quite bad. The rear camera will appear to focus, and then just before it takes the picture, it will suddenly adjust out of focus. Or, it takes a long time to find focus. I don't think it's a hardware problem, since it is possible to get it to focus. It's just really bad when you're trying to take a quick shot, and it takes 5 seconds for the camera to focus, and then it goes out of focus just as you hit the shutter button.
    polgara59 likes this.
    11-11-14 04:32 PM
  16. The Big Picture's Avatar
    Exactly the same here. It worked fine from day one, and then suddenly the focus is gone.

    I've tried the following, with no luck:

    -reboot
    -hard reset
    -full device wipe
    -installing the latest 10.3.1 leak
    -installing an android app, which also uses the camera

    I got blurry images and no focus at all. Kinda pissed off... :s
    Try reloading the camera. Bar file alone using Sachesi then hard reset the phone.

    Posted via CB10
    11-11-14 10:27 PM
  17. Kyle Andrei's Avatar
    I am also having camera focus issues.

    Posted via CB10
    11-12-14 10:35 AM
  18. zhdanovboris's Avatar
    Updated camera bar file nth change! Tried to use older one but same issue!

    Posted via CB10
    11-12-14 04:30 PM
  19. Renwick's Avatar
    I think for me it's definitely a hw issue, as I hear some cracking noise from the camera unit sometimes, but nothing really happens with the focus. I'll RMA my device.

    Posted via CB10
    polgara59 likes this.
    11-12-14 05:03 PM
  20. q10newguy's Avatar
    If you guys want I can post a bunch more pics--inside, outside, night, daylight, different modes...it will not focus period. Ever. The focus box is always white, I've never seen it go green. That's why I think it's a hardware issue. I submitted a ticket to BlackBerry support so I'll see what they say...



    Posted via CB10
    So I've chatted back and forth with BlackBerry a couple times now and they asked me to run through all the tests using BBVE and submit them as a first step in figuring out what's going on and it passed all the tests (even though of course the photo taken with the rear cam was blurry) except it failed the gyroscope test!! No matter how still I held the phone, even laying it on a counter and it won't register as being at rest. I noticed too when taking a video a couple times that even though I'm holding the phone completely still the screen would "bounce" around....would the gyroscope be involved in helping the camera focus?? I'm still waiting on BlackBerry to get back to me.

    Posted via CB10
    11-15-14 01:01 PM
  21. Tornado99's Avatar
    Yes! The camera has an image stabilization function. I think there is an option to shut it off in Camera settings, but there nay be some stabilization happening even when not set to on.



    Flicked out via Zed30
    11-15-14 04:37 PM
  22. q10newguy's Avatar
    Can't find an option to turn it off other than in video mode...

    Posted via CB10
    11-15-14 05:14 PM
  23. zhdanovboris's Avatar
    Hi again guyz! I got good news camera's focus alive. Looks like it's mechanical issue smth blocks focus lens. Just now my passport felt down on floor and focus start work!

    Posted via CB10
    11-22-14 10:53 AM
  24. q10newguy's Avatar
    Mine was definitely a hardware issue, got a new replacement from BlackBerry under warranty and the new one works infinitely better--I actually get a green focus square and good pictures now!! I literally had been carrying my Q around with me everywhere just for the camera which is ridiculous

    Posted via CB10
    11-22-14 12:17 PM
  25. Tornado99's Avatar
    So the fix here was to drop the phone to free up a stuck camera lens focuser!

    Reminds of the old days when folks would thump the TV to get a better picture.


    Posted via CB10
    11-24-14 12:32 PM
71 123

Similar Threads

  1. Custom wrapped my passport.
    By GP540 in forum BlackBerry Passport
    Replies: 8
    Last Post: 11-08-14, 05:09 PM
  2. Music App not working
    By Jigar Modi in forum Native BlackBerry OS Apps
    Replies: 5
    Last Post: 11-06-14, 09:57 PM
  3. Not very optimistic about getting another BB device.
    By Ishami in forum BlackBerry Q5
    Replies: 17
    Last Post: 11-06-14, 05:53 PM
  4. Google Play store running BUT not much happening
    By Robbenezer in forum BB10 Leaked/Beta OS
    Replies: 3
    Last Post: 11-05-14, 11:04 PM
  5. New Passport stock on expansys.com.
    By Marcin Ty in forum BlackBerry Passport
    Replies: 2
    Last Post: 11-05-14, 06:59 PM
LINK TO POST COPIED TO CLIPBOARD