1. rizvi88's Avatar
    Last edited by rizvi88; 11-25-14 at 02:31 AM. Reason: resolved now
    10-21-14 10:50 PM
  2. Bla1ze's Avatar
    Seems you have pretty bad luck when it comes to rebooting devices.. A Z10 and now a Passport.. personally, I'd try an autoloader instead of a straight up normal wipe but that's just me.
    10-21-14 11:33 PM
  3. zocster's Avatar
    Ok, my passport hasn't done this, you live where shopblackberry is, do a warranty claim and let us know how you go.
    10-21-14 11:34 PM
  4. Naziem13's Avatar
    Contact seller for this issue you should have warranty right.

    Z10 STL100-2/
    10-21-14 11:35 PM
  5. Bla1ze's Avatar
    I called shop blackberry today and unfortunately they don't do exchanges only refunds. My dilemma is that I received the 25% discount on this unit and I will have to purchase a new one at full retail.

    I'm waiting for the "RMA" to call me back so just waiting to hear what they say.

    Posted via CB10
    Either someone made a mistake in telling you what's going on or you misunderstood. They'll exchange the device for you. Also, unless they stupidly named some of their account managers RMA's.. RMA stands for Return merchandise authorization. So I'm gonna go out on a limb and say they'll be calling you back with info about your RMA. In which case, you should inquire again and ensure it's an exchange.
    10-21-14 11:58 PM
  6. Indo0x's Avatar
    Posted via CB10
    10-22-14 01:11 AM
  7. Naziem13's Avatar
    I think you need to make sure that this issue gets out there. So BlackBerry can listen and resolve

    Z10 STL100-2/
    10-23-14 02:26 AM
  8. whatsever's Avatar
    Only reboot I had download 32 BlackBerry application and 23 android application and at the same time straming music to my stereo. When I was browsing the internet at the same time the system shut down and start up again.

    It was to much after that no problem in 3 weeks.

    Posted via CB10
    10-28-14 06:34 PM
  9. ummie4's Avatar
    I had a random reboot once after I had the phone for a day or two. Hasn't happened since.

    Posted via CB10
    10-28-14 06:43 PM
  10. DuexNoir's Avatar
    I had a random reboot once after I had the phone for a day or two. Hasn't happened since.

    Posted via CB10
    Same here. Had only one reboot about 24 hrs after setting up the phone but haven't had any problems ever since.

    Posted using my Passport
    10-28-14 07:47 PM
  11. grover5's Avatar
    Congrats OP, glad to hear it worked out.
    10-28-14 08:01 PM

Similar Threads

  1. Selfie camera won't work now on the passport
    By unleash the Z in forum BlackBerry Passport
    Replies: 2
    Last Post: 11-01-14, 12:03 AM
  2. Q10 keeps rebooting going back to z10
    By Sandrot in forum BlackBerry Q10
    Replies: 5
    Last Post: 10-29-14, 10:24 PM
  3. Sim Card Problem (Won't fit!?)
    By BL3 in forum BlackBerry Passport
    Replies: 14
    Last Post: 10-22-14, 08:54 AM
  4. Where is the tab key on the Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-21-14, 09:38 PM
  5. Selfie camera won't start passport
    By unleash the Z in forum Ask a Question
    Replies: 1
    Last Post: 10-21-14, 09:08 PM