1. Cristian Galdini's Avatar
    Hi, i turned on my Passport again after some times,
    everything works excpets the SIM registration on carrier network.
    The SIM is recognized, it's active, the same SIM works on Z10, the carrier network name appears in the quick setting panel Network, but..
    the phone line is not working, it's not registered, symbol red (!) near che phone icon..
    I already reflashed firmware,
    has anyone had the same problem?
    any idea?
    thanks,
    any suggestions will be highly appreciated
    Cristian
    11-20-20 07:10 AM
  2. Dunt Dunt Dunt's Avatar
    My idea is the dreaded no Service issue that Passports seem to develop when antenna connections... break.

    If your up of opening it up and doing so soldering there is a resolution.
    11-20-20 08:17 AM
  3. Cristian Galdini's Avatar
    Thanks a lot, it make sense.
    Actually, the network is found, so I was not thinking about an antenna problem
    11-20-20 08:25 AM

Similar Threads

  1. rad.io app for BlackBerry 10 not working?
    By truth4u in forum BlackBerry 10 OS
    Replies: 18
    Last Post: Yesterday, 05:54 PM
  2. Replies: 8
    Last Post: 11-17-20, 04:28 PM
  3. Passport: cannot open doc or pdf in WhatsApp
    By Ellyott in forum BlackBerry Passport
    Replies: 0
    Last Post: 11-16-20, 09:30 AM
  4. No Signal Bars on my Blackberry Passport
    By Shanmukh Gudivada in forum BlackBerry Passport
    Replies: 9
    Last Post: 11-15-20, 04:20 AM
  5. Bb passport Keypad ic problem
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-13-20, 04:17 PM
LINK TO POST COPIED TO CLIPBOARD