1. Cameron Mitchell5's Avatar
    BlackBerry has done nothing about this known issue since October 2015. BlackBerry 10 smartphone loses signal strength or experiences dropped calls
    11-09-16 08:02 AM
  2. coffee-turtle's Avatar
    This has anything to do with the carrier, by any chance?
    11-09-16 11:58 AM
  3. KemKev's Avatar
    This has anything to do with the carrier, by any chance?
    Interesting question. I am on the Rogers network and the signal issue has become a bit worse lately. I have experienced dropped calls in the middle of calls and it is not unusual for me to see "Emergency Calls Only" every now and again in areas where there should be no issue. Recently I was in a location where everyone with iPhones and Androids were able to access their cellular network; my PP had the steady message "Searching for network...." and it did so unsuccessfully.
    11-09-16 03:49 PM
  4. coffee-turtle's Avatar
    Not sure what the other people were connected to at the time, but I would suggest you contact Rogers and see if they can troubleshoot, or at the very least, re-register your phone Over-The-Air.
    11-10-16 08:12 AM
  5. Voja Markovic's Avatar
    i switched to 4g as i got my pp and the signal was weak to non existing. i am on t mobile. since i switched to 3g the signal is fantastic even underground.

    Posted via CB10
    11-10-16 09:06 AM
  6. Ginacn's Avatar
    I have the same problem and I didn't even change carries nor the sim same old sim that actually works with others divides. And tried other sims and the same happens.

    It's definitely the Passport

    Posted via CB10
    11-11-16 08:19 AM
  7. jaglenn's Avatar
    I was told it is a problem with Rogers LTE. So I went in and took LTE off. Works good!


    Jaglenn's Passport
    11-11-16 06:25 PM
  8. Walter Rubin's Avatar
    My Blackberry Passport's network connection has been non-existent or quite sporadic for last three months. Of course I could use wi-fi where available but I've been carrying a flip phone around with me so I could get calls since I've had no phone service. Even when my phone said 4GLTE I wasn't able to get internet or phone. Tried security wipe, hard and soft resets, turning airplane mode on and off, replacing Sim card three times. I was worried maybe defective sim tray or antenna problem. T-Mobile suggested reinstalling operating system. I didn't know that a security wipe and reinstalling the Blackberry 10 operating system were not the same. That did the trick-except for indoor my apartment house-which can be corrected with free Cellspot router from T-Mobile. Before reinstalling the OS make sure you have complete backup on Link so you can restore everything when done-apps, photos etc.

    Posted via CB10
    11-12-16 09:53 AM
  9. Ginacn's Avatar
    I have the same problem but I'm not even in the US nor Canada.

    So I don't know what to think
    11-13-16 02:41 PM
  10. coffee-turtle's Avatar
    I have the same problem and I didn't even change carries nor the sim same old sim that actually works with others divides. And tried other sims and the same happens.

    It's definitely the Passport

    Posted via CB10
    Some carriers require you to notify them when you swap SIM into another phone. I would not conclude it is the device.

    Another poster in this thread, however, said that reinstalling their OS did the trick.

    I like my coffee  BlackBerry black! What?
    11-14-16 04:31 PM
  11. Walter Rubin's Avatar
    Blackberry users on T-Mobile's network will be experiencing non-service or sporadic service at best till at least Mid-January as the carrier is doing a massive updating of their towers as per their tech support expert I spoke to today. So just changing sim cards, reloading operating systems etc. won't solve any Emergency Calls Only or no network found warnings. Or sometimes I seemed to be on 4GLTE yet no phone or Internet.

    Posted via CB10
    11-15-16 02:09 PM
  12. kingofkerry's Avatar
    Some carriers require you to notify them when you swap SIM into another phone. I would not conclude it is the device.

    Another poster in this thread, however, said that reinstalling their OS did the trick.

    I like my coffee  BlackBerry black! What?
    I have the same problem with my Passport. It only started 2 weeks ago and I thought it must be a network fault, but I put my sim into my old Q10, using a sim card adapter and it's working fine - no problem with signal. Therefore there must be a hardware fault with my passport..
    11-15-16 02:19 PM
  13. Ginacn's Avatar
    Already done both.

    No luck
    11-17-16 04:21 PM
  14. Vistaus's Avatar
    I have the same problem but I'm not even in the US nor Canada.

    So I don't know what to think
    Same here (not in Canada or the USA either). Most of the time it works fine but sometimes it randomly loses the connection in certain places in my *city* (!). Gonna test with my trusty Motorola Razr V6 Maxx as well to see if it's a black spot issue. If not, then it really is a BB10 issue.

    Posted via CB10 using my amazing  Passport (OG Red) <3
    11-17-16 11:54 PM
  15. Ginacn's Avatar
    I now have issues with the prepaid sim I use with a 9790 so I called the carrier and they say it's BlackBerry's platform not being supported no more
    11-19-16 07:19 PM
  16. Allan Milo's Avatar
    Anyone have this problem whiler on the Att&T network?

    Posted via CB10
    11-19-16 11:08 PM
  17. spacemanZ10's Avatar
    My original passport started loosing signal till it got nothing. I tried different sim cards but they worked fine in other phones. The replacement is better, but doesn't get signal in all areas my original one did. Glad it's not just me.

    Swiped on my Passport!
    11-20-16 08:21 AM
  18. spacemanZ10's Avatar
    Btw I'm in UK on three.

    Swiped on my Passport!
    11-20-16 08:22 AM
  19. Vistaus's Avatar
    Same here (not in Canada or the USA either). Most of the time it works fine but sometimes it randomly loses the connection in certain places in my *city* (!). Gonna test with my trusty Motorola Razr V6 Maxx as well to see if it's a black spot issue. If not, then it really is a BB10 issue.

    Posted via CB10 using my amazing  Passport (OG Red) <3
    So I've just tested it out in a few of the places where the network connection (and other connections) gets lost and it does seem like a BB10 issue 'cause the issue didn't occur with my aforementioned Motorola Razr V6 Maxx. Same spots, same sim card, same carrier... so BB10's the culprit (I guess).

    Posted via CB10 using my amazing  Passport (OG Red) <3
    11-21-16 05:53 AM
  20. si001's Avatar
    Well you can read that, your not alone.

    https://supportforums.blackberry.com...ls/m-p/3182922
    11-21-16 06:22 AM

Similar Threads

  1. Passport Clone
    By hamitako in forum BlackBerry Passport
    Replies: 9
    Last Post: 11-14-16, 12:47 PM
  2. BB Passport default texts to BB messenger?
    By ego_sum_spartacus in forum Ask a Question
    Replies: 1
    Last Post: 11-09-16, 07:39 AM
  3. Passport & WiFi
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 11-08-16, 03:11 PM
  4. Where can I try a BB Passport before I purchase one
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 11-08-16, 02:01 PM
  5. Replies: 6
    Last Post: 11-08-16, 12:36 PM
LINK TO POST COPIED TO CLIPBOARD