1. gsm_dealer08's Avatar
    After 3 years of android I've decided to switch back to BlackBerry. Loved the look of the passport from the first time i've seen it on display so I finally gave in and bought one. I still have half a year of my contract with Three UK network and they don't sell BlackBerry. My only option was to buy one myself. Got mine from eBay from this woman saying she got it for free for continuing her contract with O2. The phone was as new when it arrived but from day one I've noticed the 4G signal is much much lower than it was on my zperia z2. I have H+ signal on full bars most of the times but I rarely get 4G and when I do,it's one bar and it goes away after a few seconds. In the settings the network is set to 2g/3g/4g. I've even called Three for advice and they said there is nothing in my account that would prevent me to have 4G and told me to try a factory reset. Any of you had the same problem? I've spent days setting up the device to be exactly how I like it and having to reset it and do it all over again seems such a pain. Any advice? I live in London by the way and the 4g reception is very good

    Posted via CB10
    11-27-15 02:52 AM
  2. BerrySoul's Avatar
    I have excellent reception 4g + and LTE in my passport SE. No issues with mine.

      
    11-27-15 02:59 AM
  3. so crow's Avatar
    Also I'm in the uk with three and have no problems with 4g etc on my red passport.

    Posted via CB10
    11-27-15 04:21 AM
  4. daveshiz's Avatar
    No probs in bonny scotland with 4g. With vodafone on my se passport

    Posted via CB10
    11-27-15 05:29 AM
  5. gsm_dealer08's Avatar
    I'll try another SIM from a friend that's on Three to see if it's any difference

    Posted via CB10
    11-27-15 05:57 AM
  6. gsm_dealer08's Avatar
    A workmate has a Q10 so I tried my SIM card in his phone and it turns out his has the same network coverage. 1 or 2 bars of 4g then back to H+. It is either a problem with my SIM or with Three in this area. I will try a different Three sim later

    Posted via CB10
    11-27-15 07:00 AM
  7. gsm_dealer08's Avatar
    I stopped by the Three shop on my way home last night and a very arrogant lady there told me that there is nothing wrong with the network and it is my device that is causing the problem. But when I arrived home I checked my friend's Three reception on his iPhone and it was exactly as mine. He said that 4g has been really bad lately. So it has nothing to do with the BlackBerry

    Posted via CB10
    11-28-15 03:00 AM

Similar Threads

  1. Priv or BlackBerry Passport silver edition
    By Blackburberry_priv in forum BlackBerry Priv
    Replies: 31
    Last Post: 04-06-16, 01:40 PM
  2. Is the original Passport battery similar to Silver Edition?
    By chicofehr in forum BlackBerry Passport
    Replies: 12
    Last Post: 03-09-16, 12:03 AM
  3. Love the Priv. Kept the Priv. Sold my Passport.
    By naijab0y in forum BlackBerry Priv
    Replies: 31
    Last Post: 01-11-16, 10:49 PM
  4. Help! My Passport is stuck and nothing will load, what do I do?
    By sonieee in forum BlackBerry Passport
    Replies: 21
    Last Post: 12-03-15, 01:10 AM
  5. Having Problems with Blend and Passport
    By okayito in forum BlackBerry Blend
    Replies: 1
    Last Post: 11-26-15, 09:30 PM