1. stevewoodrow11's Avatar
    Hi all - bit of a weird one as I know WiFi issues can be down to so many reasons but I have an old router which I have used to boost the signal upstairs. The thing is my BlackBerry passport doesn't seem to choose the strongest AP (ie when I am downstairs) however my Z10 does. Both are running the latest leak OS (I appreciate a leak could be the cause) but it's just odd it is only affecting the Passport.

    Could this be down to the Passport radio perhaps?

    I have done the usual steps of rebooting devices and routers, deleting and re adding the wifi profile etc.

    I don't recall having this issue previously so am thinking OS or radio.

    All advice appreciated as this community is great.

    Posted via CB10
    03-23-15 02:51 PM
  2. stevewoodrow11's Avatar
    Yeah I have same SSID and the inter access point handover set.

    Interesting point about retaining the current AP - thanks for the help, much appreciated.



    Posted via CB10
    03-23-15 06:02 PM
  3. quangtran1's Avatar
    A device usually does not seek for a new AP unless the current connection reaches a certain low threshold. That's why one should reduce transmission power of an AP in the overlapping zone. If possible, reduce the transmission power of your upstairs AP just to sufficiently cover upstairs. I deal with high end Meraki APs all day long. I have to reduce signal on these to create a livable mesh network environment.
    03-23-15 06:25 PM
  4. Viet Ton's Avatar
    It should switch to what you set as priority in you wifi list. Open wifi settings, see in saved and prioritize them as you desire.

    Posted via my BlackBerry Passport - 10.3.1.2576
    03-23-15 06:38 PM
  5. quangtran1's Avatar
    However, it does not automatically switch until the current AP is out of range. The priority list only comes into play when both APs are in reach, then a device will make selection based on the preferred order. Different devices have different roaming aggressiveness and hand-off amplification thresholds. When the new 802.11r standard comes out in July, it will drastically reduce hand-off delay to remedy this very problem.
    Last edited by quangtran1; 03-23-15 at 07:43 PM.
    03-23-15 07:32 PM
  6. anon(679606)'s Avatar
    I have seen this before on other wifi devices. Some radios are so avid to the signal the result is a reluctance to release to another despite strength advantage... I don't know why ?? Lurking can yield quite an education.
    03-31-15 08:58 PM
  7. RA-HA's Avatar
    I can offer no solution, but a similar problem. When I restart the Passport while I'm in the room where the router is, it connects on network type ac with 4xx Mbps. When I then leave the room and walk around the house it drops to n with 72 Mbps which is probably ok.

    However when I then return to the room with the router it never switches back to ac, not even when I leave it sitting there over night. If I want ac back I'll have to restart the device.

    Anybody an idea on this one? Thanks!
    04-01-15 12:23 AM
  8. quangtran1's Avatar
    As I've previously stated, this is not uncommon. Wifi devices are behaving as they were designed: A wifi device will not seek another hotspot if it's already connected. This is the case with a, b, or n. When these standards were created, the 801.11 consortium didn't think of elaborate multi-zone re-entries. The new standard 801.11r will handle this. In the mean time, what we need to do is creating a wifi environment in which the dead zone can be detected sooner. One, you can reduce transmission power of your routers so your phone can "lose" that connection sooner, so that it can begin the renegotiation process with the 2nd router sooner. Two, you can purchase 2 routers that have built-in capability to create a mesh network. Also, keep in mind that every device has a different threshold for "loss-to-renegotiate". That's why people say "Well, I don't have any problem with my laptop or iPad, etc".
    Last edited by quangtran1; 04-01-15 at 05:10 AM.
    04-01-15 04:36 AM
  9. RA-HA's Avatar
    My bad I guess. I should have been clearer (or should have opened a new thread which I didn't feel was necessary).

    I only have ONE router. That's why I said my problem is similar to the one that's actually being discussed here.

    My problem is that the PP doesn't switch back to ac when I move back closer the router.

    Again, sorry if I created any confusion.
    04-01-15 09:42 AM
  10. quangtran1's Avatar
    My bad I guess. I should have been clearer (or should have opened a new thread which I didn't feel was necessary).

    I only have ONE router. That's why I said my problem is similar to the one that's actually being discussed here.

    My problem is that the PP doesn't switch back to ac when I move back closer the router.

    Again, sorry if I created any confusion.
    Are you saying your device does not switch from mobile data to wifi?
    04-01-15 10:09 AM
  11. RA-HA's Avatar
    No Sir. I'm talking about different wifi network types. Initially when I'm near the router and turn on the PP, it connects to the router using the faster network type AC. When I then leave the room, the connection obviously gets worse, and the connection type switches to N. However when I then go back near the router, it doesn't switch back to AC.

    No big deal really, I guess. Was just wondering.
    04-01-15 01:23 PM

Similar Threads

  1. Replies: 2
    Last Post: 07-02-15, 02:18 AM
  2. Passport Email Issue
    By MiSsY_ in forum Ask a Question
    Replies: 4
    Last Post: 03-25-15, 12:11 PM
  3. Is the Red Passport Really Worth $100 more?
    By nucks26 in forum BlackBerry Passport
    Replies: 29
    Last Post: 03-24-15, 10:39 AM
  4. BBM video does not function
    By jackyjunaid in forum Ask a Question
    Replies: 3
    Last Post: 03-24-15, 12:03 AM
LINK TO POST COPIED TO CLIPBOARD