1. Stephen Severino's Avatar
    So I have my Passport running on Metro PCS, and I'm in Bergen County, NJ.

    When I'm at work in Union County, I get 4G LTE (the BlackBerry symbol shows up on the signal bar next to 4G.)

    When I'm in Bergen County, I get only 4G. No LTE. No Blackberry symbol.

    Voice works fine in both regions. But data does not work at all around my home. I can't get text messages at all, and can only use internet apps when connected to WiFi.

    Any idea why this could be? Why can I get a 4G connection but not get data?
    06-13-15 08:35 PM
  2. masterscarhead1's Avatar
    So I have my Passport running on Metro PCS, and I'm in Bergen County, NJ.

    When I'm at work in Union County, I get 4G LTE (the BlackBerry symbol shows up on the signal bar next to 4G.)

    When I'm in Bergen County, I get only 4G. No LTE. No Blackberry symbol.

    Voice works fine in both regions. But data does not work at all around my home. I can't get text messages at all, and can only use internet apps when connected to WiFi.

    Any idea why this could be? Why can I get a 4G connection but not get data?
    Have you tried calling at home? Usually when there's no BB symbol it suggests the connection is so weak. You might not actually have any functional signal at all.
    06-13-15 08:51 PM
  3. Stephen Severino's Avatar
    As I said, voice works. No problems with that.

    But if the BlackBerry symbol indicates signal strength, shouldn't I still get at least some data?

    Posted via CB10
    06-13-15 08:54 PM
  4. RoseBud68's Avatar
    Metro POS.....
    06-13-15 08:59 PM
  5. emanuel0ss0's Avatar
    I'm actually shocked that you could activate it on Metro. When I took my Z10 to them, they said they couldn't activate it. When I contacted them on twitter, they said that no bb's could be activated on their network.

    Posted via my awesome Red Passport SQW100-1/10.3.2.680 with T-Mobile Unlimited Data
    06-14-15 12:30 AM
  6. Stephen Severino's Avatar
    So this issue has been sorted.

    When I first got the phone, I was on T-Mobile, then switched to Metro. Apparently, putting in a new SIM did not change the APN information. Changing it to Metro's seemed to do the trick.

    Posted via CB10
    06-14-15 04:40 AM
  7. Stephen Severino's Avatar
    I'm actually shocked that you could activate it on Metro. When I took my Z10 to them, they said they couldn't activate it. When I contacted them on twitter, they said that no bb's could be activated on their network.

    Posted via my awesome Red Passport SQW100-1/10.3.2.680 with T-Mobile Unlimited Data
    I didn't take the phone into their store. I bought a SIM card from them and had it sent to me, then called them up to activate it. They never asked what type of phone it was. I just told them the IMEI number.

    Posted via CB10
    06-14-15 04:42 AM
  8. danp2000's Avatar
    I'm actually shocked that you could activate it on Metro. When I took my Z10 to them, they said they couldn't activate it. When I contacted them on twitter, they said that no bb's could be activated on their network.
    It's amazing how poorly trained and/or uninformed some wireless carrier people are. They think you need BlackBerry Services when you don't.

    If they ask the type of phone just tell them it's an Android. It's not lying since you do have an Android Runtime.

    T-Mobile  вιaсĸвεггч Passport Autoloaded 10.3.1.2582 Sachesi up to 10.3.1.2744 to 2.680 to 2.798 to 2.2204
    06-14-15 07:31 AM
  9. DeRedder's Avatar
    As I said, voice works. No problems with that.

    But if the BlackBerry symbol indicates signal strength, shouldn't I still get at least some data?

    Posted via CB10
    Don't listen to the guy who you responded to, a BlackBerry symbol has nothing to do with signal strength,
    06-14-15 09:29 AM
  10. shotgunboss's Avatar
    Don't listen to the guy who you responded to, a BlackBerry symbol has nothing to do with signal strength,
    yes actually they do relate depending on where one lives, I ran into this issue yesterday, I had somewhat of a signal and no BlackBerry logo, once I got a stronger signal it reappeared
    06-14-15 11:33 AM
  11. trigger1074's Avatar
    Metropcs is Tmobile. Passports work fine, the rep just need to select Android when they select the device.

    Posted via CB10
    06-14-15 03:46 PM
  12. masterscarhead1's Avatar
    Don't listen to the guy who you responded to, a BlackBerry symbol has nothing to do with signal strength,
    Don't listen to ^ this guy haha. Try stepping into an elevator and see what happens. Your bars are still there, but BB symbol disappears because there's no effective connection
    06-14-15 03:57 PM
  13. Al moon's Avatar
    I thought the symbol meant you were connected to BlackBerry servers I've had it disappear and the browser would work fine however BBM wouldn't

    Posted via CB10
    06-14-15 04:18 PM
  14. SpamHammer's Avatar
    I'm actually shocked that you could activate it on Metro. When I took my Z10 to them, they said they couldn't activate it. When I contacted them on twitter, they said that no bb's could be activated on their network.

    Posted via my awesome Red Passport SQW100-1/10.3.2.680 with T-Mobile Unlimited Data
    It's BS from their reps. They're referring to the old BlackBerry OS phones that required a BIS data plan. Modern BBs are like standard phones - no special data required. So long as you just get a SIM card or feed them an old IMEI, then there is no issue using a BlackBerry.
    06-14-15 07:53 PM

Similar Threads

  1. Anyone's flashlight and camera stopped working?
    By d987654321 in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 06-13-15, 08:14 PM
  2. Android apps mobile data dont workin my z10
    By olger duci in forum Android Apps (Amazon Store & APK Files)
    Replies: 0
    Last Post: 06-13-15, 06:57 PM
  3. Snapchat Client that works! Casper
    By Josh Garrow in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 06-13-15, 06:27 PM
  4. BBM Invitation via SMS doesn't work
    By Loc22 in forum General BBM Chat
    Replies: 0
    Last Post: 06-13-15, 04:48 PM
  5. Deleted wrong language files with Sachesi, which do I need?
    By lycan666 in forum BlackBerry 10 OS
    Replies: 0
    Last Post: 06-13-15, 01:48 PM
LINK TO POST COPIED TO CLIPBOARD