1. parthodas's Avatar
    My device was recently updated to 10.3.2.2474. After that my device keyboard is not working properly. I can swipe & scroll with the keyboard. But the characters are not typing. Also, when I unlock my phone, Assistant would pop up. Closing the Assistant, then BBM would pop up. This happens every time.
    I restarted my phone multiple time. I restarted by pressing volume up & down keys together. I drained the battery completely and then started again. But nothing helped. Anyone facing similar issue. Or is there any solution, please let me know.
    09-14-15 01:51 AM
  2. Fool Guy's Avatar
    Device wipe may help else try Autoloader.
    With both of options loss of data happens so take backup.
    09-14-15 02:43 AM
  3. rebroker2009's Avatar
    Reload the OS

    Blackberry Passport running 10.3.2.2639
    09-14-15 02:56 AM
  4. parthodas's Avatar
    I am trying to avoid the full wipe or factory restore. If there's no solution then will go with that.
    Last edited by parthodas; 09-15-15 at 02:31 AM.
    09-14-15 03:12 AM
  5. nimra's Avatar
    I updated and a fews after did a full reload over link and installed all 3 party apps newly...

    Now it seems to me specially the scrolling with the pkb is kind of hubby jumpy.. not that smooth anymore

    Anybody experienced something similar?
    Any suggestions?

    Posted via CB10
    09-21-15 02:11 AM
  6. i_plod_an_dr_void's Avatar
    Acquaintence just came across similiar problem....keyboard lights up, and the gestures all work...just that none of the key presses register. Keyboard stopped working. His problem is that he can't get past the password entry because the keyboard doesn't work. Will he be able to use BlackBerry link to recover his personal files before attempting a reinstall of the os? (He thought maybe there was an update to the phone about the time it failed, (last week) but he doesn't think he selected it to load...maybe it did so automatically...so he just doesn't know.)
    09-24-17 10:12 PM
  7. i_plod_an_dr_void's Avatar
    Oh and embarassed to say, he never bothered to install link or backup any of his phone's data regularly or even at all....grant it he's a busy person and didn't get to it. Any suggestions to solve his problem? Is it as easy as intalling link ...does it have to be pre-windows 10, are windows 8 or xp fine to install link on?
    09-24-17 10:27 PM
  8. skyscout's Avatar
    My Passport's OS = 10.3.3.1435
    which works just fine.

    Posted via CB10
    09-25-17 12:31 PM
  9. skyscout's Avatar
    Oops! That is software version.

    The OS = 10.3.3.2163


    Posted via CB10
    09-25-17 12:39 PM
  10. Niallac's Avatar
    Oh and embarassed to say, he never bothered to install link or backup any of his phone's data regularly or even at all....grant it he's a busy person and didn't get to it. Any suggestions to solve his problem? Is it as easy as intalling link ...does it have to be pre-windows 10, are windows 8 or xp fine to install link on?
    Dunno about 8, should be fine though, I thought I was the only person in the world (except the Royal Navy) left using Windows XP.

    If he can get Link running and the device connected, and remember the device password, yes, your 'acquaintance' should be able to back up... Tell 'them' not to backup system settings though, only user data, and certainly don't attempt to restore old-version settings onto a newer OS.

    Once it's backed up, reinstall the OS from autoloader or Link. Please thoroughly research the issues around 10.3.3 on passport (search 'passport emergency calls only') before taking the plunge.

    When you are ready to restore your Link backup, take care only to restore user data. If you restore old-version settings (particularly corrupted ones like in this case) onto a newer OS version, you run the risk of going right back to square one.

    Posted via CB10
    09-25-17 02:49 PM
  11. i_plod_an_dr_void's Avatar
    Dunno about 8, should be fine though, I thought I was the only person in the world (except the Royal Navy) left using Windows XP.

    If he can get Link running and the device connected, and remember the device password, yes, your 'acquaintance' should be able to back up... Tell 'them' not to backup system settings though, only user data, and certainly don't attempt to restore old-version settings onto a newer OS.

    Once it's backed up, reinstall the OS from autoloader or Link. Please thoroughly research the issues around 10.3.3 on passport (search 'passport emergency calls only') before taking the plunge.

    When you are ready to restore your Link backup, take care only to restore user data. If you restore old-version settings (particularly corrupted ones like in this case) onto a newer OS version, you run the risk of going right back to square one.

    Posted via CB10
    Not to leave this "passport physical keyboard not working problem" as a cliff-hanger. My BUSY acquaintance who still hadn't found time to load LINK for an OS refresh.....reported to me in the last little while....that VOILA... the Keyboard works again! ....all he did was give it time to fully discharge its battery he thinks on a not-fully charged device to begin with. Wow that took a really long time to do! I guess that's kudos to the BlackBerry's work-all day batteries in the BB10 Passport.

    What was the procedure again to mimic pulling your battery out of the device and back in again....when powering off (or on) It involved key pressing for some number of seconds? He probably could have used that procedure instead? I remember way back in the STORM or that pre-priv slider, forgot the name...pulling the battery, and it solved the rare hanging hiccups (only had to do it once, as i recall).

    If no one believes that could have solved the problem, then perhaps he got the keyboard wet/damp? and it took this long to properly dry-out? Though that seem far-fetched, he thinks he may have done that some weeks earlier, though it worked fine in the intervening weeks....my bet is the battery drain...unless some app got hung and froze the keyboard, and didn't let go until a complete power drain?
    09-29-17 01:49 PM
  12. Mark bb10's Avatar
    You can press and hold the volume up and down keys at the same time until you see the BlackBerry logo come up then let go then that will be a hard reset done.

    Posted by my majestic Passport........"and like that.........he's gone"....
    i_plod_an_dr_void likes this.
    09-29-17 06:53 PM
  13. Zdravko Jesus Raves's Avatar
    I had this problems, same and found solution, it's not about software, just open the phone and clean contacts on board and keyboard jack, after that working like new

    Posted via CB10
    i_plod_an_dr_void likes this.
    09-30-17 12:21 PM

Similar Threads

  1. Very Happy with Passport
    By weiberry in forum BlackBerry Passport
    Replies: 29
    Last Post: 09-15-15, 11:24 PM
  2. Passport Freezes
    By Bfalcon1 in forum BlackBerry Passport
    Replies: 3
    Last Post: 09-14-15, 05:35 PM
  3. Speaker not working after update
    By aiken7 in forum BlackBerry Z10
    Replies: 2
    Last Post: 09-14-15, 05:57 AM
  4. Can I get some help with my sim in my BlackBerry Passport?
    By roshni sursh in forum BlackBerry Passport
    Replies: 1
    Last Post: 09-14-15, 02:23 AM
  5. Replies: 6
    Last Post: 09-13-15, 11:34 PM
LINK TO POST COPIED TO CLIPBOARD