1. denverbarr's Avatar
    Hey, I got my passport a few days ago and really like it! So far the only issue is that about once a day the keyboard light stops working (Seems to be the sensor, as others have had) and a reboot temporally fixes it. However, each day without fail this has occurred. I was on the os that supposedly fixed the issue and I'm currently on 10.3.1.1016.

    Any suggestions?

    Denver
    10-30-14 11:38 PM
  2. byex's Avatar
    Did you run BBVE app and do a sensor test? Sensors are more than likely failing.

    Did you load a backup from another BlackBerry 10 device that was an OS less than 10.3 on to your passport?

    Posted via CB10
    10-30-14 11:44 PM
  3. denverbarr's Avatar
    I did run the BBVE app and yea it says they fail. I'm not sure what you mean about the backup, the phone came with a 10.3.something-or-other and I updated it to a newer one. Nothing on it has been lower that what it initially came with.
    10-30-14 11:48 PM
  4. byex's Avatar
    I did run the BBVE app and yea it says they fail. I'm not sure what you mean about the backup, the phone came with a 10.3.something-or-other and I updated it to a newer one. Nothing on it has been lower that what it initially came with.
    Sorry I meant did you do a data transfer from your other BlackBerry 10 phone if you had one?
    Or your setup on the passport was from scratch. As in no old data or settings were migrated.

    Posted via CB10
    10-30-14 11:56 PM
  5. denverbarr's Avatar
    Sorry I meant did you do a data transfer from your other BlackBerry 10 phone if you had one?
    Or your setup on the passport was from scratch. As in no old data or settings were migrated.

    Posted via CB10
    The Passport is my first BB10 device.
    10-30-14 11:58 PM
  6. byex's Avatar
    The Passport is my first BB10 device.
    When I had this problem I returned the phone for another unit. My new unit kept doing the same thing. As per some of the advice here I didn't migrate any data from my previous BB10 phone and it's been fine.

    In your case you could exchange it for another unit if your purchase policy allows it. If not you could possibly do a security wipe and start from scratch again. That would be the last resort and unless someone has another recommendation.

    There's been no definite answer here as to why the sensors are failing. Some have documented their experience with this issue on the forum.

    Posted via CB10
    10-31-14 12:12 AM
  7. denverbarr's Avatar
    When I had this problem I returned the phone for another unit. My new unit kept doing the same thing. As per some of the advice here I didn't migrate any data from my previous BB10 phone and it's been fine.

    In your case you could exchange it for another unit if your purchase policy allows it. If not you could possibly do a security wipe and start from scratch again. That would be the last resort and unless someone has another recommendation.

    There's been no definite answer here as to why the sensors are failing. Some have documented their experience with this issue on the forum.

    Posted via CB10
    I'll give Telus a shout. In fact they are now completely unavailable and reboots are no longer "fixing" them.
    10-31-14 12:16 AM
  8. Jaybird9520's Avatar
    Having the same issue on an intermittent basis with my passport as well. A reboot usually fixes the issue, but it rather annoying. I'm hoping that it's a software issue that can be rectified with an update. Has there been any official word from BlackBerry about this?

    Posted via CB10
    10-31-14 12:30 AM
  9. byex's Avatar
    I'll give Telus a shout. In fact they are now completely unavailable and reboots are no longer "fixing" them.
    Telus is where I exchanged mine. Was real quick and simple. Just explained the issue and they created an RMA for the unit and issued a new one on the spot.

    Posted via CB10
    10-31-14 01:10 AM
  10. denverbarr's Avatar
    Telus is where I exchanged mine. Was real quick and simple. Just explained the issue and they created an RMA for the unit and issued a new one on the spot.

    Posted via CB10
    Thats really promising! Thanks for your help man! Do i need to bring anything aside from the phone?
    10-31-14 01:22 AM
  11. Taigatrommel's Avatar
    I have to say something appears to ne quite strange with the Passport's ambient light sensor and keyboard backlight. There are too many threads regarding a backlight that doesn't work at all or, just in my case, simply stays on virtually all the time. My first unit didn't show this. Already rebooted, tried BBVE and everything works as it should there regarding the sensors. I guess the software adjusting the keyboard light is somehow fcked up.

    Posted via CB10
    10-31-14 02:37 AM
  12. byex's Avatar
    Thats really promising! Thanks for your help man! Do i need to bring anything aside from the phone?
    Just make sure you wipe the phone. If you're on a plan with Telus it will be fine. If you bought it outright also bring the receipt.

    Posted via CB10
    10-31-14 08:07 AM
  13. denverbarr's Avatar
    Just make sure you wipe the phone. If you're on a plan with Telus it will be fine. If you bought it outright also bring the receipt.

    Posted via CB10
    Just got it swapped at a telus store. Pretty easy. However, either now i'm paranoid or I have the worst luck as the space bar seems really loose. Like it creaks if you slide your finger across it. Not normal correct?
    10-31-14 01:41 PM
  14. byex's Avatar
    Just got it swapped at a telus store. Pretty easy. However, either now i'm paranoid or I have the worst luck as the space bar seems really loose. Like it creaks if you slide your finger across it. Not normal correct?
    No not normal at all. The keys should be tight. I don't have that with any of my keys.
    Try it out for a few days and see if the problem persists. If it does you can always exchange it.

    Posted via CB10
    10-31-14 05:21 PM
  15. Mo Alsharaf's Avatar
    Hey, I got my passport a few days ago and really like it! So far the only issue is that about once a day the keyboard light stops working (Seems to be the sensor, as others have had) and a reboot temporally fixes it. However, each day without fail this has occurred. I was on the os that supposedly fixed the issue and I'm currently on 10.3.1.1016.

    Any suggestions?

    Denver
    Keeping in mind, moving from highly or normal lit area to a dark space can delay the illumination sensor, also extreme cold temp can cause the sensor act erratically, but the solution is to double tap or cover the "almost invisible" sensor above the BlackBerry (the fruit) symbol and the keyboard will illuminate.
    12-04-14 06:03 PM
  16. pamarnani's Avatar
    Hi do you know if an OS update resolves this problem?

    Posted via CB10
    02-19-15 05:09 PM

Similar Threads

  1. Uneven black lit keyboard lights
    By mona5804 in forum BlackBerry Passport
    Replies: 20
    Last Post: 03-30-15, 08:43 AM
  2. Replies: 2
    Last Post: 11-05-14, 01:57 AM
  3. 2 weeks in with the Passport, I booted up my Q10
    By Lemster81 in forum BlackBerry Passport
    Replies: 5
    Last Post: 11-01-14, 07:56 PM
  4. keyboard phone
    By Sebyoo in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 11-01-14, 07:53 AM
  5. Why don't I have audio in my headset on my Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 10-30-14, 10:05 PM
LINK TO POST COPIED TO CLIPBOARD