1. Jasonn Brantley's Avatar
    Has anybody experienced keyboard lag when typing?

    Sometimes when I'm typing my Passport can't keep up with my typing and will miss a handful of letters I've typed.
    Anybody else experiencing this, any work around, or just a minor bug?

    It's pardonable like my Q10s double letter issue, but if there's a work around, that would be great.

    Thanks in advance!
    I searched the forum, but found nothing. So sorry if this has been addressed before.

    Posted via CB10
    01-11-16 07:46 PM
  2. parothd95's Avatar
    I've had the same happen the last few weeks on my Z30, so it might not be limited to the Passport. I updated to the last week or 10 days, but this lagging issue actually started before with the lower OS. I had hoped the update would fix it but it didn't.

    It's sort of hard to explain but I've noticed three things in particular. One, it doesn't keep up when I type fast. That was always one of the advantages to the wonderful BB10 keyboard, it kept up no matter how fast one typed. Two, it lags even when I consciously slow down my typing. Lagging meaning when I hit a key, the phone doesn't respond for a second or two. It just happened with that sentence. I typed "or" and the phone froze for a second and replaced the "or" that I had typed with a period. What in the world? In other times when it lags, it doesn't predict or it predicts a strange word that has none of the letters I typed and more than predicts, it places a completely different word in my sentence. Like with the period example above. Three, and this is sort of related to the lagging, if it doesn't have a prediction, it just completely erases the word I typed. Very frustrating since, next to the Hub, the keyboard is one of the best features of BB10.

    Is anyone else experiencing this? Any solutions in the horizon?

    Posted via CB10
    01-17-16 09:01 PM
  3. KhalidAznawi's Avatar
    My passport se works as great.... no lagging at all

    Posted via CB10
    01-18-16 02:27 AM
  4. LordCrankypants's Avatar
    The only time I see a lag, and even then it only happens occasionally, is when I'm trying to do keyboard input on desktop versions of websites that are fully rendered.


    Posted internationally thanks to my Passport
    01-18-16 05:59 AM
  5. Tessoro Desoto's Avatar
    Have you installed many android apps? If a restart doesnt solve the issue you may be up for a complete wipe and start from scratch, no restoring from backup initially to see if that help. Remember you will lose all data. I do notice that crackberry forums make the device lag.
    01-18-16 07:48 AM
  6. Alain_A's Avatar
    I have no android apps, never has and I did experience the keyboard lag along side with the freezing screen.
    Last week I did a wipe and nothing had changed.
    Today everything is fine for now.

    By the way I also got the phantom windows popping up regularly all over the screen. When I get home I will do an OS reload.
    01-18-16 01:32 PM

Similar Threads

  1. Replies: 8
    Last Post: 01-15-16, 04:01 PM
  2. Passport stuck on bb10-0015 error after wipe, what can I do?
    By pszemia in forum BB10 Leaked/Beta OS
    Replies: 5
    Last Post: 01-12-16, 12:38 PM
  3. Snapchat for Blackberry Passport ? Help please..
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 01-11-16, 04:34 PM
  4. How to set up multi-language keyboard support on the BlackBerry Priv
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 01-11-16, 06:00 AM
  5. Passport Bluetooth
    By GusBandicoot in forum BlackBerry Passport
    Replies: 0
    Last Post: 01-11-16, 05:41 AM