1. jtmo3's Avatar
    OK, got a new passport today. Opened turned on, all seems ok. Went to update it cause it says there is a new update. Tried through link, error. Tried through website...error. Did a security wipe, error downloading drivers. I am at my wits end. I've spent over two hours just trying to get this thing to update. It's frustrating the heck out of me. Anyone got any ideas? Not a good start with the new device.
    11-02-14 02:34 PM
  2. Andy Wijaya's Avatar
    Is your wifi connection okay? I think you can download update later.
    11-02-14 02:41 PM
  3. SK122387's Avatar
    The update takes a while.

    Make sure you're connected to WiFi, which you connect to in the Setup process. It will then prompt you to update your software.

    If that doesn't work, just complete the setup process and go to Settings then click Software Updates and then Check for Updates.

    It will find the update and update for you, though be patient because it took my phone like a half an hour to download.

    Posted via CB10
    bungaboy likes this.
    11-02-14 02:43 PM
  4. Pdinos3's Avatar
    First, take a breath. Second if it says there's an update on the device, why not update on the device?
    Make sure your battery is above 20% before attempting update.

    VIA CB10 Rockin PassportSQW100-1/10.3.1.1016 and Official Member of the Peevishlicious Crew
    thymaster and bungaboy like this.
    11-02-14 02:43 PM
  5. jtmo3's Avatar
    Thanks for the replies guys. I have tried the update on the phone first but an hour into it and still not done downloading. Could it take this long? WiFi is connected and internet is 50Mb speed.

    I am going to try letting it complete the download and see what happens. This could take a while!
    11-02-14 02:49 PM
  6. Chris S Mellor's Avatar
    Could try installing the update via Autoloaders?

    Posted via CB10
    11-02-14 02:53 PM
  7. SK122387's Avatar
    Thanks for the replies guys. I have tried the update on the phone first but an hour into it and still not done downloading. Could it take this long? WiFi is connected and internet is 50Mb speed.

    I am going to try letting it complete the download and see what happens. This could take a while!
    There's the download process and then the Install process. Mine took like 45 minutes or maybe even an hour now that I think about it. I just did it two days ago, since I received a replacement device.

    It eventually will complete and restart your phone. To make sure you have the update, go to Settings and About and then select OS and make sure you're on 10.3.0.1418 OS Version or just type myver and press spacebar in a text field and it will display PassportSQW100-1/10.3.0.1418.

    I thought mine took a longtime to download too, but just be patient. It's probably just slow like mine was.

    Posted via CB10
    11-02-14 02:55 PM
  8. thymaster's Avatar
    It could be a delay in the server maybe try later.
    11-02-14 02:59 PM
  9. jtmo3's Avatar
    OK, letting it download and I'll see what happens. I'll let you know if it was successful. Thanks again.
    11-02-14 03:01 PM
  10. jtmo3's Avatar
    OK great. I let the download and install finish and it finally did update. So far so good. I feel much better now.

    Has anyone seen an issue with a 128Gb card? I have one and tried to use it but it too would throw up an error when it tried to access and download the drivers. I put a 64Gb card in and it downloaded the drivers fine. Stuck the 128Gb card back in and it formatted and appears to be working now. It would initially with the card. Anyone seen or heard of this?

    Again, thanks guys for the help. Looking forward to finally getting to play with this thing. It appears I'm gonna really like it!
    11-02-14 03:53 PM
  11. bungaboy's Avatar
    The age of instant gratification. LoL

    OP, glad you got everything sorted out. Enjoy your new device!
    11-02-14 04:03 PM
  12. mikedolo's Avatar
    Blaming the passport for simple mistakes made lol. Glad to see it all worked out
    11-02-14 04:55 PM
  13. brendanr6's Avatar
    OK great. I let the download and install finish and it finally did update. So far so good. I feel much better now.

    Has anyone seen an issue with a 128Gb card? I have one and tried to use it but it too would throw up an error when it tried to access and download the drivers. I put a 64Gb card in and it downloaded the drivers fine. Stuck the 128Gb card back in and it formatted and appears to be working now. It would initially with the card. Anyone seen or heard of this?

    Again, thanks guys for the help. Looking forward to finally getting to play with this thing. It appears I'm gonna really like it!
    Yes, with the bigger SD cards the phone needs to format it first into the appropriate format.

    Posted via CB10
    11-02-14 05:00 PM
  14. buwee's Avatar
    Has anyone seen an issue with a 128Gb card? I have one and tried to use it but it too would throw up an error when it tried to access and download the drivers. I put a 64Gb card in and it downloaded the drivers fine. Stuck the 128Gb card back in and it formatted and appears to be working now. It would initially with the card. Anyone seen or heard of this?
    I have a Sandisk 128GB micro sd card in mine and have had no problems. Inserted the card, the downloading driver message popped up, then said it was ready for use.
    11-02-14 05:31 PM

Similar Threads

  1. Passport holster made for LG OPTIMUS VU
    By bcorreia in forum BlackBerry Passport
    Replies: 3
    Last Post: 11-06-14, 10:49 PM
  2. Strange Hub Issue
    By Yoox_II in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 11-02-14, 10:14 PM
  3. Passport reboot issue
    By ricard112 in forum BlackBerry Passport
    Replies: 15
    Last Post: 11-02-14, 08:00 PM
  4. Replies: 2
    Last Post: 11-02-14, 02:15 PM
  5. Where's CrackBerry Kevins Passport Review?
    By Jeffm63 in forum BlackBerry Passport
    Replies: 11
    Last Post: 11-02-14, 01:33 PM
LINK TO POST COPIED TO CLIPBOARD