1. ms322's Avatar
    Hello, my Passport is on the latest (official) Software but the flashlight does not work? Neither by using the quick menu to switch it on, nor with the Cam-App nor with an BlackBerry World Flashlight-App.

    I think someone mentioned somewhere to try to side load the program file for the flash light? (Does anyone have a link? Can I find it at BB?) Or does anyone have a better solution?
    (Yes, I know it could really be a hardware problem but there was no damage, drop, spill etc.)

    Thanks!
    11-11-15 02:03 PM
  2. conite's Avatar
    Does the flash work when you take a picture?

    Have you tried a hard reset (both volume buttons until reboot)?

    PassportSQW100-4/10.3.2.2789
    11-11-15 02:04 PM
  3. zombiecupcake's Avatar
    Does the flash work when you take a picture?

    Have you tried a hard reset (both volume buttons until reboot)?

    PassportSQW100-4/10.3.2.2789
    +1.

    This has happened to me before and iirc it had something to do with the camera app still using it even when closed. Just do a hard reset and it should go back to normal.

     = ♥ | 8220, 8530, 9670, 9810, Q10, Passport
    11-12-15 06:59 AM
  4. ms322's Avatar
    I tried to take pictures and I also did the hard reset (and several reboots) but still the flash LED does not respond
    11-12-15 10:58 AM
  5. Machete Santa's Avatar
    Hey at least your camera still works. My flash works fine but it's my rear camera that doesn't focus anymore :/

    Still trying to figure it out before admitting defeat and doing a BlackBerry RMA. I got a month or two left on the warranty

    Did you use the flash a lot?

    Posted via CB10
    11-12-15 12:47 PM
  6. Adi Marwan's Avatar
    Hey at least your camera still works. My flash works fine but it's my rear camera that doesn't focus anymore :/

    Still trying to figure it out before admitting defeat and doing a BlackBerry RMA. I got a month or two left on the warranty

    Did you use the flash a lot?

    Posted via CB10
    One of the threads have possible solution, which is to hold the camera button until it focuses, and then release it. That should work. It has something to do with continuous focus or some sort.

    Try it, open camera, press and hold the shutter until box becomes green, then release it.

    Posted via Z30
    11-12-15 11:57 PM
  7. chopachain's Avatar
    OP. Having READ your post I doubt you will be able to fix it without a OS reload through link or with autoloader.

    http://forums.crackberry.com/bb10-le...rchive-943672/
    11-13-15 12:51 AM
  8. ms322's Avatar
    Thanks chopachain for the link to the files.
    I now will go for an RMA :-/
    11-14-15 04:46 AM

Similar Threads

  1. Google hangouts on priv. Does it work?
    By hoverbover in forum BlackBerry Priv
    Replies: 10
    Last Post: 01-05-17, 02:33 PM
  2. When,a New Passport is going to sale?
    By dvmblues in forum BlackBerry Passport
    Replies: 7
    Last Post: 11-15-15, 12:58 AM
  3. A thought for people not liking android or the priv.
    By Silkaz in forum BlackBerry Priv
    Replies: 12
    Last Post: 11-11-15, 01:53 PM
  4. Replies: 5
    Last Post: 11-11-15, 01:06 PM
  5. Replies: 3
    Last Post: 11-11-15, 11:04 AM
LINK TO POST COPIED TO CLIPBOARD