1. ozbb-q10's Avatar
    Hi
    My new Passport (2 weeks old) does not boot anymore!
    I removed the sim card and it in my old Classic to use

    Any idea how can I bring my Passport back to life again?

    Thanks
    11-21-17 12:35 AM
  2. Dunt Dunt Dunt's Avatar
    Does it do anything? LED flash? Screen have any messages?
    11-21-17 07:02 AM
  3. TechyThePoodle's Avatar
    Same problem. Will not reboot...light blinking, Phone rings...screen black.


    Posted via CB10
    11-21-17 03:16 PM
  4. brookie229's Avatar
    First thing to do is just hold the power button down for 15 seconds or so and try the hard boot. Next thing to do (if hard boot does not work) is to try and use an autoloader and give yourself a new OS.
    Qorax likes this.
    11-21-17 03:48 PM
  5. TechyThePoodle's Avatar
    Thank you. 1st fix suggestion worked! Thank you. I simply did no hold power button down long enough.


    Posted via CB10
    Qorax likes this.
    11-21-17 03:56 PM
  6. ozbb-q10's Avatar
    Thank you guys, you are really amazing! it is working ( the 15 sec technique). I can enjoy my new BB Passport now
    Qorax likes this.
    11-21-17 07:24 PM

Similar Threads

  1. Google play service not working
    By july3192 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 11-24-17, 12:28 AM
  2. E-Mails do not open (Hub)
    By wildsau666 in forum BlackBerry Motion
    Replies: 7
    Last Post: 11-22-17, 02:01 PM
  3. Contact bdays not shown on calendar
    By MB64 in forum BlackBerry 10 OS
    Replies: 10
    Last Post: 11-21-17, 08:41 PM
  4. Keyone says dialing but does not dial number
    By nataleehillman in forum BlackBerry Mobile Support
    Replies: 7
    Last Post: 11-20-17, 07:42 PM
  5. Why the volume in my KEYone does not work?
    By Firqie in forum BlackBerry KEYone
    Replies: 1
    Last Post: 11-20-17, 03:21 PM
LINK TO POST COPIED TO CLIPBOARD