09-20-17 07:48 AM
37 12
tools
  1. martinajm's Avatar
    I owned a passport for several years and recently made the switch to the Keyone. I loved the passport, but the functionality of some basic apps became an issue for me.

    I was never able to get the file transfer from the Passport to the Keyone to work correctly, but mostly was just lacking pictures. My work around was to have the passport relatively accessible so I could send select pictures by wifi as needed.

    My problem is my passport appears to now be dead. When I have it connected to a charger, the indicator light is a solid red. Other than that, I can't get any reaction on the phone, i.e. trying to power or, extended hold of power button to "reboot", etc.

    Any suggestions to get it running one more time?
    07-30-17 09:45 AM
  2. IvanTheTolerable's Avatar
    Try connecting to the PC and see if link detects it?
    07-30-17 09:48 AM
  3. leeiling's Avatar
    SE or OG? I have an SE having the same issue, and I tore the phone apart to realize it is the power key malfunction.

    Posted via CB10
    07-30-17 09:57 AM
  4. martinajm's Avatar
    No luck with the PC. Not sure what the difference is between SE and OG. Mine was an ATT bought in 2015...
    07-30-17 05:03 PM
  5. LSDBerry's Avatar
    First try a different charger - preferably a 2.4amp one, and try a different cable.
    08-01-17 02:10 AM
  6. cbd212's Avatar
    Same problem, tried connecting to a computer, that lasted for a short while, then sent it back to BB, not pleased with the results - back it came - unrepaired - and they told me there was "liquid damage," nothing they could do, so sorry. I asked for pictures - they sent them, just now, pictures of who knows what. So a phone I have owned for just 2 years is DOA. I am protesting and I have let them know what CB10 found. Any other suggestions? And I did try everything suggested in this thread.
    08-02-17 03:31 PM
  7. Huussi's Avatar
    Same problem, tried connecting to a computer, that lasted for a short while, then sent it back to BB, not pleased with the results - back it came - unrepaired - and they told me there was "liquid damage," nothing they could do, so sorry. I asked for pictures - they sent them, just now, pictures of who knows what. So a phone I have owned for just 2 years is DOA. I am protesting and I have let them know what CB10 found. Any other suggestions? And I did try everything suggested in this thread.
    If it's actually liquid damage and it doesn't work then it's time for a new phone (or a mainboard swap).
    08-03-17 03:21 AM
  8. cbd212's Avatar
    Thanks, have given up - I don't see any liquid damage, but who am I? So, we are now a household with one working Passport, which I love, and an iPhone.....ah, well.
    08-04-17 05:01 PM
  9. rawkerboi 07's Avatar
    Let your Passport rest in peace now


    Posted via CB10
    08-05-17 02:31 PM
  10. Sam-Tech's Avatar
    My PP has been on the disabled list for the last four months due to the "emergency calls virus". I've been using the Z10, but with these fat fingers it takes too long to text "spell check is no match for these fingers ". So I just bought a motherboard and spkr/ant module, to resurrect my old BB10 friend. And we'll ride the OS10 Doomsday Rocket into the Sun.

    Posted via CB10
    08-05-17 05:52 PM
  11. kw9700's Avatar
    Same problem, tried connecting to a computer, that lasted for a short while, then sent it back to BB, not pleased with the results - back it came - unrepaired - and they told me there was "liquid damage," nothing they could do, so sorry. I asked for pictures - they sent them, just now, pictures of who knows what. So a phone I have owned for just 2 years is DOA. I am protesting and I have let them know what CB10 found. Any other suggestions? And I did try everything suggested in this thread.
    I went through the EXACT same process as you (warranty, pictures of "liquid damage" after demanding proof, etc.) with the exact same result. Only thing was, it happened to me almost 2 years ago, and at the time there weren't nearly as many cases of this happening. It smelled funny because I was always so careful with it and was sure I never let it near any liquid damage. Treated it the same (quite well) as any other phone I've ever had. Now I'm seeing more and more of these stories pop up that are very similar, but yours is the most identical to mine that I've ever seen. I have a feeling Blackberry got away with not admitting to a known issue here by sloughing it off as "liquid damage" every time and relying on the masses to move onto their newer devices and Android devices. With so many cases by now of seemingly magical charge port issues, how could they not know...
    08-30-17 06:28 PM
  12. Rcornelsen's Avatar
    My PP has been on the disabled list for the last four months due to the "emergency calls virus". I've been using the Z10, but with these fat fingers it takes too long to text "spell check is no match for these fingers ". So I just bought a motherboard and spkr/ant module, to resurrect my old BB10 friend. And we'll ride the OS10 Doomsday Rocket into the Sun.

    Posted via CB10
    Where did you buy the motherboard and spkr/ant module? I think I need a new one for my passport.

    Posted via CB10
    08-30-17 09:09 PM
  13. aslamk47's Avatar
    I owned a passport for several years and recently made the switch to the Keyone. I loved the passport, but the functionality of some basic apps became an issue for me.

    I was never able to get the file transfer from the Passport to the Keyone to work correctly, but mostly was just lacking pictures. My work around was to have the passport relatively accessible so I could send select pictures by wifi as needed.

    My problem is my passport appears to now be dead. When I have it connected to a charger, the indicator light is a solid red. Other than that, I can't get any reaction on the phone, i.e. trying to power or, extended hold of power button to "reboot", etc.

    Any suggestions to get it running one more time?
    Press volume up and down button in the same times for 1 minute ...

     BLACKBERRY |P A S S P O R T | OG| BBM 2C1E63FA
    08-31-17 06:56 AM
  14. EchoTango's Avatar
    Another new member of the "no cellular connection/emergency calls only" club. The membership continues to grow and Blackberry is still sitting on its hands. They have officially know about the problem since April 26th and have not even updated the tickets since that date.

    Very poor support performance which continues to surprise and shock.
    09-03-17 10:15 AM
  15. BigBrownBirdDog's Avatar
    It hit me last night. I have not heard of this issue until now. Has the rest of the device been compromised?

    Posted via CB10
    09-04-17 08:24 AM
  16. EchoTango's Avatar
    It hit me last night. I have not heard of this issue until now. Has the rest of the device been compromised?

    Posted via CB10
    The device will continue function in all capacities with exception of a connection to a cell network. Even wifi will continue to work fine. Mine still looks like new as it spent its two years of life in a case but is completely useless as a communication device.

    I sincerely hope you're not experiencing this, but if you are I would figure out if you have a warranty and if yes, get it replaced immediately.
    09-04-17 09:16 AM
  17. Sam-Tech's Avatar
    Sorry for the delayed response :-( I searched Ebay and found 5 or 6 for sale from different vendors. I bought the cheapest one for $69.00. And it's been working great!
    09-05-17 09:20 PM
  18. EchoTango's Avatar
    Sorry for the delayed response :-( I searched Ebay and found 5 or 6 for sale from different vendors. I bought the cheapest one for $69.00. And it's been working great!
    Was it used, refurbished or new ?
    09-05-17 09:28 PM
  19. Sam-Tech's Avatar
    Was it used, refurbished or new ?
    The ad said refurbished, But I think it's just another way of saying used! Anyways It works great, and my fat thumbs are happy again.
    09-05-17 10:25 PM
  20. Aaditya Sabharwal's Avatar
    Haven't ever experienced such a problem. But still, I think you may try to tear apart the phone and check for water damage. If not, you could leave it open in sunshine or at least in a warm place for a day. If not even then, try a new battery, i.e. get a new battery and use it.

    Posted via CB10
    09-06-17 05:38 AM
  21. Chuck Finley69's Avatar
    Another new member of the "no cellular connection/emergency calls only" club. The membership continues to grow and Blackberry is still sitting on its hands. They have officially know about the problem since April 26th and have not even updated the tickets since that date.

    Very poor support performance which continues to surprise and shock.
    Exactly what should BlackBerry do? Since device is no longer in production and hasn't been in over a year and there is no BB10 development going on. Topping it all off, BlackBerry exited the hardware business.

    Your options are send it back if under warranty or if past warranty period, buy another phone of your choice. That's it.
    09-06-17 07:21 AM
  22. wingnut666's Avatar
    wow. did you try hard reset? one person suggested it here, otherwise i see no mention of it. as soon as i read your symptom, that is what came to mind.

    Posted via CBX
    09-06-17 08:19 AM
  23. EchoTango's Avatar
    Exactly what should BlackBerry do? Since device is no longer in production and hasn't been in over a year and there is no BB10 development going on. Topping it all off, BlackBerry exited the hardware business.

    Your options are send it back if under warranty or if past warranty period, buy another phone of your choice. That's it.
    What Blackberry should do is provide a definitive cause and solution so whatever has failed can be replaced. Also, without knowing the cause, how can you buy another Passport (if you really like the phone, which I do) which might have the same issue, again without a known cause or fix.

    I'm fairly certain replacing the motherboard will solve the problem but it would be nice to know what the original issue was to provide some confidence of device's future stability.
    09-06-17 09:38 AM
  24. EchoTango's Avatar
    wow. did you try hard reset? one person suggested it here, otherwise i see no mention of it. as soon as i read your symptom, that is what came to mind.

    Posted via CBX
    How about a full device wipe and reloading the software from scratch ? Is that "hard" enough ?
    09-06-17 09:40 AM
  25. wingnut666's Avatar
    How about a full device wipe and reloading the software from scratch ? Is that "hard" enough ?
    i dont even know what this thread is about anymore. i was referring to the red light. i have a second passport with a dead antenna. that problem is unfixable. its a wifi-only device now for multimedia and a bluetooth remote..

    Posted via CBX
    09-06-17 09:45 AM
37 12

Similar Threads

  1. Replies: 4
    Last Post: 07-30-17, 12:17 PM
  2. blackberry passport wifi problem
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-30-17, 04:23 AM
  3. Caller ID – speaking, talking, announcer, speech – for Blackberry Passport
    By BlackberryQ10 Cooperativism in forum BlackBerry Passport
    Replies: 0
    Last Post: 07-29-17, 06:22 PM
  4. How to transfer text messages from an iPhone to the Passport?
    By mrgarygeorge in forum Ask a Question
    Replies: 0
    Last Post: 07-29-17, 03:36 PM
  5. how to use whats app in BB passport??
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 07-29-17, 03:20 PM
LINK TO POST COPIED TO CLIPBOARD