07-13-16 05:03 PM
59 123
tools
  1. johnwto's Avatar
    So suddenly my Legend randomly disconnects from my Passport in the middle of a call. Even if I switch the bluetooth device back on it will disconnect soon afterwards.

    I have done no recent upgrades (10.3.1.1779), have reset the bluetooth stack, reset the Legend sensors and nothing.

    The question is which unit is defective? The Passport or the Legend? From this thread it would appear that other brands are also randomly disconnecting. So confused, it shouldnt be this hard to get a bluetooth headset working.

    ** it's the Legend. I switched my sim card to a Moto X and sure enough it kept disconnecting from that too. Should have known better than to think my amazing Passport was to blame
    Last edited by johnwto; 06-18-15 at 09:43 PM.
    06-18-15 04:20 PM
  2. J Quimson's Avatar
    So I called AT&T about my first Passport's by issue, unfortunately the BlackBerry line was busy and we couldn't get through. AT&T did tell me that it would have to go through BlackBerry for the warranty exchange. I'll be calling them again on Wednesday to complete the process. The cs rep told me it would have a good chance of being replaced.
    06-18-15 11:57 PM
  3. james_1980's Avatar
    I've not had any plantronics to BlackBerry issues.... and I'm currently on my fifth voyager and goodness knows how many BlackBerry currently Passport on PassportSQW100-1/10.3.1.2576

    Good luck guys. Two amazing products

    Posted via CB10
    07-01-15 04:16 PM
  4. ztx's Avatar
    So suddenly my Legend randomly disconnects from my Passport in the middle of a call. Even if I switch the bluetooth device back on it will disconnect soon afterwards.

    I have done no recent upgrades (10.3.1.1779), have reset the bluetooth stack, reset the Legend sensors and nothing.

    The question is which unit is defective? The Passport or the Legend? From this thread it would appear that other brands are also randomly disconnecting. So confused, it shouldnt be this hard to get a bluetooth headset working.

    ** it's the Legend. I switched my sim card to a Moto X and sure enough it kept disconnecting from that too. Should have known better than to think my amazing Passport was to blame
    I have the same issue, voyage legend disconnect during call, sometimes it can reconnect, sometimes not, very annoying.

    Posted via CB10
    Last edited by ztx; 07-08-15 at 08:48 PM.
    07-08-15 08:32 PM
  5. Smokeaire's Avatar
    I have the same issue, voyage legend disconnect during call, sometimes it can reconnect, sometimes not, very annoying.

    Posted via CB10
    The disconnect issue you are having has been reported/posted many times. The source of the issue is your phone. The bluetooth is defective. Returning your phone and getting a new one will be the solution. I had that problem with my first Passport. I returned it and the second phone's Bluetooth is perfect. No disconnects what so ever.

    Sent from my BlackBerry Passport.
    07-09-15 06:51 AM
  6. ztx's Avatar
    I did a senser rest, now pick up to answer worked, but after a while, the sensor need to reset again.
    My problem is during call, the audio switched from headset to phone, I can switch back to headset by the tap the audio -headset, the Bluetooth connection didn't lost.

    To test the sensor, wearing the headset, tap the call button, you heard a talk time voice alter, the sensor is ok, otherwise need a reset. To reset, charge your headset, place on a flat non-metallic surface for more than 10 seconds.

    Posted via CB10
    07-10-15 12:04 AM
  7. MPF94025's Avatar
    I was having the same problem with frequent connects/disconnects using Passport and Plantronics Legend. Interestingly, same Legend paired fine with another Passport I keep as backup, no problem. I think sometimes if one more than one headset is used the BBRY Bluetooth can't distinguish and gets "confused" (if that's possible). I restored the Passport to factory settings, the problematic Passport still would connect/disconnect. I then used the Plantronics updater on its website and turned off the "sensor" function that automatically turns Bluetooth ear piece on/off when laying down/picking up. After that, the problem went away. I had used the autoupdater (on the Plantronics web site) to update firmware on the headset, that alone didn't fix the problem: I tried turning off the sensor feature as a "last resort". It happened to work. Also, Plantronics just came out with a new Legend, the 5200. I think the sound quality in the limited time I've had it is not any better, but supposed to be, with more microphones/noise cancellation and finally a micro USB on the ear piece for charging. It connected no problem, even when the Passport was having problems with the original Legend. So this may be an expensive solution for those who really like the Legend and can't get it to pair consistently with a Passport. I'd trying updating firmware and turning off ear piece sensor first.... And I don't think it's worth the trouble of doing a system restore (if you do, turn off encryption first and shut down BB Protect as apparently this leads to a problem whereby restoring to factory settings takes forever, then gets stuck at 99% security wipe - another thread on Crackberry described a workaround to THIS problem, which is turning off the phone then connecting it to BBLink as it's booting up, the restore then proceeds...FWIW)
    07-05-16 10:56 AM
  8. prplhze2000's Avatar
    My new Passport SE has the disconnect problem. I can run my soundbar all night hooked up to it. However, my plantronics voyager legend keeps connecting and disconnecting at random. Tried a plantronics update. Didn't work.

    Posted via CB10
    07-05-16 08:23 PM
  9. prplhze2000's Avatar
    I was having the same problem with frequent connects/disconnects using Passport and Plantronics Legend. Interestingly, same Legend paired fine with another Passport I keep as backup, no problem. I think sometimes if one more than one headset is used the BBRY Bluetooth can't distinguish and gets "confused" (if that's possible). I restored the Passport to factory settings, the problematic Passport still would connect/disconnect. I then used the Plantronics updater on its website and turned off the "sensor" function that automatically turns Bluetooth ear piece on/off when laying down/picking up. After that, the problem went away. I had used the autoupdater (on the Plantronics web site) to update firmware on the headset, that alone didn't fix the problem: I tried turning off the sensor feature as a "last resort". It happened to work. Also, Plantronics just came out with a new Legend, the 5200. I think the sound quality in the limited time I've had it is not any better, but supposed to be, with more microphones/noise cancellation and finally a micro USB on the ear piece for charging. It connected no problem, even when the Passport was having problems with the original Legend. So this may be an expensive solution for those who really like the Legend and can't get it to pair consistently with a Passport. I'd trying updating firmware and turning off ear piece sensor first.... And I don't think it's worth the trouble of doing a system restore (if you do, turn off encryption first and shut down BB Protect as apparently this leads to a problem whereby restoring to factory settings takes forever, then gets stuck at 99% security wipe - another thread on Crackberry described a workaround to THIS problem, which is turning off the phone then connecting it to BBLink as it's booting up, the restore then proceeds...FWIW)
    Took your advice. The Voyager Edge works fine, knock on wood.

    Posted via CB10
    07-13-16 05:03 PM
59 123

Similar Threads

  1. Is it ok to use PB charger on Passport?
    By prplhze2000 in forum BlackBerry Passport
    Replies: 34
    Last Post: 06-03-15, 12:50 PM
  2. Music Player on Passport
    By piko 72 in forum BlackBerry Passport
    Replies: 5
    Last Post: 05-13-15, 12:58 AM
  3. bluetooth connection to mac OSX failed
    By manuelcicca in forum BlackBerry Passport
    Replies: 5
    Last Post: 05-12-15, 08:45 PM
  4. Trade my Passport for classic
    By ramsbee in forum BlackBerry Classic
    Replies: 11
    Last Post: 05-12-15, 07:07 AM
  5. Link USB sync deletes current calendar entries on Passport
    By hamilgs in forum BlackBerry Passport
    Replies: 0
    Last Post: 05-11-15, 05:42 PM
LINK TO POST COPIED TO CLIPBOARD