1. Mohamad Chehadeh's Avatar
    Battery on my passport has been draining faster than usual. I could get between 24 and 27 hours sometimes on a single charge. Now I barely get 12 to 15 max. When I check the device monitor, it shows that the system is at 40%.
    What's draining my battery so fast?

    Posted via the king of phones. The Passport.
    06-09-15 05:12 PM
  2. nward2010's Avatar
    Try resetting your phone by holding the up & down volume keys at the same time for about 6-7 seconds.

     RED Passport SQW100-1/10.3.2.680 on Telus
    06-09-15 05:32 PM
  3. deltact's Avatar
    Device Monitor may give you a clue.

    Posted via CB10 on Passport.
    ivo1969 likes this.
    06-09-15 06:18 PM
  4. iCoutinoc's Avatar
    I had that battery issue when I first installed the os I have, so I reinstalled the os and my battery it's great now.

    Passport battery-img_20150610_100429.png

    Posted via Passport SQW100-1/10.3.2.680
    Trauma Surgeon likes this.
    06-10-15 10:13 AM
  5. SpamHammer's Avatar
    Device Monitor may give you a clue.
    From the original post...

    When I check the device monitor, it shows that the system is at 40%.
    What's draining my battery so fast?

    God, it's like none of you guys bother reading the actual posts anymore.

    What a bad reply. He stated that he checked the Device Monitor before you ever jumped on the scene. The proper reply would have been something that helped him narrow down how to determine what the item is in System that is running up the battery usage.
    06-10-15 02:40 PM
  6. shahyaz's Avatar
    Battery on my passport has been draining faster than usual. I could get between 24 and 27 hours sometimes on a single charge. Now I barely get 12 to 15 max. When I check the device monitor, it shows that the system is at 40%.
    What's draining my battery so fast?

    Posted via the king of phones. The Passport.
    Have you been using the Amazon App store? I find that since two updates ago, the apps get stuck in a weird install pending state. That's what was doing it for me. I force closed the Amazon store and everything was fine. Give it a go?
    06-10-15 02:54 PM
  7. puddycom's Avatar
    I had that battery issue when I first installed the os I have, so I reinstalled the os and my battery it's great now.

    Click image for larger version. 

Name:	IMG_20150610_100429.png 
Views:	1220 
Size:	750.1 KB 
ID:	356863

    Posted via Passport SQW100-1/10.3.2.680
    Hi! Please how do I reinstall the os? Was getting 24 hours plus before os update to 10.31.1779. But now I barely get 7 hours.

    P.S.
    My passport is extremely busy

    Posted via CB10
    06-11-15 06:48 AM
  8. nward2010's Avatar
    Hi! Please how do I reinstall the os? Was getting 24 hours plus before os update to 10.31.1779. But now I barely get 7 hours.

    P.S.
    My passport is extremely busy

    Posted via CB10
    Connect your device to BlackBerry Link and select the Reload option. Your device will be wiped and the OS will be re-installed.

     RED Passport SQW100-1/10.3.2.680 on Telus
    06-11-15 09:07 AM
  9. iCoutinoc's Avatar
    Try the link way or an autoloader, I used the autoloader because was the last leak

    Posted via Passport SQW100-1/10.3.2.680
    06-11-15 11:24 AM
  10. puddycom's Avatar
    Thanks. Will try now

    Posted via CB10
    06-11-15 01:40 PM
  11. puddycom's Avatar
    Problem still not solved. I have updated to 10.3.2 via a downloaded autoloader. I also tries the reset suggestion above. Nothing seems to work so far. Battery still does less than 12 hours. I would appreciate any suggestion.
    Passport battery-img_20150613_170441.png

    Posted via CB10
    06-13-15 03:04 PM
  12. deltact's Avatar
    From the original post...




    God, it's like none of you guys bother reading the actual posts anymore.

    What a bad reply. He stated that he checked the Device Monitor before you ever jumped on the scene. The proper reply would have been something that helped him narrow down how to determine what the item is in System that is running up the battery usage.
    I meant that Device Monitor gives a lot more information, beyond just battery usage, and that the OP should give more information. I have found that looking at CPU usage is helpful, to see if there are large spikes there. On my Z10 running 10.2.x, I would occasionally have a loss of 30% battery because there was a massive spike in CPU usage, which I could never figure out. System usage does spike when I change timezones because the Hub changes all the message times to match the local time, but that's not an issue with the Passport.

    Bad signal also kills the battery; I have lost over 40% in an hour on my Z10 when in an area that keeps hopping between no signal and GSM. Not sure increasing the antenna gain is reflected under System usage. Try turning off LTE to see if that helps.

    Posted via CB10 on Passport.
    06-13-15 03:32 PM
  13. SpamHammer's Avatar
    I meant that Device Monitor gives a lot more information, beyond just battery usage, and that the OP should give more information.
    Posted via CB10 on Passport.
    Yeah, but you should have expanded on those instead of simply saying "look at the device monitor" after OP stated he had. Clearly he didn't know how/where to find that info, or he would have posted it. So simply telling him to check the place he already checked without giving more specific advice about how to use the tool better was not helpful. That's the point I was making.

    This reply you just posted has a lot more useful information in it; maybe there's something there that can spur him to find the culprit.
    06-14-15 06:35 PM
  14. SpamHammer's Avatar
    I meant that Device Monitor gives a lot more information, beyond just battery usage, and that the OP should give more information.
    Posted via CB10 on Passport.
    Yeah, but you should have expanded on those instead of simply saying "look at the device monitor" after OP stated he had. Clearly he didn't know how/where to find that info, or he would have posted it. So simply telling him to check the place he already checked without giving more specific advice about how to use the tool better was not helpful. That's the point I was making.

    This reply you just posted has a lot more useful information in it; maybe there's something there that can spur him to find the culprit.
    06-14-15 06:35 PM

Similar Threads

  1. Red Passport owners do u experience black paint flake?
    By TheGraduate in forum BlackBerry Passport
    Replies: 5
    Last Post: 06-10-15, 12:03 PM
  2. Question seidio Spring clip holder for Blackberry Passport
    By WRubin23 in forum BlackBerry Passport
    Replies: 5
    Last Post: 06-09-15, 11:01 PM
  3. Battery is not charging
    By Edwin Valle in forum Ask a Question
    Replies: 1
    Last Post: 06-09-15, 06:26 PM
  4. Replies: 5
    Last Post: 06-09-15, 05:34 PM
  5. BlackBerry Passport pricing through ShopBlackBerry reduced for a limited time
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 06-09-15, 02:22 PM
LINK TO POST COPIED TO CLIPBOARD