1. Surago's Avatar
    Just bought a "new" in box passport off ebay already having some issues

    1) main issue, if I restart the phone most if not all my settings are wiped. As if I just got a brand new phone.

    2) green led keeps flashing intermittently, I think this has something to do with another issue it had where the phone notification was not going away but i hadnt even made or received a phone call

    Posted via CB10
    10-11-17 08:43 PM
  2. Chuck Finley69's Avatar
    Just bought a "new" in box passport off ebay already having some issues

    1) main issue, if I restart the phone most if not all my settings are wiped. As if I just got a brand new phone.

    2) green led keeps flashing intermittently, I think this has something to do with another issue it had where the phone notification was not going away but i hadnt even made or received a phone call

    Posted via CB10
    Return it.... Passport has enough problems documented on here that cannot be fixed like connectivity issues. Since you have a return window and you're already having issues right from the box, it's statistically best to return it.

    That being said, if you're hellbent on a Passport, at least have them exchange it for another.
    Last edited by Chuck Finley69; 10-11-17 at 09:01 PM.
    10-11-17 08:50 PM
  3. Surago's Avatar
    Return it....
    Thanks.....

    Posted via CB10
    10-11-17 08:56 PM
  4. Chuck Finley69's Avatar
    Thanks.....

    Posted via CB10
    Sorry, I wasn't done replying and hit reply. I can be real abrasive but that wasn't the intent at that moment. LOL. I edited my answer but you'd already replied.
    10-11-17 09:07 PM
  5. anon(10336011)'s Avatar
    Just bought a "new" in box passport off ebay already having some issues

    1) main issue, if I restart the phone most if not all my settings are wiped. As if I just got a brand new phone.

    2) green led keeps flashing intermittently, I think this has something to do with another issue it had where the phone notification was not going away but i hadnt even made or received a phone call

    Posted via CB10
    Probably got a bad one..i bought one today for 200 and it works flawlessly..best phone I've ever owned

    Posted via CB10
    10-11-17 09:27 PM
  6. Surago's Avatar
    Just in case anyone else decides to check this out. My problem was very easy to fix. Google blackberry passport blue led and it comes right up. It is a known issue. Love this phone.

    Posted via CB10
    10-12-17 06:59 PM
  7. AbeM25's Avatar
    I have a consistent red LED flashing even when there is no new notifications. Could it be the same issue? Also have had an issue with the settings being wiped.

    Posted via CB10
    10-15-17 06:32 PM
  8. Surago's Avatar
    Maybe is it a new phone?

    Posted via CB10
    10-15-17 06:39 PM
  9. AbeM25's Avatar
    Yes it is. I bought it from amazon. Thought I was getting the black OG Passport but they sent me an AT&T version instead, which is fine with me. It looks new but now I'm wondering if it was purchased before and returned due to these issues/glitches.

    Posted via CB10
    10-15-17 06:42 PM
  10. Surago's Avatar
    Yes it is. I bought it from amazon. Thought I was getting the black OG Passport but they sent me an AT&T version instead, which is fine with me. It looks new but now I'm wondering if it was purchased before and returned due to these issues/glitches.

    Posted via CB10
    So yes, if you're manually restarting the phone and it's reverting back to basically stock bb10 form, this could be the issue. Another sign is when your be restarted the phone, after the blackberry logo appears, the led light will turn on and be solid blue. This is some sort of notification that it's entering the setup process and basically wiping the phone.

    So, go to google, type in "bb10 passport blue led issue" and a crack berry submission with come up with a sure fire fix to your problem. Mine works flawlessly after I performed this task.

    Let me know how it goes.
    10-15-17 07:37 PM
  11. AbeM25's Avatar
    So it worked! I went and looked up the CrackBerry submission you told me to find and I followed the steps and now my Passport doesn't have any issues. Thank you for the help!
    Last edited by AbeM25; 10-17-17 at 03:24 PM.
    10-17-17 02:34 PM

Similar Threads

  1. Passport hot to touch!
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 03-29-18, 09:58 PM
  2. Passport PRD Number ???
    By EchoTango in forum Ask a Question
    Replies: 3
    Last Post: 10-13-17, 11:08 AM
  3. WIFI Connection Issue: "ConnectivityCheck"
    By PFactor in forum BlackBerry DTEK50
    Replies: 1
    Last Post: 10-11-17, 08:09 PM
  4. Are There Speed Test Comparing Orig to Black version?
    By EndRacism in forum BlackBerry KEYone
    Replies: 1
    Last Post: 10-11-17, 05:02 PM
  5. Spotted a Passport in the wild
    By Newfangled in forum BlackBerry Passport
    Replies: 1
    Last Post: 10-11-17, 03:09 PM
LINK TO POST COPIED TO CLIPBOARD