12-15-14 06:47 PM
27 12
tools
  1. aghs's Avatar
    Just got an OTA update from TELUS 10.3.0.908 (in Alberta). Haven't seen this release number before. Probably just a maintenance release of some sort.
    10-17-14 06:07 PM
  2. Media Warrior's Avatar
    Looks like your right, 79 meg OTA

    OTA Update from TELUS 10.3.0.908-img_20141017_152300.png


    Posted via CB10
    aghs likes this.
    10-17-14 06:25 PM
  3. LamarStarr's Avatar
    Forced? Or optional?

    Posted via CB10
    10-17-14 06:38 PM
  4. zocster's Avatar
    It would be advisable to update

    Sent from my Passport using Tapatalk
    10-17-14 06:39 PM
  5. Ecm's Avatar
    This is the same OS 10.3.0.1418 (software release 10.3.0.908) that Rogers released for the Passport last week(end).
    10-17-14 06:40 PM
  6. aghs's Avatar
    This is the same OS 10.3.0.1418 (software release 10.3.0.908) that Rogers released for the Passport last week(end).
    Ah, you are correct! I looked at the release, not the OS version.

    Do we know what's in it? Or is it just various fixes?
    10-17-14 06:53 PM
  7. PowderJockey's Avatar
    Telus BC as well. First said it was 79 mb, did some downloading and installing, got to 99 % installed, then sadi it was interruppted and started to download a 1.2 GB file. both said 10.3.0.908.
    10-17-14 06:57 PM
  8. Ecm's Avatar
    There are a couple of threads you could look at:
    10.3.0.1418 Fixes & Findings Thread - Page 14 - BlackBerry Forums at CrackBerry.com
    http://forums.crackberry.com/bb10-le...-1-xyz-968532/

    My experience with it shows a few bug fixes, a little better performance overall, including battery life. Nothing outrageous, just nice.

    Some have reported WiFi signal issues, I havent had any.
    Some have experienced a timezone glitch (I did), but thats easily resolved.

    So, personally, I'd say it's worth it.
    10-17-14 06:59 PM
  9. LamarStarr's Avatar
    Telus BC as well. First said it was 79 mb, did some downloading and installing, got to 99 % installed, then sadi it was interruppted and started to download a 1.2 GB file. both said 10.3.0.908.
    Sounds wild. Glad that didn't happen to me

    Posted via CB10
    10-17-14 07:04 PM
  10. LamarStarr's Avatar
    The reason I ask is cuz rogers forced me to update. Without my permission

    Posted via CB10
    10-17-14 07:05 PM
  11. cooper_tor's Avatar
    The reason I ask is cuz rogers forced me to update. Without my permission

    Posted via CB10
    You likely have your settings configured for auto-update. Software updates are not forced on any platform I've ever seen. Too many liabilities.

    Posted via CB10
    10-17-14 07:09 PM
  12. PowderJockey's Avatar
    I did complete the survey on the Blackberry Beta Zone. Seems like they did have few bugs by some of the questions. Some I had and some I did not.

    Install now. All should be fine.
    10-17-14 07:19 PM
  13. PowderJockey's Avatar
    Sounds wild. Glad that didn't happen to me

    Posted via CB10
    I was on the road today and wonder if being in and out of places with wifi, the download didn't take properly.
    10-17-14 07:21 PM
  14. Media Warrior's Avatar
    Telus BC as well. First said it was 79 mb, did some downloading and installing, got to 99 % installed, then sadi it was interruppted and started to download a 1.2 GB file. both said 10.3.0.908.
    I'm also Telus/BC. Mine started OTA, said use wifi due to size and ended as the 79 originally shown. Not sure what happened to your update unless OTA corrupted the existing OS and needed to clean install.


    Posted via CB10
    10-17-14 08:01 PM
  15. Media Warrior's Avatar
    Too bad this update did not fix the overlapped frames issue I get with font size >9 here is size 10


    OTA Update from TELUS 10.3.0.908-img_20141017_170655.png

    Posted via CB10
    10-17-14 08:07 PM
  16. buwee's Avatar
    Too bad this update did not fix the overlapped frames issue I get with font size >9 here is size 10


    Click image for larger version. 

Name:	IMG_20141017_170655.png 
Views:	865 
Size:	90.3 KB 
ID:	306839

    Posted via CB10
    The 10.3.1 leak fixes this problem
    10-17-14 09:59 PM
  17. liddiepud's Avatar
    You likely have your settings configured for auto-update. Software updates are not forced on any platform I've ever seen. Too many liabilities.

    Posted via CB10
    Unfortunately not the case... I don't use Auto-update never have, personally don't like someone else updating my device without me at least having an opportunity to "weigh-in" on the thought. Regardless I received this update OTA, from Rogers, and it was identified as a mandatory update no choice given. The down side is that a number of apps, third Party and Rogers supplied, no longer work they were working fine before the update, and now don't. They start show me their opening screen and then it goes back to my page 1 of apps. I am going to try to wipe the device, reload the OS, then re-install my apps.... hopefully that will solve the issue cause I really like my Passport, or did until Rogers got at it.
    10-17-14 11:20 PM
  18. GP540's Avatar
    Forced? Or optional?

    Posted via CB10
    Optional I am pretty sure people are not turning off the automatic install feature

    OTA Update from TELUS 10.3.0.908-img_20141017_212753.png

    This was enabled out of the box.
    I chose to turn it off.

    In Squircle I Trust
    10-17-14 11:28 PM
  19. liddiepud's Avatar
    Optional I am pretty sure people are not turning off the automatic install feature

    Click image for larger version. 

Name:	IMG_20141017_212753.png 
Views:	584 
Size:	61.2 KB 
ID:	306889

    This was enabled out of the box.
    I chose to turn it off.

    In Squircle I Trust
    When the mandatory update, from Rogers, started I was no where near home, therefore not on WiFi and in spite of having my device set to do such updates only by WiFi the update, via OTA, was happening anyway; it is possible file size was small enough to get under the limit?? maybe... not the point of my post. However, when it [the OTA update] started the setting illustrated was the first thing I checked to ensure that somehow it hadn't somehow been turned on despite my turning it off when I first received my glorious, beautiful, Passport... it was still off. Bottom line is that Rogers sent out a "forced" update period, not the smartest move I'm thinking but it is what it is. Just some food for thought.

    Good News is the "restarts" I was doing were apparently not the right ones, pressing and holding the power button to restart my phone, I just tried the Volume-Up/Dn version and apps are all working fine again. I throw this out for anyone else who has this challenge after the update.
    10-17-14 11:49 PM
  20. RLTurn77's Avatar
    I'm on AT&T from shopblackberry, LTE with Passport after switching from Verizon. This update was a life saver for me. For some reason my phone was extra buggy.

    It would recognize a swipe, but not unlock unless I restarted, got caught in a loop repeating the same AT&T logo fixed with a hard restart, every so often I could not unlock device by swipe only had to hit the power button, and my @123 key was extremely finicky.

    Updated by downloading Sachesi then plugging phone in the USB in which it automatically recognized my Passport and noted there was an official update available. Hit download, then install... phone updated and restarted and have not had any problems at all since. Everything has been perfect and haven't had to unnecessarily restart the device every day or so anymore. Haven't restarted at all since updating.

    Not sure why anybody would not update, especially if having any bugs as I was. Just as easy as OTA without having to backup. Only thing was that I received 2 Rogers apps which I deleted. Cannot be more thankful for Sachesi and this update. Did not want to have to go through DR to return and try getting a new device. Anybody not on this release (it is official and was my first time installing an update from another carrier) should take a look at how simple this is to do.

    Perfect Passport now! Thank you Sachesi and Rogers!

    Posted via CB10
    10-18-14 11:10 AM
  21. Media Warrior's Avatar
    The 10.3.1 leak fixes this problem
    I tried the leak and could not get any volume on notifications. Missed an emergency call, went back to stock.

    Posted via CB10
    10-19-14 12:00 AM
  22. ridersinc's Avatar
    I'm on AT&T from shopblackberry, LTE with Passport after switching from Verizon. This update was a life saver for me. For some reason my phone was extra buggy.

    It would recognize a swipe, but not unlock unless I restarted, got caught in a loop repeating the same AT&T logo fixed with a hard restart, every so often I could not unlock device by swipe only had to hit the power button, and my @123 key was extremely finicky.

    Updated by downloading Sachesi then plugging phone in the USB in which it automatically recognized my Passport and noted there was an official update available. Hit download, then install... phone updated and restarted and have not had any problems at all since. Everything has been perfect and haven't had to unnecessarily restart the device every day or so anymore. Haven't restarted at all since updating.

    Not sure why anybody would not update, especially if having any bugs as I was. Just as easy as OTA without having to backup. Only thing was that I received 2 Rogers apps which I deleted. Cannot be more thankful for Sachesi and this update. Did not want to have to go through DR to return and try getting a new device. Anybody not on this release (it is official and was my first time installing an update from another carrier) should take a look at how simple this is to do.

    Perfect Passport now! Thank you Sachesi and Rogers!

    Posted via CB10
    Any steps you can provide or guide me towards regarding the upgrade would be greatly appreciated. I'll be receiving my PP tomorrow and also going from Verizon to AT&T LTE. I'm planning on doing the upgrade before porting over. I've downloaded Sachesi 1.9.2 on my Mac in preparation. Tks in advance!

    Posted via CB10
    10-20-14 01:31 AM
  23. CDM76's Avatar
    Damn. Got excited at first. Didn't read fully and notice is a Passport thread :'(
    Posted via CB10
    10-20-14 02:43 AM
  24. RLTurn77's Avatar
    Any steps you can provide or guide me towards regarding the upgrade would be greatly appreciated. I'll be receiving my PP tomorrow and also going from Verizon to AT&T LTE. I'm planning on doing the upgrade before porting over. I've downloaded Sachesi 1.9.2 on my Mac in preparation. Tks in advance!

    Posted via CB10
    Absolutely. It was as easy as any OTA update. It did take some time so set aside a few hours. The first time I tried the connection failed and had to restart. Did not have to backup phone either. For additional information, I would suggest looking in the BB10 OS forum. Here is the tutorial posted there:

    Steps
    1. Download Sachesi 1.9.5: https://github.com/xsacha/Sachesi/releases/
    2. Connect your phone to your computer via USB
    3. Run Sachesi!
    4. (First time you use Sachesi): Go to Install tab and and type in password for your device
    5. Go to Search tab and click 'Search', then 'Download All'
    6. When that is finished, go to Install tab and 'Install Folder' and choose the folder that was created.
    7. Your phone will reboot and it will take several minutes to process the upgrade


    Congratulations! You should be on the new OS, updated OTA with everything migrated correctly and no need to backup or restore.

    Troubleshooting
    Step #4: If it is not detecting your device, go to Settings -> Storage and Access on your device and make sure it is set correctly to either 'Connect to Windows' for Windows or 'Connect to Mac' for everything else.

    Step #5: Don't click 'Download All' unless the 'Download Device' is correctly set. It should say 'Connected' and NOT 'As Above'. If your device is not connected, refer to #4.
    If your download is especially slow or keeps stopping, you may wish to use a Download Manager such as jDownloader instead. In this case, use the 'Grab Links' button instead.

    Step #6: If the install does not work, make sure it is not a company phone. Your company phone may have a policy set to block installing.

    Step #7: If your phone feels buggy after the install, it may be because you didn't install OS + Radio + Apps together. Installing the OS separately can cause issues because your settings won't be migrated, if required. This can hose your install completely so please make sure you upgrade files together

    ....So for me, I received an update immediately after turning on the Passport and was very buggy on my device. As I stated this was an official release and I have never installed any leaked OS; especially on my only GSM device at this point, but was comfortable as I knew this was sent out by BlackBerry.

    Read and re-read the tutorial first. I actually printed a copy to have next to me while updating. What I did was connect my device via USB to my Windows laptop. Then I ran the latest version of Sachesi. Since it was my first time using Sachesi I had to go into the "Install" tab and put in my device password. I then clicked "Search" and the update showed as "Carrier - Rogers" and "Country - Canada". It is critical to make sure that your device is listed as CONNECTED. My Passport automatically connected after a minute or two after putting in my password with the Rogers update automatically appearing. After this is complete download all files. Make sure you download all files. I did have a connection problem the first time and some of the files did not download so make a note of the amount of files you are downloading and make sure they all download (because of the connection error I just deleted everything from Sachesi and started over). After this was completed, I clicked on the install tab and made sure all files were selected. I believe there were 203/204 files. Make sure they are all there and that you install them all at the same time. Keep an eye on the device section where it will say "connected" and show as the Passport. I made sure all files were selected and clicked on install. After a decent amount of time of sending the files to the device, my Passport noted that a software update was in progress and then restarted. That was it and I was on the latest official OS sent out from Rogers in Canada.

    I am in the US and on AT&T as I noted and this OS fixed many issues I was having that I knew were software related. It may seem complicated, but it was so easy that I can't wait for the next official release so I can update again. Very easy if you follow the instructions as noted above. If you need any other help feel free to ask! After realizing how easy it is to get the latest OS, I will never wait again. There is also a youtube tutorial in the BB10 OS forum under the Sachesi tutorial thread. I have no idea why anybody would not update after doing this myself. Did not have to backup my device and everything is now working perfectly.
    PowderJockey likes this.
    10-20-14 03:03 AM
  25. ridersinc's Avatar
    RLTurn77...greatly appreciated! I'll provide an update this week when I go through the process.

    Posted via CB10
    10-20-14 01:14 PM
27 12

Similar Threads

  1. update 10.3.0.908 now in progress
    By freeyo in forum BlackBerry Passport
    Replies: 6
    Last Post: 10-18-14, 06:21 PM
  2. New update just loaded through Telus. Problem
    By unleash the Z in forum BlackBerry Passport
    Replies: 11
    Last Post: 10-18-14, 11:54 AM
  3. OTA Updates Vodafone
    By ChrisAmbrose in forum BlackBerry Passport
    Replies: 1
    Last Post: 10-17-14, 05:39 PM
  4. Just got a software update.
    By campbecw in forum BlackBerry Passport
    Replies: 13
    Last Post: 10-17-14, 05:29 PM
LINK TO POST COPIED TO CLIPBOARD