1. RichardHBB's Avatar
    Passport SE recent purchase, running 10.3.2.2836

    I've seen the multiple threads here about proximity sensor issues on Passports, not sure that's what is going on with my device, though.

    1. When I make a call, if I put the phone to my ear briefly after tapping to complete the dialing, the screen does not turn off. If I take the phone away from my ear for just a moment and then put it back, the screen will turn off. It's as if there is a lag in responding to the proximity sensor. This is fairly consistent behavior.

    2. A little less consistent but still very often, when I press the power button to unlock (I have disabled swipe to unlock to prevent pocket dialing), the screen does not immediately come on. It will after a short pause, maybe one second. I am not anywhere near the proximity sensor when this happens, for what it's worth.

    Proximity sensor behaves completely normal in BBVE. The very instant I get near it, the "near" test passes. Far test stays "passed"

    This isn't a huge issue but it is kind of annoying, and definitely not something I ever experienced on my Z30 running the same OS version.

    Any ideas?

    Richard
    12-08-16 08:44 AM
  2. The_Passporter's Avatar
    You have to wait for the screen to change from the dialing screen to the actual call. That is what's happening. Once the screen changes to the call screen it then will initiate the sensor.
    12-08-16 09:04 AM
  3. mad_mdx's Avatar
    Turning off swipe to unlock is useless. I've never pocket dialed from my device and I've never had it off.
    Have you tried turning off advanced interactions?
    For the record, I've had my passport since launch and there is always a short delay, about half a second to a second, to go from screen off to on. Regardless of method of unlocking.
    If you're device is busy in the background that might slow things down too
    Posted via CB10
    12-08-16 09:28 AM
  4. RichardHBB's Avatar
    You have to wait for the screen to change from the dialing screen to the actual call. That is what's happening. Once the screen changes to the call screen it then will initiate the sensor.
    I understand that, but I never had this issue with my Z30. Tap to dial, phone to ear, screen goes off - every time. I thought the Passport had a faster processor?

    Turning off swipe to unlock is useless. I've never pocket dialed from my device and I've never had it off.
    Have you tried turning off advanced interactions?
    For the record, I've had my passport since launch and there is always a short delay, about half a second to a second, to go from screen off to on. Regardless of method of unlocking.
    If you're device is busy in the background that might slow things down too
    Posted via CB10
    I respectfully disagree about turning off swipe to unlock. I have absolutely had trouble prior to disabling it. Had my phone in my pocket while cutting the grass and pulled it out later to find it had literally gone down nearly my entire contact list dialing each one, nice and early in the morning. This was my Z10 but no reason any other BB10 device wouldn't do the same.

    Advanced interactions are off; I don't use 'em.

    As far as busy in the background, I generally don't leave anything running, by habit.

    Richard
    12-08-16 10:09 AM
  5. gmr1987's Avatar
    When I dial and put the Passport to my ear immediately, it does that too. I always have to wait until it shows calling. Always been like that, and I've almost gotten used to it after thousands and thousands of minutes.........

    Behold, my thumbs have spoken.
    12-08-16 04:21 PM
  6. mad_mdx's Avatar
    I understand that, but I never had this issue with my Z30. Tap to dial, phone to ear, screen goes off - every time. I thought the Passport had a faster processor?


    I respectfully disagree about turning off swipe to unlock. I have absolutely had trouble prior to disabling it. Had my phone in my pocket while cutting the grass and pulled it out later to find it had literally gone down nearly my entire contact list dialing each one, nice and early in the morning. This was my Z10 but no reason any other BB10 device wouldn't do the same.

    Advanced interactions are off; I don't use 'em.

    As far as busy in the background, I generally don't leave anything running, by habit.

    Richard
    Well the passport is a lot harder to swipe to unlock, the z10 was surprisingly really good at doing that well. Anyway if you don't need it it doesn't matter.

    How long is the delay ? Can you make a video of it?

    Posted via CB10
    12-08-16 10:11 PM
  7. pkadasi's Avatar
    Same here. That was the only reason I was waiting for the OS update so much. Unfortunately, this bug has not been fixed.

    Posted via CB10
    12-08-16 11:48 PM
  8. RichardHBB's Avatar
    mad_mdx: my apologies; I was mistaken when I said advanced interactions were off. I generally do keep them all off, but I checked last night and saw that all were off -except- "hold to stay awake" which I may have overlooked since you have to scroll down to see it. Not sure how that one got turned on as I don't honestly believe I intentionally enabled it.

    Now that I've turned off "hold to stay awake" the intermittent pause when unlocking the phone seems to have gone away, which is a nice change. Doesn't make a whole lot of sense but I'll take it.

    Still has the lag when placing a call; have to wait a few moments before placing the phone to my ear. Very consistent, and pretty annoying since my Z30 doesn't do this on the same exact O/S version.

    Richard
    12-12-16 08:26 AM
  9. mad_mdx's Avatar
    mad_mdx: my apologies; I was mistaken when I said advanced interactions were off. I generally do keep them all off, but I checked last night and saw that all were off -except- "hold to stay awake" which I may have overlooked since you have to scroll down to see it. Not sure how that one got turned on as I don't honestly believe I intentionally enabled it.

    Now that I've turned off "hold to stay awake" the intermittent pause when unlocking the phone seems to have gone away, which is a nice change. Doesn't make a whole lot of sense but I'll take it.

    Still has the lag when placing a call; have to wait a few moments before placing the phone to my ear. Very consistent, and pretty annoying since my Z30 doesn't do this on the same exact O/S version.

    Richard
    I keep that 'hold to stay awake' on as its a really great feature, but interesting to see its actually solved the slowdown! Very strange.

    Maybe a os reload would fix your call problems but I think it's not worth it.


    Posted via CB10
    12-12-16 05:01 PM

Similar Threads

  1. What is the best version of Audible to use on the Passpoort?
    By waxler900 in forum BlackBerry Passport
    Replies: 9
    Last Post: 12-13-16, 01:03 PM
  2. Passport and google Play services... I could google it but...
    By Garlic_aroma in forum BlackBerry Passport
    Replies: 9
    Last Post: 12-08-16, 05:34 PM
  3. q10 white bb mobile how to unlock
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-08-16, 01:39 AM
  4. Can anyone reccomend a smart watch to pair with passport?
    By howsjau in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 12-07-16, 11:43 PM
LINK TO POST COPIED TO CLIPBOARD