1. ditsura2042's Avatar
    Have had a Passport for the past 3 years, was very pleased with the device until a week ago. In the past week I've had issues connecting to my network carrier, with the phone saying "Emergency Calls Only". I get spotty or no coverage in locations where I was able to get a 4G connection, and no incoming calls at all. On wifi, the apps and data usage works perfectly fine. Also, while this is going on, the top right side of the screen, near the volume controls, gets quite hot.

    Not sure what's wrong, but wondering if there's anything that can be done to save it, or should I just switch to a Priv.
    03-25-17 07:31 AM
  2. rbtg's Avatar
    i would try to replace the sim card
    since it's not totally functional it's worth trying a data wipe
    03-25-17 09:48 AM
  3. Old_Mil's Avatar
    This is about the sixth thread describing this problem. It is a known hardware failure mode for all models of passport running all variations of BB10.

    It is unclear whether this is a fault with the motherboard or the antenna but no one has found a solution aside from replacing the phone.

    Given the number of people reporting this it is probably just a matter of time till all passport owners experience this.
    03-25-17 02:01 PM
  4. garryville's Avatar
    I've had my phone for the last 3 years as well, and being wondering if the last update had changed something in the update. I'm wondering if the hardware is a little different and new update caused this issue.

    Sort of pisses me off, I haven't found a way to go back to older version to check if the update is the problem.

    Anyone have a way to go back a update or 2?

    thanks in advance
    03-25-17 03:03 PM
  5. Mojarch's Avatar
    Hi!
    I'm experiencing this too!
    Well funny part is that it is almost a month that I got my passport silver edition!

    Posted via CB10
    03-25-17 08:38 PM
  6. krazyatom's Avatar
    I do have multiple passport and I don't have this issue. Sadly, I don't have 10.3.3 updates yet. I have att passport and unlocked Og passport from uk and my tmobile USA. I haven't heard anyone with tmobile having this issue if I am correct. Maybe is carrier related issue?

    Posted via CB10
    03-25-17 11:18 PM
  7. Old_Mil's Avatar
    We have t-mobile and have a second passport developing this issue. Originally I thought it was a t-mobile tower upgrade incompatibility, then a problem with 10.3.3, before realizing it was a hardware flaw with the passport itself independent of carrier, versions of BB10, and versions of the passport.
    03-26-17 09:34 AM
  8. ditsura2042's Avatar
    Replaced the SIM twice, still no solution. Will try the data wipe.
    04-15-17 01:05 AM
  9. Walter Rubin's Avatar
    Nothing works. Did all that! Only solution unfortunately is to buy an Iphone 8 if they make a larger screen.

    Posted via CB10
    04-27-17 03:03 PM

Similar Threads

  1. Replies: 5
    Last Post: 03-26-17, 02:08 AM
  2. No longer about to access Rogers/Yahoo calendar
    By luvsql in forum BlackBerry Passport
    Replies: 6
    Last Post: 03-25-17, 09:00 PM
  3. Showbox no longer working after 10.3.3
    By MaxR_A in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 03-24-17, 01:19 PM
  4. Blackberry Link - Not connecting to Laptop
    By Warrior_Scholar in forum BlackBerry Passport
    Replies: 2
    Last Post: 03-24-17, 08:25 AM
  5. No option to add email in bb os v.7.1 in bold 9790
    By kumarabhilash212 in forum Ask a Question
    Replies: 3
    Last Post: 03-23-17, 09:33 PM
LINK TO POST COPIED TO CLIPBOARD