1. scienceboy's Avatar
    Just got my new passport, which is great, but the Amazon store won't open and I can't load any sideloaded apps... suggestions? The green line never finishes with amazon and then it crashes

    Posted via CB10
    11-06-14 05:21 PM
  2. robsteve's Avatar
    Try downloading the Amazon app store from the Amazon web site and install it. I think the url is amazon.com/getappstore.



    Posted via CB10
    aha and 93Aero like this.
    11-06-14 05:44 PM
  3. scienceboy's Avatar
    Thanks, but it won't process any apk files... some sort of problem With the runtime?

    Posted via CB10
    11-06-14 06:19 PM
  4. Carjackd's Avatar
    Dumb question, but you have set the device to allow apps from other sources?

    "Official International Accountant of the Peevishlicious Crew " via my Canadian Passport!!
    11-06-14 06:21 PM
  5. Keepin_Pace's Avatar
    Yes. You have to allow other sources for install. Then you can get the updated amazon store app. You'll be good to go after that

    Posted via CB10
    11-06-14 06:31 PM
  6. scienceboy's Avatar
    Yep, that's enabled. I think something went wrong during setup... my computer now tells me I need to unplug my passport and finish setup using the setup app. Only that app doesn't give me any options to complete setup

    Posted via CB10
    11-06-14 06:41 PM
  7. johnnyuk's Avatar
    Have you restarted the phone?

    Just sounds like the Android runtime has got itself in a twist, it happens occasionally.

    I've heard of the runtime breaking completely but it's rare. If that's happened it is fixable by reinstalling it manually (sideloading) over USB with tools like Sachesi. Or back up your data and use an autoloader to put the latest leak of 10.3.1 on your phone, that will sort it out too.

    Search CrackBerry and then forums for guides on how to do all of that.

    Posted from my BlackBerry Z30 STA100-2 /10.2.1.3247 on O2 UK - Activated on BES10.2.4
    11-06-14 07:02 PM
  8. dusdal's Avatar
    Experiencing the same thing with wife's passport.

    Tried everything except a clean wipe.

    Posted via CB10
    11-06-14 07:35 PM
  9. scienceboy's Avatar
    Okay, for anyone else who's had this problem... I ended up just reloading the OS on Link. This required me setting it up on a separate computer, but eventually I got to the right screen. As soon as the OS was reloaded everything worked fine. Very snappy
    11-07-14 07:06 AM
  10. aha's Avatar
    Try downloading the Amazon app store from the Amazon web site and install it. I think the url is amazon.com/getappstore.



    Posted via CB10
    Yeah that solved it for me.

    Posted via CB10 with PassportSQW100-1/10.3.0.1418
    11-07-14 07:42 AM
  11. dusdal's Avatar
    Okay, for anyone else who's had this problem... I ended up just reloading the OS on Link. This required me setting it up on a separate computer, but eventually I got to the right screen. As soon as the OS was reloaded everything worked fine. Very snappy
    With or without restore?

    Posted via CB10
    11-07-14 10:53 AM
  12. JamieWilson01's Avatar
    I'd advise a hard restart. Hold both volume key's until the device reboots.

    But if that doesn't work let me know and i'll upload the runtime for you to sideload via sachesi.

    Posted via CB10
    11-07-14 12:33 PM
  13. guygardner73's Avatar
    Just got my new passport, which is great, but the Amazon store won't open and I can't load any sideloaded apps... suggestions? The green line never finishes with amazon and then it crashes

    Posted via CB10
    This happened to me after an update. I had to backup, security wipe and then restore. Since then everything is going well.

    PassportSQW100-1/10.3.0.1418 O2 UK
    11-07-14 12:42 PM
  14. dusdal's Avatar
    I'd advise a hard restart. Hold both volume key's until the device reboots.

    But if that doesn't work let me know and i'll upload the runtime for you to sideload via sachesi.

    Posted via CB10
    I've done both these so far. Many hard restarts, then sideloaded working runtime on top. No dice.

    Going to try a clean wipe and see if it works without restore.

    Thank you for the suggestions.

    Posted via CB10
    11-07-14 01:45 PM
  15. JamieWilson01's Avatar
    There is a bar file dedicated to installing apps from other sources have you tried sideloading it?


    Via CB10 from Scotland using my awesome PassportSQW100-1/10.3.0.1418
    11-07-14 03:02 PM
  16. AntJones80's Avatar
    Posted via CB10
    11-07-14 03:03 PM
  17. scienceboy's Avatar
    With or without restore?

    Posted via CB10
    No restore... I decided to start again clean. Shiny clean. My new Passport is now officially awesome

    Posted via CB10
    11-07-14 04:54 PM
  18. Coraya's Avatar
    Yep, that's enabled. I think something went wrong during setup... my computer now tells me I need to unplug my passport and finish setup using the setup app. Only that app doesn't give me any options to complete setup

    Posted via CB10
    Did you allow all permissions that the amazon app store required?

    Posted via CB10
    11-07-14 05:02 PM
  19. scienceboy's Avatar
    Did you allow all permissions that the amazon app store required?

    Posted via CB10
    Yes, it was a problem with the runtime I think. Had to reload the OS. Flawless now.

    Posted via CB10
    11-08-14 07:01 AM
  20. brian4591's Avatar
    I'm having the same issue. Tried a wipe and restore and it still doesn't work.

    Next option I am going to try is the custom restore but NOT restore the "BlackBerry runtime" app (I'll unclick that option).

    Will the runtime automatically download when I try installing a APK file?
    Should I manually install the BlackBerry runtime after restore?
    Is the runtime in BlackBerry World?
    If not in BlackBerry World does someone have a link to manually install it?

    Thanks!
    12-09-14 01:35 PM

Similar Threads

  1. Like new Unlocked White Z10 with a lot of extra
    By darkoman4 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 8
    Last Post: 11-07-14, 10:10 PM
  2. Passport - is Blend connecting through your mobile network?
    By eabbq10 in forum BlackBerry Passport
    Replies: 20
    Last Post: 11-07-14, 01:57 PM
  3. Swipe delete words problem?
    By InfinityBob in forum BlackBerry Z30
    Replies: 3
    Last Post: 11-07-14, 04:05 AM
  4. Saw My First Passport in the Wild!
    By yamahammer in forum BlackBerry Passport
    Replies: 19
    Last Post: 11-06-14, 10:34 PM
  5. Got Your Passport?
    By SteelBerry86 in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 11-06-14, 06:21 PM
LINK TO POST COPIED TO CLIPBOARD