04-06-16 04:20 AM
48 12
tools
  1. fudabb's Avatar
    Hello,

    Ive had the passport for about a month and I love it, except for the call signal strength. 95% of the time it only gives me one to two bars of signal where my z10 was a steady 4 to 5 bars always. The strange thing is that, when I make a call, or answer an incoming one the reception shoots up to full bars. As soon as I hang up, reception goes back down to one to two bars. Call quality is fine always, but Ive had about 5 calls in the past month go straight to my voicemail, which rarely happened on my z10. Im on the Rogers network in Mississauga, Ontario, Canada. The phone wasnt purchased through Rogers but instead through blackberry direct, so it is unlocked. Ive called Rogers, Blackberry, tried another sim, hard reset all to no avail. Sounds like some of you might be having similar issues. Can you please share how you resolved this.

    Thanks...
    12-12-14 08:02 AM
  2. Nasser Alomran's Avatar
    I dont know about you but I was using a Note3 handset before getting the passport. The passport has much better reception believe it or not. With my note the call used to cut off when I jumped in the lift. On the passport im surprised the call stays on one or two bars while riding the elevator to my apartement

    Posted via CB10
    12-12-14 08:48 AM
  3. doubleplusgood's Avatar
    My partner lives in a semi-rural area and a couple of weeks ago upgraded her Q10 to a BB Passport (unlocked) and activated it on the same network as her Q10 (Bell Canada). Whereas the Q10 had solid reception in her community, the Passport drops a couple of calls per day. Also, whereas the Q10 always had LTE, the Passport drops in and out of LTE. Call quality on the Passport is generally good during calls.

    To learn more we installed Signal Tracker on the Passport and on my Z30. Initial tests in a number of locations averaging over time we are seeing about an 8-10 dBm difference between the two devices. However, the tests may not be fair since the Z30 runs on Telus wheres the Passport is on Bell. My understanding is that Bell and Telus share the same towers though Bell may have more bandwidth. In the past, with the Q10 the signal strength, LTE connectivity and download speeds were not noticeably different to those of my Telus Z30.

    We also performed some speed tests using Traffic Monitor. The Z30 was typically running 50-80% faster on download. Interestingly enough the Passport was showing about 1/2 the latency. However, I expect those differences may well be due to network tuning differences between Bell and Telus.

    One of the more interesting failures of the Passport occurs on her ferry commute where she often has no service at all whereas the Q10 would typically maintain a connection throughout, sometimes bettering my Z30.

    Today we discussed the problems with Bell who acknowledged that calls on the Passport were being dropped due to poor reception. However, they seemed to think this is due to network issues in the last two weeks. I am skeptical due to the fact this never occurred on the Q10. We also contacted BlackBerry support. The agent we spoke to said she has had a previous call on this topic. She went on to recommend a security wipe and if that doesn't work requesting a new SIM card from Bell. I'm not too sure why either of these would help but if things don't improve I may try the alternate SIM.

    One thing I have noticed is that sometimes, for short periods of time the Passport shows better power readings than the Z30. This leads me to believe that it is not a hardware problem with the phone but some peculiarity of the radio software. So I am hoping a software update may fix the problem. If not, then we may switch the phone for a Z30 which in some respects (screen contrast, touch screen sensitivity/selectability) we prefer to the Passport.
    12-20-14 08:43 PM
  4. doxa sub750T's Avatar
    I am on TMO and don't notice anything significant either better or worse.

    Cheers

    Posted via CB10 with BlackBerry PP
    12-20-14 09:46 PM
  5. doxa sub750T's Avatar
    I should say my previous was Z10. My results are true when I roam international with TMO as well.

    Posted via CB10 with BlackBerry PP
    12-20-14 09:48 PM
  6. will308's Avatar
    Hi,

    I'm using the Passport since a few days and I'm so far happy with it.
    But there's a big BUT: The reception quality seems to be worse than that of other BlackBerrys and phones!

    Where my xperia Z ultra or my Z10 shows LTE/4G the passport is already on EDGE :-(
    Same location and carrier!

    Is my device defective or do you have the same experiences?
    you may find its down to the radio software I have had bad signal on a couple of the software versions I have loaded up
    12-21-14 01:41 AM
  7. T.W.G's Avatar
    I have the latest official update and my second Passport is still worse than Z10, Bold 9900, Xperia Z Ultra and LG Flex! So the Passport is a step backwards in terms of network quality - which is surprisingly bad!
    01-13-15 11:57 PM
  8. rolojr1's Avatar
    Ok, I experienced this issue when I transferred data from my Z30 to the Passport. I have reported this issue in threads along with other issues forum members are still complaining about. It is unfortunate that a wipe fixes this. One thing they do not mention is transferring the data from your previous device only brings back the issues. This is something BlackBerry needs to work on. I had to do a wipe and NOT transfer system settings. I used device switch to import contacts and did everything else manually back in October.

    BlackBerry has updated Link and device switch app few times so I'm not sure if the initial issues I experienced have been corrected but my Passport is working phenomenally. The issues I'm reading about aren't occurring anymore. The reception is awesome.

    When I transferred my data from my Z30 I experienced poor signal performance, Passport heating up, random memory and battery drains. I thought it was a defective Passport. The same thing occurred when I transferred my data from my Bold 9780 to the Z10. I did a wipe and installed manually.

    I know it's a pain and it's inconvenient but wiping and installing everything manually worked. My Passport is working beautifully now.

    Posted via CB10
    01-14-15 03:03 AM
  9. T.W.G's Avatar
    I didn't use device switch and used the Passports only synchronizing with a Google account for contacts and calendar and having these problems.
    I can try to wipe it again but I don't think that it will solve it. But your suggestion is worth a try!
    01-14-15 03:12 AM
  10. ioan_calin's Avatar
    Replaced two Passports due to bad call quality and poor signal reception. The Classic (in my opinion) is far superior. My love "affair" with Passport is over. Will not try the third one. Happy with the Classic so far. When I got the second Passport, it would have little to less signal in areas where now th Classic has 2 or sometimes three lines of signal. The sound of my voice sounded muffed and remote. When I got to the Classic, everyone congratulated me on how nice and clear my voice was. So, for me, no Passport. But again, maybe I wasn't lucky...
    07-04-15 03:36 AM
  11. shawnreum's Avatar
    Hi,

    I'm using the Passport since a few days and I'm so far happy with it.
    But there's a big BUT: The reception quality seems to be worse than that of other BlackBerrys and phones!

    Where my xperia Z ultra or my Z10 shows LTE/4G the passport is already on EDGE :-(
    Same location and carrier!

    Is my device defective or do you have the same experiences?
    I'm going to take a wild guess that your previous devices were carrier specific?
    If that's correct, the unlocked Passport falls under the carriers terms as a non carrier branded device and is subject to de prioritized service.
    Also carrier specific devices are set up to be optimized for the network as the Passport is not. So you'll have some issues there also.

    But I have been thru three OS on my Passport, the original OS that came on my phone was most definitely the best for network selection.

    I have instances where my Passport has LTE but the other phones can't pick up service.

    So back to your question,
    Even though the other phones seem to connect perfectly and your Passport doesn't. It is probably just fine for its self but has a lot against it for a non carrier branded phone.
    Try calling your provider and ask them to reset the Sim card to their network, it might help. Or tell them that your issue, they might be able to adjust things on their end.

    Posted via CB10
    07-04-15 07:51 AM
  12. Ziro1's Avatar
    I started my passport with AT&T and I was missing calls in my house, so I went to the store and they suggested that I buy their signal booster which was $150, i cancelled AT&T and went to TMobile and they gave me their signal booster for free.
    I plugged in in my house and I still get dead signals in some rooms.
    I am frustrated also, my z30 which was on verizon never had that issue.
    07-04-15 08:18 AM
  13. BallJohnsonDance's Avatar
    I've been having issues for over 3 weeks now..after switching from t mobile to at&t I noticed I was having the same issues unless I was extremely close to the cell towers in my area of florida.ive spend about 5 hours over the last few days on the phone with blackberry trying to troubleshoot the problem to no avail and now they won't even replace the phone I have to send to them to be repaired

    Posted via CB10
    07-07-15 11:45 AM
  14. CFFrost's Avatar
    In my case my phone never ever dropped below H+ since I got it and internet moves amazingly fast, so fast that I already used up 9GB of mobile data in one month.
    07-07-15 04:52 PM
  15. gonka95's Avatar
    I have the exact issue. I live in the middle of nowhere for cellular service and get 2 bars on AT&T with Classic but Passport has nothing.
    07-07-15 04:55 PM
  16. anon(870071)'s Avatar
    I think this issue is mainly a srvice provider issue! You may be in a fringe area. But i'm on rogers wireless and I know they three bands of LTE in my city.

     Passport SQW100-1 / leak 10.3.2.2204 Rogers Wireless Posted via CB
    07-10-15 11:28 AM
  17. Apple Aya's Avatar
    Well I can't really comment on previous BlackBerries because the Passport is my first one, but it is far better than any other phone I've ever had. Most of those have been Samsungs and one HTC. The Passport even makes it through one part of my indoor parking garage that would completely cut out on other phones....through thick concrete walls and all. Unbelievable.

    But my friend who also has a Passport said that his Torch had even better reception/signal strength so maybe there's something to that.
    07-10-15 12:35 PM
  18. ilcasalino's Avatar
    I've ask for help at BlackBerry and they suggested me to ask to my carrier for a new SIM.
    And yes now the signal is better.
    So the problem could be a defective SIM.
    10-24-15 01:42 AM
  19. yyz321's Avatar
    I've ask for help at BlackBerry and they suggested me to ask to my carrier for a new SIM.
    And yes now the signal is better.
    So the problem could be a defective SIM.
    This is probably the quickest or easiest first troubleshooting step to rule out the SIM card. The Passport does have better reception than my Z30 (subjectively) but had consistently better reception than my LG G2 since I compared both devices side-by-side using the same app to compare signal strength on the same network and cell tower.

    Posted via CB10
    10-24-15 06:32 AM
  20. anon(2325196)'s Avatar
    I haven't noticed any different in reception quality throughout all my BlackBerry 10 devices.

    Posted via CB10
    10-26-15 09:53 PM
  21. xectis's Avatar
    Tried OnePlus 2, iPhone 6 Plus, HTC one 9...and the rest. None of them come close to BB Z30 for call, network reception,speaker and battery duration quality. In my experience the Z30 is the best (so far) mobile phone ever made.
    andy957 likes this.
    10-29-15 08:38 AM
  22. syclone1978's Avatar
    I too have terrible reception on calls, it's becoming very frustrating.

    I just received my AT&T Passport a few days ago, my Z10 but read so many posts about the Passport and just had to have it.

    I am not certain but the post here says lots of LTE and my issue isn't clear as my Passport always says LTE with 3 to 5 bars but as soon as I make a call it switches to 4G and drops to 1 bar.

    Not sure if this is similar to what anyone else is experiencing but this is my experience.

    I will add that, I am using 10.3.2.2813 on my Passport just as I was using on my Z10. Which is the exact same downloaded file. Both were loaded via Sachesi using a Blitz from a link found on Crackberry. I've never had any problems with any Blitz or Autoloader found here.

    PassportSQW100-3/10.3.2.2813 AT&T
    04-05-16 10:27 PM
  23. ichajoy2003's Avatar
    Nope, for me the reception is better, even better than my xperia z3 compact...

    Posted via CB10
    04-06-16 04:20 AM
48 12

Similar Threads

  1. Why isn't my mobile turning on and why is the LED blinking?
    By Salva7orres in forum BlackBerry Z30
    Replies: 15
    Last Post: 11-29-14, 05:13 AM
  2. Running on OS 10.3.0.908 any idea of official OS update in india.
    By hussain17 in forum BlackBerry Passport
    Replies: 3
    Last Post: 11-17-14, 12:53 AM
  3. Guys...Blackout Passport is Possible
    By deadcowboy in forum BlackBerry Passport
    Replies: 15
    Last Post: 11-16-14, 11:25 PM
  4. WTS: Bold 9900/9930 Battery and Hardshell Case
    By jrsva2008 in forum The Marketplace - Buy, Sell & Trade
    Replies: 1
    Last Post: 11-16-14, 03:31 PM
  5. BlackBerry Passport original stock ringtones
    By First777 in forum BlackBerry Passport
    Replies: 0
    Last Post: 11-16-14, 02:53 PM
LINK TO POST COPIED TO CLIPBOARD