1. Rendergroup's Avatar
    Hello, I need some help this time.

    A couple days ago I switched mobile operator, my device was working perfect in 4G with the previous provider.

    When I switched the new provider I could get to change to 4G, even though I have set in 4G & 3G & 2G Network Mode, another issue that I have is I can't change the APN settings for this provider.

    I went to the store in order to check if my SIM is working properly and they tested in another (Android) device and was showing 4G in the screen, they make a call also to check if was working as should be.

    I have been doing updates regularly as well as some releases that some of the members of the forum posted and installed via Sachesi, no problem as all.

    I'm running the last official release of the OS, no more leaked versions installed.

    So here are my questions:

    1.- Can I install some file via Sachesi in order to get the 4G working properly?.

    2.- If I need to wipe the device (never done) can I get all my stuff restored? (Mails, contacts, chats, I mean all my stuff), I do backups regularly but never made a wipe & restore, if I need to do that, could you please give me an easy tutorial (last option).

    3.- I work in OSX environment, I've read if you need to Autoload a fresh version you need a Windows machine (I have a virtual windows in my Mac, but as far as I know that is not possible).

    Please I need help, my Blackberry Passport is in a 3G straitjacket mode.

    Thanks

    My Passport details

    Previous cel provider:

    2G ==> 1900
    3G ==> 850
    4G ==> 1900

    New Provider:

    2G ==> N/A
    3G ==> 1900
    4G ==> 1700 / 2100
    -----------------------------
    Software Release: 10.3.2.226
    OS version 10.3.2.2339
    Radio Version: 10.3.2.2340
    08-21-15 10:02 AM
  2. Technarch's Avatar
    One thing you need to be aware of is band numbering. You can have different band numbers that use the same frequency.

    In settings, about, general it will say the LTE bands. For my specific model sta100-5 z30 I only have 4,5,7.

    If your provider does not use any of those 3 then I can't get LTE.


    Posted via CB10
    08-21-15 10:20 AM
  3. dierre's Avatar
    Mines is stuck on 2g edge for the past 12 hours


    Posted via CB10
    08-21-15 11:04 AM
  4. Rendergroup's Avatar
    @Technarch thanks for your reply, my new provider uses class 4 (I saw an Iphone and Samsung phone with the 4G icon), the thing is I can't even get H+ or 3.5G.

    @dierre hope it returns to the maximum speed available, my concern is that I just switch providers, they work in 4G and my passport can't get to that

    I don't know if I should wipe and reinstall all or patch some file with Sachesi, I'm waiting a samaritan of this forum to give me some help

    I'm paying for something I can't get in my phone.
    08-21-15 11:28 AM
  5. RLTurn77's Avatar
    What carrier is it? I'm sure it wouldn't be too difficult to find out what bands they use. The SQW100-1 and even the -3 and -4 all have most LTE bands, but not sure of your location or carrier. I'd think that would be the first step to see if the device supports whatever bands your carrier uses.

    Posted via CB10
    08-21-15 11:33 PM
  6. Rendergroup's Avatar
    Hello RLTurn77 thanks for answering, my new provider is Entel, here is some info I could find in English

    Welcome to Peru | Entel

    The use this freq.

    Please request your carrier to activate the Roaming service on your subscription and validate that your device is compatible with UMTS/WCDMA 1900
    I really dont know what else to do, I want to avoid format/erase/wipe and reinstall all the OS, Apps and data (is painful to do this).

    Do I need to post this question in another thread of the forum?.

    Regards
    08-21-15 11:48 PM
  7. Rendergroup's Avatar
    For the records...

    Wiped my Passport (took more than 12 hrs).
    Installed an autoloader and still CANT GET 4G!

    I really don't know what else to do, I have to wait 2 months to return again to my old Cel Company.

    HELP Needed
    08-23-15 03:56 PM
  8. RLTurn77's Avatar
    I'm hoping someone will help with the band you posted. I believe your new carrier was WCDMA/UMTS 1900. That's not a CDMA band is it? I wouldn't think so since if it was a carrier that uses CDMA then the Passport wouldn't even work as it only works with GSM carriers.

    In the US some have had issues with LTE because of the IMEI numbers on the Silver Edition. The IMEI for the Silver Edition was only showing as a 3G device for AT&T for some. Some people just used the IMEI number from their previous phone as the Passport has all of the bands needed for LTE. There were similar issues with the original Passport and AT&T when launched.

    Other than that is your SIM card a 4G/LTE enabled SIM card? These are just the troubleshooting that we would do in the states. Basically, #1 - Make sure that the Passport has all of the bands needed that the carrier uses, #2 - Make sure that the SIM card is LTE enabled (try another SIM card if needed), #3 - Change the IMEI number if the carrier doesn't recognize the device as a 4G/LTE device or you are still having problems (you can use the IMEI number from your previous 4G/LTE device).

    There are some settings that can be adjusted, but I'm really not an expert on that so I do not feel comfortable giving advice in this case. That would be in your network and connection settings I believe.

    Posted via CB10
    08-23-15 05:45 PM
  9. Rendergroup's Avatar
    RLTurn77 thanks again

    Other than that is your SIM card a 4G/LTE enabled SIM card?

    Yes, they (the cel company) tested the SIM in another phone and showed 4G, so there's no doubt the SIM is fine.

    #1 - Make sure that the Passport has all of the bands needed that the carrier uses

    Yes, it's capable (Class 4 1700/2100)

    #3 - Change the IMEI number if the carrier doesn't recognize the device as a 4G/LTE device or you are still having problems (you can use the IMEI number from your previous 4G/LTE device).

    I think this is not possible for me, I upgraded from Bold 9780 and that device is not 4G

    That would be in your network and connection settings I believe


    That should be, but now that most of the phones are Android (Samsung, Sony, Motorola) they won't move a finger for a Blackberry , because they don't sell the new ones.

    This would be my last Blackberry, my ride has been bumpy.

    Kind regards
    08-23-15 10:17 PM

Similar Threads

  1. Passport Screen Lifted - *Fix*
    By destroyerx20 in forum BlackBerry Passport
    Replies: 14
    Last Post: 04-02-18, 09:08 AM
  2. Users of the new Passport Silver Edition, how do you like it?
    By ioan_calin in forum BlackBerry Passport
    Replies: 21
    Last Post: 08-30-15, 08:46 AM
  3. List of games that work perfectly in a square screen?
    By VoodooEx in forum Android Apps (Amazon Store & APK Files)
    Replies: 6
    Last Post: 08-23-15, 01:01 AM
  4. My blackberry Q5 says 'error' during a security wipe what do i do?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-21-15, 11:07 AM
  5. blackberry z10 3g video call
    By Suraj2 in forum Ask a Question
    Replies: 1
    Last Post: 08-21-15, 09:54 AM
LINK TO POST COPIED TO CLIPBOARD