1. PrinceOfEgypt's Avatar
    Hi all,

    My OS is currently on 10.3.2.2474...When i goto software update it says up to date...But it seems there are newer versions out?

    What is the most stable version to upgrade to please? I have an unlocked Passport SE. im in the UK if that makes any difference?

    Thanks!
    12-29-15 02:19 PM
  2. Lostboy5151's Avatar
    If you wait for your carrier to release the latest OS, you could be waiting for a long time.

    The most up to date OS is 10.3.2.2876


    http://forums.crackberry.com/bb10-le...vices-1054544/

    or

    http://forums.crackberry.com/bb10-le...aders-1054501/
    12-29-15 03:02 PM
  3. anon(8050899)'s Avatar
    Hi all,

    My OS is currently on 10.3.2.2474...When i goto software update it says up to date...But it seems there are newer versions out?

    What is the most stable version to upgrade to please? I have an unlocked Passport SE. im in the UK if that makes any difference?

    Thanks!
    This is also my present version (10.3.2.2474). Everything is fine. However, I don't use any Android apps.

    Posted via CB10
    12-29-15 03:15 PM
  4. GodGibson's Avatar
    Just do an OTA upgrade im running 2876 it's got a bug in it with the android runtime so the previous 28XX series is better

    Posted via CB10
    12-29-15 03:24 PM
  5. xueyaotianxia's Avatar
    I updated my phone to 2474 today. It seems better with android apps. They run faster and smoother...hope the new one will be better again.

    Posted via the CrackBerry App for Android
    12-29-15 03:29 PM
  6. PrinceOfEgypt's Avatar
    Its seems that 2876 is very buggy and 2813 is stable, especially if you are running android apps?
    12-29-15 03:58 PM
  7. Lostboy5151's Avatar
    Considering I have 19,000 more posts than all you put together and have been a positive helpful member for many years, I'd consider going with my suggestion!
    My point... "It seems" doesn't even belong in the conversation.

    I KNOW what I'm talking about!!

    (in my opinion, of course)
    12-29-15 08:08 PM
  8. Lostboy5151's Avatar
    Just do an OTA upgrade im running 2876 it's got a bug in it with the android runtime so the previous 28XX series is better

    Posted via CB10
    Another helpful suggestion...
    Don't EVER download/update a large file (like an OS) OTA. The slightest glitch can cause a file to corrupt. Always go hardwired when you can.
    2813, 2876 and any future BB10 OS upgrades will be fixes and maintenance and you can't go wrong with those kind of updates.

    If you're running 10.3.2.2876 and are having issues, It's NOT because of the software.
    Also, you should be rebooting your device on a regular basis.

    Bottom line... I've had Blackberry's since around 2005 and have Never had a single issue with any of my devices. So, you can go with what "seems" to work or read up a bit more on how things DO work.

    (in my opinion... of course)
    12-30-15 11:04 AM
  9. PrinceOfEgypt's Avatar
    Thanks Lostboy!

    Where do i download these build from? All the links seem to be dead?
    12-30-15 11:48 AM
  10. conite's Avatar
    I would go with 10.3.2.2813. The latest, 10.3.2.2876 has a catastrophic bug with the Android Runtime.

    Although if you know what you're doing, load 2876 and then sideload the two Android bar files from 2813.
    12-30-15 11:52 AM
  11. PrinceOfEgypt's Avatar
    where can i get 10.3.2.2813 from please?

    Thanks
    12-30-15 12:27 PM
  12. conite's Avatar
    where can i get 10.3.2.2813 from please?

    Thanks
    You can start with the 2813 thread:

    http://forums.crackberry.com/showthread.php?t=1051879
    12-30-15 12:30 PM
  13. PrinceOfEgypt's Avatar
    Many thanks!

    Would i need to download the core and radio file for the passport?
    12-30-15 01:05 PM
  14. conite's Avatar
    Many thanks!

    Would i need to download the core and radio file for the passport?
    If you want to do a non-destructive update, you need to download and then extract all of the apps from the debrick file first. Download the core and radio for your device and put them in the same folder as all of those apps. Then move the entire folder into Sachesi. (Apps + Core + Radio)
    12-30-15 01:20 PM
  15. PrinceOfEgypt's Avatar
    I get this error when trying to update!

    Most stable OS to update to? Currently on 10.3.2.2474-capture.jpg
    12-30-15 04:22 PM
  16. conite's Avatar
    I get this error when trying to update!
    It will do that on the Passport. Just ignore the warning.
    Last edited by conite; 12-31-15 at 08:16 AM.
    Lostboy5151 likes this.
    12-30-15 08:09 PM
  17. PrinceOfEgypt's Avatar
    It will do that on the Passport. Just ignore the warning.
    That worked like a charm!
    12-31-15 06:14 AM
  18. Lostboy5151's Avatar
    And another happy ending. Thanks to Conite!

    Happy New Year to you and all our helpful Members!
    12-31-15 01:46 PM
  19. meniidol's Avatar
    I have my passport since september and I had a lot of problems with the heat and withe the constant rebooting, when opening the camera and some apps, I did the update to 2836 from 2747 and I think this problem is solved, thank god, so if one of you have the same issue update now!! Grettings!

    Posted via CB10
    12-31-15 05:34 PM

Similar Threads

  1. U8 Smartwatch - impressions I'd like to share
    By New_England in forum BlackBerry Passport
    Replies: 19
    Last Post: 12-07-16, 05:58 PM
  2. Problems with OS
    By miko2097 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 01-31-16, 11:15 AM
  3. Advice on switching to a Passport from a Galaxy S6?
    By xSkyer in forum BlackBerry Passport
    Replies: 29
    Last Post: 01-01-16, 10:12 AM
  4. New Z30. How to custom Home-screen?
    By mien742 in forum Ask a Question
    Replies: 5
    Last Post: 12-29-15, 09:59 PM
  5. Can I unlock my AT&T Z10 so I can use it on Verizon?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 2
    Last Post: 12-29-15, 01:25 PM
LINK TO POST COPIED TO CLIPBOARD