1. ElGorgon's Avatar
    Ok guys, I noticed since I got passport that I have a considerably amount of missed calls.
    Now I discovered that passport turn off call sound when u touch screen in any point, so when I got it in my pocket and not being absolutely static, the phone just got silenced almost immediately when someone is calling, and this is very disturb for me cause I need it for working.
    Any way to fix this? G.

    Posted via CB10
    zmsox likes this.
    10-19-14 03:54 AM
  2. sgt_snacks-64's Avatar
    The issue is that touching anywhere on the screen silences the notification. I've trundled through the phone settings and can't find anyway to actually change this :/ therefore there isn't a setting to disable it unfortunately, from what I can see anyway.

    No wonder I kept missing calls on my Z30....


    Check this
    http://forums.crackberry.com/showthread.php?t=948782
    Posted via CB10
    ElGorgon likes this.
    10-19-14 04:10 AM
  3. zmsox's Avatar
    Same problem here. We need a case or a os update.

    Posted via CB10
    10-19-14 07:12 AM
  4. realpete's Avatar
    Actually I experienced this issue also on my Z10.
    10-19-14 07:21 AM
  5. kbz1960's Avatar
    If your phone is locked in your pocket how does it get touched to disable the sound? And doesn't the sound have to "sound" before it gets disabled by touching?
    10-19-14 07:30 AM
  6. ElGorgon's Avatar
    If your phone is locked in your pocket how does it get touched to disable the sound? And doesn't the sound have to "sound" before it gets disabled by touching?
    Ok, when the screen side is touching my leg, the screen detects something and silent the call...and I don't like to put the screen looking out in my pocket, any litle impact goes to your screen...
    And no, the disable is so fast that there is almost no sound...


    Posted via CB10
    10-19-14 07:59 AM
  7. MobileMadness002's Avatar
    At least you know root cause. Time to act accordingly.
    10-19-14 09:29 AM
  8. StevenChoi's Avatar
    Ok guys, I noticed since I got passport that I have a considerably amount of missed calls.
    Now I discovered that passport turn off call sound when u touch screen in any point, so when I got it in my pocket and not being absolutely static, the phone just got silenced almost immediately when someone is calling, and this is very disturb for me cause I need it for working.
    Any way to fix this? G.

    Posted via CB10
    Even with vibrate?
    10-19-14 10:13 AM
  9. DuexNoir's Avatar
    Even with vibrate?
    Yes, I just tried it. I always have my phone in a case, so I never knew you can do this. But this can be problematic, as people have posted.

    Posted via CB10 on my Z10
    10-19-14 10:34 AM
  10. vladi's Avatar
    Touching the screen will silence the call on all BB10 phones from what I can tell. It could be an issue with the bigger screen so I can see why they should include a slider for it somewhere in the settings. I quite like the actual feature instead of hunting for the soft or hardware buttons.
    10-19-14 11:03 AM
  11. fanisk's Avatar
    Was same on the Z30.

    Sent from my BlackBerry Passport
    10-19-14 12:42 PM
  12. Allgoodnicknamesaretaken's Avatar
    what if you set up a picture password to unlock the phone? does touching the screen still silence the calls when it's fully locked?
    10-19-14 07:05 PM

Similar Threads

  1. How can I make a call through Viber using BlackBerry 9800?
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 06-05-15, 09:15 PM
  2. Replies: 1
    Last Post: 10-19-14, 01:21 AM
  3. Next lot of passports
    By jskerutis in forum BlackBerry Passport
    Replies: 1
    Last Post: 10-19-14, 12:19 AM
  4. Couple of PP related Questions
    By thecarrot in forum BlackBerry Passport
    Replies: 5
    Last Post: 10-18-14, 07:06 PM
  5. Passport Out of Stock again on Shop Blackberry!!
    By Keith Pappachen in forum BlackBerry Passport
    Replies: 1
    Last Post: 10-18-14, 05:15 PM
LINK TO POST COPIED TO CLIPBOARD