1. tplcem's Avatar

    First of all let me tell you that I have bought my Passport in November 2014 from a seller on internet (Blackberry does not officially sell phones in my country) and because I was very excited to get my first BB phone and also very stupid, I didn't buy from the ones which come with a warranty (it was already very expensive - I paid 1000 USD in total at that time).

    So, I was happily using my phone for a few months until it gave an OS error one night while it was charging and wanted me to wipe the device and install the OS again. The problems started after this, after I did the wipe it started to do constant reboots. It booted, let me install the phone for a few seconds and rebooted itself again until it drained its battery. When it booted successfully and let me completely install the device then it gave an "Unknown SIM error" or something like that, I can't remember.

    I was completely helpless, I couldn't do anything to fix my device. I used autoloaders, downgraded the OS several times, didn't restore the former memory (backup) etc... No luck. Then I talked with the seller and then understood he was a jackal. I contacted Blackberry support on Twitter but I guess actual humans do not offer tech support via Twitter, only a help bot and when this bot understood I have a bad problem it told me to bring the device to the original place of sale and shut me out completely, without further replying to my messages. I wrote on Crackberry and other BB forums on the internet and no one could find any solution. Also, as an insult to injury, an American user told me to go f.ck myself and also told me that this would happen to you if you live in a "sh.tty 3rd world country".

    I gave up and started to use my old phone, then bought an iPhone few months later. But yesterday I wanted to power the Passport up again with the hopes of using it as a secondary phone - if it works that is.

    It actually started to work. It booted itself and was fine, then it updated the software to the latest one and the damned reboots started again. I downgraded it to the old version using an autoloader, the reboots stopped but now it randomly reboots throughout the day (maybe once or twice).

    I have taken some notes to tell you about the current problems of the device using the Blackberry Virtual Expert. Here they are:

    - The audio jack does not work. I have tried it with different headphones.
    - I cannot adjust the audio levels of the phone using the volume buttons. The thing is, the buttons work when I try to take a screenshot or do a full boot but does not adjust the sound levels.
    - GPS works in "Maps" app but does not work in BB Virtual Expert.
    - Camera cannot start sometimes
    - "Unknown error" still persists.

    Model : SQW100-1
    OS Version :

    Is this a hardware problem or a software problem?
    08-22-16 12:02 PM
  2. shawnreum's Avatar
    It could bee either a hardware or software problem by the sounds of it.
    08-22-16 08:22 PM
  3. coffee-turtle's Avatar
    Some of those problems could be related to the type of autoboot loader you used. Are you sure you are using the latest and greatest? Passport:


    08-23-16 01:04 PM
  4. dusanvn's Avatar
    It's hardware error. Probably flash memory damage.

    Posted via CB10/BB PP SE.
    09-03-16 03:34 AM

Similar Threads

  1. Replies: 2
    Last Post: 08-22-16, 03:25 PM
  2. Is there any way to make a photo collage on my Blackberry Z30?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 08-22-16, 02:26 PM
  3. I can not backup my Passport to either of two Macs.
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-22-16, 12:02 PM
  4. Disney my experience app
    By zzbsb in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 08-22-16, 11:38 AM
  5. why doesn't my password protection hold?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 08-22-16, 11:06 AM