1. AlwaysTantric's Avatar
    a few months ago the usb charging port on my passport had to be replaced. for some reason blackberry repair reset my phone. and my hub has been acting screwy ever since.
    the main issues all seem to be hub related:

    HUB goes blank: can't see any messages, they pop up every once in a while but stays blank most of the time.

    Slow messages: my messages, like texts, come in slow as hell. the notification will sound but I can't see them. Emails are coming in hours after they have been recieved

    It is taking forever for my device to charge, especially in the car using a blackberry brand car charger.

    I have restored my phone 3 times since getting it back and it keeps doing it. anyone have any suggestions or know what the problem may be?

    it just seems like ever since they "repaired" my phone, its been acting horribly. other than the usb port my phone was working perfectly
    06-22-16 11:11 PM
  2. SeeBeeEss's Avatar
    Sounds like you need to send it back for repair again.
    06-22-16 11:17 PM
  3. AlwaysTantric's Avatar
    I hope I wouldn't have to send it back. it seems like a software issue.
    06-22-16 11:22 PM
  4. SeeBeeEss's Avatar
    Although some of your problems sound like they could be software issues, taking forever for the device to charge sounds more like a continuing hardware issue.
    06-23-16 08:00 AM

Similar Threads

  1. BlackBerry annual and special meeting 2016 transcript
    By Bla1ze in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 06-24-16, 05:01 AM
  2. Snap app login issues
    By John Pundyk in forum Ask a Question
    Replies: 5
    Last Post: 06-23-16, 12:29 AM
  3. Replies: 4
    Last Post: 06-23-16, 12:05 AM
  4. Replies: 1
    Last Post: 06-22-16, 09:50 PM
  5. How do I get my screen to rotate on the BlackBerry Passport?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 1
    Last Post: 06-22-16, 08:45 PM