1. Lawrence Gan's Avatar
    Hi guys,

    Recently got a BB. Today, after I disconnected from Link, I found that my hub froze there and I couldn't swipe back. However, everything else is fine. Does anybody know what cause this? I did install some android apps such as clean master, would that be the cause? It never happened before. Attachment 326451

    Battery also have draining issues, even it says like two days, I don't feel that way, it goes very quick. Hub froze and battery issues-img_20150110_162115.jpgClick image for larger version. 

Name:	IMG_20150110_162115.jpg 
Views:	96 
Size:	89.5 KB 
ID:	326452

    Using latest version of BB OS. Not a very heavy user for this device.

    Did I get a defective device?
    Last edited by Elessar.cm; 01-10-15 at 02:14 PM.
    01-10-15 11:33 AM
  2. Lawrence Gan's Avatar
    Anybody here?
    01-10-15 01:04 PM
  3. TrueKulcha's Avatar
    First thing in order would be a hard reset with volume up / down keys. Not familiar with your apps so don't have an opinion there.

    NewsFlash! The highest rankin g American citizen is using a BlackBerry
    01-11-15 06:56 AM

Similar Threads

  1. HOW TO: receive News directly as a Notification at the HUB
    By QtHelex in forum BlackBerry 10 OS
    Replies: 13
    Last Post: 03-09-15, 03:39 AM
  2. Bridge and 10.3.1
    By akavbb in forum BlackBerry PlayBook OS
    Replies: 10
    Last Post: 03-07-15, 11:18 AM
  3. Z10 battery problem...
    By archieAPC Z10 in forum Ask a Question
    Replies: 2
    Last Post: 01-11-15, 01:22 PM
  4. BlackBerry Classic Battery
    By bbdubai in forum Ask a Question
    Replies: 5
    Last Post: 01-10-15, 02:21 PM
  5. Replies: 0
    Last Post: 01-10-15, 11:31 AM
LINK TO POST COPIED TO CLIPBOARD