03-25-15 12:29 PM
50 12
tools
  1. ce71's Avatar
    So, I purchased a new Passport from AT&T yesterday and began to realize I had a problem before I even left the parking lot. Either the GPS in the Passport is a super cheap, piece of trash, or my Passport happens to have a defective GPS. First, the BB10 Maps app could not find my location for about 10 minutes... this was after a few restarts. Once I finally began my trip home, GPS navigation seemed to either not work at all or just intermittently at times. I was tempted to turn around and return the device but it was the last one left. Besides, I wanted to get home to download the latest updates and then try a different map application, etc.

    Anyway, the only way I was able to successfully navigate home was to turn on the Passport's Mobile Hotspot and then use my Z30 (no sim, just wireless internet connection). By the way, the Z30's GPS/app performed flawlessly the entire time, so this was not an issue with not finding a clear view of the sky for the Passport, etc.

    Before I reluctantly return the device, I want to ask other Passport owners how their GPS performs... just to rule out the highly unlikely possibility that Blackberry just happened to use a cheap GPS in the phone.

    Thoughts?
    02-26-15 03:13 PM
  2. mgmueller's Avatar
    I've used all leaks and GPS seemed fine.
    Now I'm on the latest official OS and GPS is off by about 3 to 5 meters.
    Else all works fine and I can live with that kind of deviation. Responsive and stable.

    Posted via CB10
    ce71 likes this.
    02-26-15 03:23 PM
  3. robsteve's Avatar
    I have had problems and it seems to be carrier related. I am on Eastlink and when I disable LTE and use 4G the GPS works. I think on some cell sites the assisted GPS is not working right. Not a Passport problem in particular, as I noticed this with my Q10 when I first switched to Eastlink.
    MobileMadness002 likes this.
    02-26-15 03:36 PM
  4. ce71's Avatar
    Interesting. I think I'll disable LTE and give it a test. I really don't want to return this phone and have to wait for one to be sent in the mail. I'm shamelessly addicted.

    Thanks for the suggestion!
    02-26-15 03:38 PM
  5. sesp9's Avatar
    My GPS is not working at all. I'm on at&t with os 10.3.1.1372. I keep getting an error message saying can't find your location. Even though my location services is turned on.


    My newfound, astound, profund, round...Passport
    02-26-15 05:59 PM
  6. MobileMadness002's Avatar
    I have had problems and it seems to be carrier related. I am on Eastlink and when I disable LTE and use 4G the GPS works. I think on some cell sites the assisted GPS is not working right. Not a Passport problem in particular, as I noticed this with my Q10 when I first switched to Eastlink.
    I think it was you that turned me in this direction as well. GPS was horrible on my Z30 till I did the same thing as you and then,,, BAM, accurate to within like 3 meters. Eastlink in Dartmouth.
    02-26-15 06:12 PM
  7. ce71's Avatar
    I think I'm going to exchange mine today... just to see if it was the phone or the network. I'm starting to doubt the network is the problem because when I was using my Z30 on the same network with LTE... I never had a problem with the GPS.
    02-27-15 06:42 AM
  8. muellerto's Avatar
    Using a GPS normally the problem is something big near you, a house or a wall or a ship. My three GPSes work fine when I stand on flat and plane bottom. But when I'm in the mountains it becomes difficult, the result depends from where I are, especially in deep valleys. When I stand in front of a 200m rock wall I can forget the GPS. Your GPS can then tell you a position several hundred meters away from where you are. Also the altimeter can be heavily disturbed. If you have tall buildings near you don't expect too much from your GPS.
    02-27-15 07:04 AM
  9. robsteve's Avatar
    I think I'm going to exchange mine today... just to see if it was the phone or the network. I'm starting to doubt the network is the problem because when I was using my Z30 on the same network with LTE... I never had a problem with the GPS.
    The way I figured it out was to turn the cellular radio off and connect to my wife's phone's mobile hotspot. The GPS was accurate to within a meter or so. Going by this, I came to the conclusion that the inaccuracies or poor GPS coverage was not from the actual GPS in the phone, but the integration of the cellular GPS assist into the software, aGPS.

    I am on Eastlink, which will share another carrier's network when there is not an Eastlink cell site in range and I am not sure if the GPS problems is related to this or just a compatibility problem with aGPS on some towers/switches/cell sites.

    I was in Clearwater Florida last week and the GPS worked flawlessly there using a Roam Mobility SIM, which uses Tmobile towers.
    ce71 likes this.
    02-27-15 07:31 AM
  10. GLTruesdale's Avatar
    GPS works flawless on my device.

    Posted via CB10
    ce71 likes this.
    02-27-15 07:50 AM
  11. ce71's Avatar
    The way I figured it out was to turn the cellular radio off and connect to my wife's phone's mobile hotspot. The GPS was accurate to within a meter or so. Going by this, I came to the conclusion that the inaccuracies or poor GPS coverage was not from the actual GPS in the phone, but the integration of the cellular GPS assist into the software, aGPS.

    I am on Eastlink, which will share another carrier's network when there is not an Eastlink cell site in range and I am not sure if the GPS problems is related to this or just a compatibility problem with aGPS on some towers/switches/cell sites.

    I was in Clearwater Florida last week and the GPS worked flawlessly there using a Roam Mobility SIM, which uses Tmobile towers.
    You were right!

    I returned my Passport and exchanged it for a new one... walked out of the store... got into my car... turned on my navigation... and there it was - the same crappy problem. So, I was driving home and decided to turn off my mobile network... and wa-lah... the Passport's native maps application worked perfectly the entire trip home.

    With my AT&T Passport, there is no option to turn off LTE, so what can we do? Surely this issue has to be resolved at some point or many AT&T LTE users will not be happy.
    Last edited by ce71; 02-27-15 at 02:24 PM.
    02-27-15 02:12 PM
  12. mustangh2o's Avatar
    My GPS has worked flawlessly with mobile turned on since I got it last week.

    Posted via CB10
    02-27-15 02:46 PM
  13. ce71's Avatar
    AT&T LTE?
    02-27-15 03:46 PM
  14. atteberryr's Avatar
    I have had same problems. Brand new from at&t and can't find my location. It jumps everywhere. My Z10 it was perfect! Very frustrated with all the bugs with this phone.
    03-01-15 05:12 PM
  15. ce71's Avatar
    I have had same problems. Brand new from at&t and can't find my location. It jumps everywhere. My Z10 it was perfect! Very frustrated with all the bugs with this phone.
    I don't think it's the phone. As robsteve mentioned above, it probably has to do with the AT&T network.

    Do me a favor. Load up a destination in Blackberry Maps. Turns off your wireless network and tell me what happens. I did the same thing and my GPS worked flawlessly!
    03-01-15 06:30 PM
  16. anon5989741's Avatar
    My GPS on the Passport is great!

    Posted via CB10
    03-01-15 06:43 PM
  17. shotgunboss's Avatar
    it works awesome on mine


    How's your GPS?-img_20150301_193749.png

    Posted via CB10
    03-01-15 07:40 PM
  18. j_the_p's Avatar
    it works awesome on mine


    Click image for larger version. 

Name:	IMG_20150301_193749.png 
Views:	484 
Size:	104.7 KB 
ID:	338004

    Posted via CB10
    What app is that?


    Posted via my BlackBerry Passport
    03-01-15 07:57 PM
  19. shotgunboss's Avatar
    What app is that?


    Posted via my BlackBerry Passport
    mireo don't panic, uses GPS unlike BlackBerry maps which uses data

    Posted via CB10
    03-01-15 08:01 PM
  20. coufy's Avatar
    Maybe passport is badly programmed and prefer gsm signal instead of gps but depend on software aswel, if I turn off gsm all apps works fine

    Posted via CB10
    03-02-15 10:56 AM
  21. ngc's Avatar
    I posted a thread about a month ago.

    http://forums.crackberry.com/blackbe...ssport-989046/

    I've notice using RunKeeper and Cascarun that with only a few trees nearby the Passport losses the GPS signal very easily.

    This is really frustrating as I've come from a long line of iPhones that once it got GPS signal I throw it in my pocket and forget about it and never got any GPS signal loss.

    Anyone else having this problem?!?
    03-02-15 12:00 PM
  22. Machete Santa's Avatar
    Mine worked fantastic via StraightTalk and off a 5-bar 3G H signal (rural area)
    03-02-15 01:04 PM
  23. rkirshner's Avatar
    hello
    so i also have att PP. the gps or more accurately the BBmaps for directions is very poor . are there any more observations about this . is it worthwhile downloading another navigation app
    thanks
    03-07-15 05:58 PM
  24. aldebaran12's Avatar
    Only google maps use the gps, BlackBerry maps uses the cell network; crap
    03-08-15 11:42 PM
  25. Warlack's Avatar
    Not a problem here in the UK on O2.... hope it gets fixed, soon.

    Since there is little coverage in rural areas, I saw myself forced to download nogago maps as well. It's free and therefore shouldn't be a problem...

    Posted via CB10
    03-08-15 11:58 PM
50 12

Similar Threads

  1. How to change Color Of LED indicator?
    By Blackberry-Prince in forum BlackBerry 10 OS
    Replies: 8
    Last Post: 03-26-16, 02:06 AM
  2. With the new OS how do I get my text screen to have a dark background?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-26-15, 02:55 PM
  3. How to fix my Z10 after the new update?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-26-15, 02:53 PM
  4. How can I turn off the vibrate?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 02-26-15, 02:32 PM
  5. How can I turn off the vibrate when I get a text?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-26-15, 02:19 PM
LINK TO POST COPIED TO CLIPBOARD