1. KiiKeEp's Avatar
    FIX BELOW

    My Passport's proximity sensor isn't working since new.
    In BBVE I noticed that if I turn the phone upside down (screen seeing to the floor) the sensor starts working if I test with my hand and upside down.

    So, gyroscope or acelerometer related? Or the sensor isn't in the correct position.

    I pulled battery, reinstal OS, clean conectors and nothing, dunno if its easy to access to the sensor itself for cleaning.

    How many with this issue??
    Do you think its software or hardware related??

    I know I'm not the only one, lets find a fix for this

    BBVE test results: always saying ''near'', but if I rotate the phone or move it the test detect far too.
    How many Passports with proximity sensor issues?-img_20160419_230129.png

    Posted via CB10

    -------------------------------------------------

    EDIT: I Fixed it by cleaning the sensor and the glass section under it, I share you the proccess:



    So, there are several reasons why the sensor might not work.
    I recommend you try the following before disassembly:

    1. Reinstall OS
      BB10 Leaked/Beta OS - BlackBerry Forums at CrackBerry.com
    2. Battery pull or let it die (0%) for a while
    3. Contact RIM for Waranty
    4. Disassembly & clean (Which I did)


    Cheers - KiiKeEp
    Last edited by KiiKeEp; 04-20-16 at 12:55 PM. Reason: add important info
    Lusitano17 likes this.
    04-19-16 11:04 PM
  2. Lusitano17's Avatar
    My Passport's proximity sensor isn't working since new.
    In BBVE I noticed that if I turn the phone upside down (screen seeing to the floor) the sensor starts working if I test with my hand and upside down.

    So, gyroscope or acelerometer related? Or the sensor isn't in the correct position.

    I pulled battery, reinstal OS, clean conectors and nothing, dunno if its easy to access to the sensor itself for cleaning.

    How many with this issue??
    Do you think its software or hardware related??

    I know I'm not the only one, lets find a fix for this

    BBVE test results: always saying ''near'', but if I rotate the phone or move it the test detect far too.
    Click image for larger version. 

Name:	IMG_20160419_230129.png 
Views:	1114 
Size:	95.5 KB 
ID:	397668

    Posted via CB10
    What are the results of the remaining sensor tests? Those will give you an indication of whether or not the gyroscope and accelerometer are functional. How exactly are you testing distance when the device is face-up? If you reloaded OS and problem remains it is likely hardware.
    If this device is a recent purchase and all indications point to hardware you should return it for exchange or warranty repair.
    04-20-16 12:14 AM
  3. Lucas D's Avatar
    My Black one had the sensor issue was such a pain when using it in bed or late in dark ended up selling it. Got SE never had the issues with that but I'm back on z30 now anyway

    Posted via CB10
    04-20-16 02:25 AM
  4. littlebuff's Avatar
    It happens to me from time to time. One or a few hard reset would help.


    Posted from my Passport
    04-20-16 11:48 AM
  5. KiiKeEp's Avatar
    I Fixed it by cleaning the sensor and the glass section under it, I'm uploading video.
    kadlk likes this.
    04-20-16 12:29 PM
  6. coffeeaddict305's Avatar
    Had that issue with my Red Passport for a few days and I agree with letting the battery die overnight and then charge it. That miraculously worked! Almost wanted to send it for repair and very very happy I didn't! Disassembly is the very lsst option!

    Posted via CB10
    04-20-16 02:29 PM
  7. KiiKeEp's Avatar
    Yeah disassembly is the last option!

    Posted via CB10
    04-20-16 09:13 PM
  8. conbrio29's Avatar
    FIX BELOW

    My Passport's proximity sensor isn't working since new.
    In BBVE I noticed that if I turn the phone upside down (screen seeing to the floor) the sensor starts working if I test with my hand and upside down.

    So, gyroscope or acelerometer related? Or the sensor isn't in the correct position.

    I pulled battery, reinstal OS, clean conectors and nothing, dunno if its easy to access to the sensor itself for cleaning.

    How many with this issue??
    Do you think its software or hardware related??

    I know I'm not the only one, lets find a fix for this

    BBVE test results: always saying ''near'', but if I rotate the phone or move it the test detect far too.
    Click image for larger version. 

Name:	IMG_20160419_230129.png 
Views:	1114 
Size:	95.5 KB 
ID:	397668

    Posted via CB10

    -------------------------------------------------

    EDIT: I Fixed it by cleaning the sensor and the glass section under it, I share you the proccess:



    So, there are several reasons why the sensor might not work.
    I recommend you try the following before disassembly:

    1. Reinstall OS
      BB10 Leaked/Beta OS - BlackBerry Forums at CrackBerry.com
    2. Battery pull or let it die (0%) for a while
    3. Contact RIM for Waranty
    4. Disassembly & clean (Which I did)


    Cheers - KiiKeEp
    Awesome! I had a hunch cleaning the proximity sensor window would work! I once had a Passport that I sold because of this exact issue, and I swear that the proximity sensor window was dirty (I could see it needed a cleaning). You could tell it's dirty inside if only super intense light actually triggers it to detect far, as it uses relative light brightness to determine near vs. far. I also am certain that it stopped working after I took my device to Ghost Armor and had a shoddy screen protector reapplied several times in one week. Their application solution grimed up the sensor window. I'm confident though that this video would have provided the fix I needed at the time! Thanks for sharing!

    Posted via CB10
    04-21-16 07:30 AM
  9. Q100's Avatar
    I noticed that the sensor starts working when in a video chat,an see the red light. Upon closing video chat it stops, an so does the sensor stop illumination. It's the face detection .

    Posted via CB10
    04-24-16 08:52 PM
  10. kadlk's Avatar
    Great!
    I had the same problem.
    25 minutes and all works!

    Thanks for video.
    09-09-16 06:51 AM

Similar Threads

  1. How to sync Sent emails with IMAP account?
    By conkybubs in forum BlackBerry Priv
    Replies: 11
    Last Post: 10-12-17, 02:38 AM
  2. FB messenger is not running on BlackBerry Passport
    By Bunthoeunek007 in forum Ask a Question
    Replies: 2
    Last Post: 04-22-16, 01:35 AM
  3. Z10: The ONLY BlackBerry with 5000mAh battery available
    By MarCiano274 in forum BlackBerry Z10
    Replies: 11
    Last Post: 04-20-16, 08:35 PM
  4. How to downgrade from OS 10.3.2.2876?
    By SolarBear28 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 04-20-16, 05:37 PM
  5. How can I update my AT&T unlocked priv without AT&T network?
    By ss109nato in forum BlackBerry Priv
    Replies: 2
    Last Post: 04-19-16, 09:06 PM
LINK TO POST COPIED TO CLIPBOARD