More Answers

69
Apr 01 2021 | 2:41 pm EDT Tutur

I managed to download and install Google Chrome to one of my OS10 devices a few weeks ago.

I've installed a Google Play solution (Cobalt) to my Z30, and I was able to download and use Chrome.

It worked fine, but I've deleted it a while ago.

56,038
Apr 01 2021 | 2:53 pm EDT conite

I managed to download and install Google Chrome to one of my OS10 devices a few weeks ago.

I've installed a Google Play solution (Cobalt) to my Z30, and I was able to download and use Chrome.

It worked fine, but I've deleted it a while ago.
Except that the Cobalt solution is so old that the ancient files present a security risk.

69
Apr 01 2021 | 3:07 pm EDT Tutur

That's one of the reasons why I deleted is after a while.
But it works in general.

89
Apr 01 2021 | 6:34 pm EDT MeMeCe

Today I downloaded and installed Chrome simply from Yalp Store just out of curiosity. No problems at all, Chrome installed and works. No need for Cobalt solution at all. Haven't done any testing, just opened some random web pages. But it seems to start and run much quickly and smoother than any other Android browser on BB10. To my surprise. Funny.

EDIT: This way is installed Chrome ver 42.0.2311.111 from April 2015, so it is quite ancient (ver 89. is probably the most up to date).

Posted via CB10

69
Apr 02 2021 | 3:06 am EDT Tutur

I remember the installed App was much "smaller / lighter" than other Android Browser.
I think it was like this: Chrome 65 MB, Opera 80MB and Firefox 85MB.
Those might not be the exact figures, but it was a significant difference.