06-19-19 03:06 AM
28 12
tools
  1. passpass's Avatar
    I tried an old link you've posted on how to install viber on 2018 but nothing works. I really need it pls help
    03-17-19 11:21 AM
  2. Sime0n_S's Avatar
    03-17-19 02:42 PM
  3. passpass's Avatar
    It doesn't work unfortunately So nobody with a passport has viber? i mean there must be a way....anyone?
    03-20-19 01:44 PM
  4. TrumpetTiger's Avatar
    It doesn't work unfortunately So nobody with a passport has viber? i mean there must be a way....anyone?
    What's the error you get when trying to run Viber pass? I seem to be stuck on an activation spiral but I assume you already have an active account....
    03-20-19 09:01 PM
  5. TrumpetTiger's Avatar
    It doesn't work unfortunately So nobody with a passport has viber? i mean there must be a way....anyone?
    What's the error you get when trying to run Viber pass? I seem to be stuck on an activation spiral but I assume you already have an active account....
    03-20-19 09:02 PM
  6. johnny_bravo72's Avatar
    I tried an old link you've posted on how to install viber on 2018 but nothing works. I really need it pls help
    If you "really need" Viber, use a compatible device.
    03-20-19 09:38 PM
  7. TrumpetTiger's Avatar
    If you "really need" Viber, use a compatible device.
    Come now johnny; the OP was asking how to install it on a Passport. I don't tell Android people who are mad at Blackberry Mobile devices but want to stick with the ecosystem to switch back to BB10.....
    03-20-19 09:53 PM
  8. johnny_bravo72's Avatar
    Come now johnny; the OP was asking how to install it on a Passport. I don't tell Android people who are mad at Blackberry Mobile devices but want to stick with the ecosystem to switch back to BB10.....
    Just keeping it real. Why force the OP to use a device that's obviously incompatible with an app that's a necessity for him.
    03-20-19 09:59 PM
  9. conite's Avatar
    Come now johnny; the OP was asking how to install it on a Passport. I don't tell Android people who are mad at Blackberry Mobile devices but want to stick with the ecosystem to switch back to BB10.....
    You're happy to steer people clear of BBMo devices though:

    "I hear you on going with something else over a GooBerry and would tend to agree."
    03-20-19 10:18 PM
  10. TrumpetTiger's Avatar
    Just keeping it real. Why force the OP to use a device that's obviously incompatible with an app that's a necessity for him.
    Because he wants to use it on this device. It should be all about the OP's choice, not what we think is best for them.
    03-20-19 10:56 PM
  11. TrumpetTiger's Avatar
    You're happy to steer people clear of BBMo devices though:

    "I hear you on going with something else over a GooBerry and would tend to agree."
    I was agreeing with the already-expressed opinion of the OP in that comment, as full context and quoting of the OP's post makes clear.

    There is another post in which the OP indicates they've already made the decision to switch to a GooBerry and I say I'm sorry to see them go but that they've got to do what works for them.

    EDIT: In fact, if memory serves I make that point in the exact same thread, two posts up from the comment you quote...so I express sadness but understanding that the OP is leaving BB10 BEFORE I agree that BBMobile devices are not the way to go for her, for the reasons she herself stated.
    03-20-19 10:58 PM
  12. conite's Avatar
    I tried an old link you've posted on how to install viber on 2018 but nothing works. I really need it pls help
    Because he wants to use it on this device. It should be all about the OP's choice, not what we think is best for them.
    The problem here is that being able to use a Passport and Viber (in a reasonably-functional way) are mutually exclusive.
    03-20-19 11:03 PM
  13. johnny_bravo72's Avatar
    Because he wants to use it on this device. It should be all about the OP's choice, not what we think is best for them.
    Lol but the OP's choice would be based on what we think is best for them. And we obviously have different opinions/solutions for his predicament.
    03-20-19 11:26 PM
  14. TrumpetTiger's Avatar
    The problem here is that being able to use a Passport and Viber (in a reasonably-functional way) are mutually exclusive.
    Or so you believe. You may be correct, but there is a default towards "assume it won't work" with BB10 when many many times there are ways to make apps work in ways that are not only reasonably functional but which completely serve the needs of the user.
    03-20-19 11:32 PM
  15. TrumpetTiger's Avatar
    Lol but the OP's choice would be based on what we think is best for them. And we obviously have different opinions/solutions for his predicament.
    No, the OP's choice is based on what THEY think is best for them. That's what makes it their choice.

    We do certainly have different opinions/solutions. I just ask that posts be on point to the solution the OP wants, as would be the case if this were a Blackberry Android device and the OP had stated they like the device "but"....
    03-20-19 11:35 PM
  16. johnny_bravo72's Avatar
    It doesn't work unfortunately So nobody with a passport has viber? i mean there must be a way....anyone?
    OP, try this solution. Follow the video instructions to the letter. If Viber still doesn't work, no other choice but to upgrade your device. Just use the Passport as a secondary/backup phone.

    03-20-19 11:42 PM
  17. conite's Avatar
    No, the OP's choice is based on what THEY think is best for them. That's what makes it their choice.

    We do certainly have different opinions/solutions. I just ask that posts be on point to the solution the OP wants, as would be the case if this were a Blackberry Android device and the OP had stated they like the device "but"....
    The OP "really needs Viber". Suggesting a compatible device is as fair game as suggesting a degraded workaround.

    Version 5.6.5.1885 should work, and does not require patching. The experience is rather limited however.
    03-20-19 11:42 PM
  18. TrumpetTiger's Avatar
    The OP "really needs Viber". Suggesting a compatible device is as fair game as suggesting a degraded workaround.

    Version 5.6.5.1885 should work, and does not require patching. The experience is rather limited however.
    I will keep that in mind for future reference, as there are cases when OPs "really need" reliable hardware and a Hub that actually displays, for example, SMS messages.
    03-20-19 11:50 PM
  19. conite's Avatar
    I will keep that in mind for future reference, as there are cases when OPs "really need" reliable hardware and a Hub that actually displays, for example, SMS messages.
    Not the same, but OK.

    The HUB+ Inbox app, apart from being one of the best (if not the best) email client on Android, has never purported to be anything more than a notification aggregator for other (non-email) apps.
    03-20-19 11:54 PM
  20. TrumpetTiger's Avatar
    OP, try this solution. Follow the video instructions to the letter. If Viber still doesn't work, no other choice but to upgrade your device. Just use the Passport as a secondary/backup phone.


    Well well well....words I thought I might never say in this order, but thank you johnny_bravo72!

    Passpass, here are the links referenced in the video:

    Ghost Commander:

    https://drive.google.com/file/d/1GLw...XCnRFSPhR/view

    Viber 5.6.5.1885:

    https://drive.google.com/file/d/1P_S...2yhxPMKoX/view
    03-20-19 11:54 PM
  21. conite's Avatar
    Well well well....words I thought I might never say in this order, but thank you johnny_bravo72!

    Passpass, here are the links referenced in the video:

    Ghost Commander:

    https://drive.google.com/file/d/1GLw...XCnRFSPhR/view

    Viber 5.6.5.1885:

    https://drive.google.com/file/d/1P_S...2yhxPMKoX/view
    The link and solution was already posted in the second post of this thread.
    03-20-19 11:57 PM
  22. TrumpetTiger's Avatar
    The link and solution was already posted in the second post of this thread.
    Whatever you say.
    03-20-19 11:59 PM
  23. BigBadWulf's Avatar
    OP please post if it works. You two above, get a room.
    03-21-19 09:03 PM
  24. passpass's Avatar
    IT WORKED. Hope it's safe though... thanks alot
    03-24-19 09:20 AM
  25. AlexDelRio's Avatar
    I tried an old link you've posted on how to install viber on 2018 but nothing works. I really need it pls help
    Just install version 5.6.5. Works on my passport for casual chat with unimportant people who still need to communicate with me. Of course, as this is an obsolete version a lot of functionality is lost compared to the latest.
    04-02-19 04:48 AM
28 12

Similar Threads

  1. Where can I buy BlackBerry branded earphones?
    By Yoox_II in forum BlackBerry KEYone
    Replies: 3
    Last Post: 03-24-19, 09:25 PM
  2. Outlook on Passport
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 03-20-19, 08:46 PM
  3. Best Prepaid Sim for Passport?
    By ArbuckleWillis in forum BlackBerry Passport
    Replies: 1
    Last Post: 03-17-19, 10:27 AM
  4. Can't disable Google calendar in calender app settings
    By joergbrandt in forum BlackBerry KEY2
    Replies: 2
    Last Post: 03-17-19, 07:50 AM
  5. Replies: 1
    Last Post: 03-17-19, 01:45 AM
LINK TO POST COPIED TO CLIPBOARD