1. Strongbad789's Avatar
    I had Hailo working fine on my Z10 by installing the google play services apk as well as the google play store apk (I had to fiddle around a bit to figure out which versions of each of them needed to be installed; too old or too new and it didn't seem to work). Once I did that, Hailo worked and was able to co-exist with various other sideloaded Android apps (notably Google maps, but various others as well).

    On my Passport I tried to do the same thing (with the same versions of play services and play store), and Hailo wouldn't load (kept getting a "You must upgrade Google Play Services" message). So I tried using somewhat newer versions of both files until I found a combination that works (play services 5.0.77 and play store 4.8.22; although I keep getting a "Unfortunately, Google Play Services has stopped" popup every so often when using Hailo, so I might need to fiddle around with the versions a bit more, but other than that it generally works).

    The problem, though, is that as soon as I installed the play services and play store apk files google maps stopped working (I get the same "Unfortunately, Google Play Services has stopped" message, but then maps either crashes or just hangs on loading).

    So...I'm wondering: has anyone had any luck with any combination of play services/play store apk files, or any other method, to get android apps like Hailo to work without screwing up other android apps like google maps? I'm going to keep playing around with different version files in the meantime, but I thought I might save myself some trouble if someone here already knew (or had a better solution).

    Thanks!
    10-16-14 10:58 AM
  2. Jonesy1966's Avatar
    Hailo's pulling out of North America, it was announced a few days ago. When that's effective I have no idea. The local managers in Toronto said they would try and keep it running there but there doesn't seem much hope that'll work out.

    When were you trying to install it on your Passport? If it was in the last 3 or 4 days that might explain why it's not working.

    This from TechCruch 2 days ago:

    http://techcrunch.com/2014/10/14/hai...under-license/

    I just remembered, there is a Google Services Patch app that's floating around CrackBerry somewhere, worth a search.
    Last edited by Jonesy1966; 10-16-14 at 11:33 AM.
    10-16-14 11:22 AM
  3. Strongbad789's Avatar
    Wow..I hadn't heard that. I hope that they do manage to keep things going in Toronto (where I live)...it's a very useful product. Although maybe it is time to look into Uber.

    That being said I don't think that that was the problem with the app...I'm pretty sure it's a Google services/play store issue. I'll check for the patch app...thanks!
    10-16-14 12:34 PM

Similar Threads

  1. BB Z30 and BB Link not working?
    By ProjectBrett in forum BlackBerry Z30
    Replies: 5
    Last Post: 10-16-14, 06:37 PM
  2. New respect for TMo USA tech service
    By CPR in forum BlackBerry Q10
    Replies: 3
    Last Post: 10-16-14, 01:36 PM
  3. CBS launches 'All Access' streaming subscription without the need for cable
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-16-14, 10:22 AM
  4. Is there an app that will allow my Z10 to sync with my iTunes?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-14, 09:13 AM
  5. Replies: 2
    Last Post: 10-16-14, 08:37 AM
LINK TO POST COPIED TO CLIPBOARD