1. buon1977's Avatar
    I was able to install Cobalt's Google play store on my Passport without a problem. I tried installing it on my Z30 but I keep getting stuck on the Google account stage. When I try to add an existing account I keep getting an error message saying that Google cannot communicate with its servers. Is it safe to assume that you can't have two devices on the same Google account??

    Posted via CB10
    09-23-17 09:56 PM
  2. joeldf's Avatar
    It shouldn't be a problem.

    I have Cobalt's Google Play on my Z10, and when I switched to the Galaxy S8, I signed in with the same account.

    But, I still have my Z10, just without cellular. The wi-fi still works and Google Play still works showing me updates for apps when they are released.

    At the same time, the S8 now has its set of apps. If I check the "Library" on either phone, it shows the same list of apps I've installed on both phones but deleted.

    Something just may not have been set up right on the Z30. Might try un-installing and re-installing the whole setup again from scratch just to be sure. Make sure you're using build 2 of the Play Store app itself.
    09-23-17 10:42 PM
  3. buon1977's Avatar
    Thanks for the tip. Will uninstall and reinstall and report back.

    Posted via CB10
    09-24-17 10:25 AM

Similar Threads

  1. What can BlackBerry do to protect our privacy from Google?
    By joker333 in forum BlackBerry KEYone
    Replies: 55
    Last Post: 10-02-17, 05:55 AM
  2. Should I be able to download access to Google Play Store to my Q10?
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 09-25-17, 06:53 AM
  3. Google Play Store doesn't work
    By Bossque in forum Ask Bla1ze
    Replies: 2
    Last Post: 09-24-17, 01:47 PM
  4. Why is my Z10 deleting google play/instagram after a reboot?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-22-17, 10:06 PM
  5. Replies: 0
    Last Post: 09-22-17, 04:20 PM