1. Lauriecad's Avatar
    Although it is not my main sat-nav on Passport SE, have been using Google Maps mostly for traffic in the UK and it has been working well for a few weeks. It it is now asking for my location services to be switched on. As far as I can see everything is switched on and I haven't switched anything off... Also, I have not upgraded the operating system from .2474 yet. any ideas?
    Thanks!

    Google Maps stopped-maps.png
    01-04-16 06:15 AM
  2. xueyaotianxia's Avatar
    Is this the newest google maps? I had the same problem before after I updated the newest version. Try install older version, I have no problem after installing the older version.

    Mia San Mia!
    01-04-16 11:03 AM
  3. Lauriecad's Avatar
    No idea what version I am on; how do I check? And where do I get the older version?
    Also, have not upgraded Maps at all – unless it has happened automatically?

    Thanks
    01-04-16 11:26 AM
  4. LoneStarRed's Avatar
    No idea what version I am on; how do I check? And where do I get the older version?
    Also, have not upgraded Maps at all unless it has happened automatically?

    Thanks
    Do you have Lucky Patcher or Snap? They will give you that info.

    "I don't think that word means what you think it means."
    01-04-16 02:12 PM
  5. Lauriecad's Avatar
    I have Lucky Patcher and patched the software. No luck. I then deleted Maps and installed an earlier version but still comes up with the same message. I did note that whatever version I load it from a fresh install it still seems to know my 'home' details. Is there something else I need to delete?
    But very strange that it's stopped working without any update etc.
    01-05-16 06:36 AM
  6. LoneStarRed's Avatar
    Take a look at the location of the file in the attached screenshot. That is where your Google Maps data is stored. Delete that for a clean install.

    Google Maps stopped-img_20160105_100354.png

    "I don't think that word means what you think it means."
    01-05-16 10:06 AM
  7. gravesend60's Avatar
    Use Waze.

    Blackberry Passport
    aidan finnegan likes this.
    01-05-16 11:10 AM
  8. xueyaotianxia's Avatar
    Just delete the current version. And then google older versions apk and download it. Maybe try earlier than OCT 2015.

    Mia San Mia!
    01-05-16 12:10 PM
  9. Optimus4's Avatar
    The newest version works on my passport. On OS2836. Delete reinstall.

    8700, Bold 9000, Bold 9900, Z30, SE Passport, ?????
    01-05-16 10:53 PM
  10. Lauriecad's Avatar
    I deleted the files LoneStarRed mentioned and clean installed an older version but still no luck.
    Time to give up... but thanks again for all your help and suggestions. Really appreciate it!
    01-06-16 07:20 AM
  11. yessuz's Avatar
    I deleted the files LoneStarRed mentioned and clean installed an older version but still no luck.
    Time to give up... but thanks again for all your help and suggestions. Really appreciate it!
    Have you rebooted phone with volume up + down?

    CB10 on PP SE in UK on 3
    01-06-16 08:19 AM
  12. Lauriecad's Avatar
    Yep, just tried again and rebooted twice before a clean install. Still the same error. I have location set to 'on' of course!
    01-06-16 12:36 PM
  13. LoneStarRed's Avatar
    Do you have saved locations in a Google (Maps) account ? Are you logged into Google Services?

    "I don't think that word means what you think it means."
    01-06-16 01:17 PM
  14. Lauriecad's Avatar
    Yes, just home, but I deleted the cache and then tried again. I am logged in to Google. The strange thing was that this was working well then got the OP message without fiddling with anything!
    01-06-16 01:27 PM
  15. Lauriecad's Avatar
    Last comment on this... Just realised that location not working on Google Earth either. But GPS does work on non-Google apps so it seems like a permissions issue. Make sense?
    01-07-16 04:13 AM
  16. LoneStarRed's Avatar
    Have you done a BBVE diagnostics test on the phone?

    "I don't think that word means what you think it means."
    01-10-16 09:29 PM
  17. Vistaus's Avatar
    Use BeMaps Pro from BBW.

    Posted via CB10 using BlackBerry Passport (OG Red)
    01-11-16 12:54 AM
  18. Lauriecad's Avatar
    Hi, have just sorted it... I read through some old threads and downloaded 'Google Settings' and clicked on location. If I needed it all the time I have no idea how Maps worked without it previously...
    Still not getting location on Google Earth but I can live with that!
    01-11-16 06:52 AM
  19. LoneStarRed's Avatar
    AWESOME!

    "I don't think that word means what you think it means."
    01-11-16 09:41 AM
  20. cvendra's Avatar
    Have you installed cobalt's google services files? If so uninstall and reinstall google id and play services.

    Passport, SQW 100-1, OS 10.3.2.2639
    01-11-16 07:02 PM
  21. LoneStarRed's Avatar
    Have you installed cobalt's google services files? If so uninstall and reinstall google id and play services.

    Passport, SQW 100-1, OS 10.3.2.2639
    Why?

    "I don't think that word means what you think it means."
    01-12-16 12:33 AM
  22. Lauriecad's Avatar
    Hi Cvendra, as I mentioned i installed Cobalt's Google Settings which seems to have fixed it.

    Thanks again, everyone!
    01-12-16 04:40 AM

Similar Threads

  1. Anyone using Google Translate on Passport?
    By carloeh in forum BlackBerry Passport
    Replies: 9
    Last Post: 01-24-16, 07:57 PM
  2. Google Voice
    By Munchkinguy in forum BlackBerry OS Apps
    Replies: 5
    Last Post: 01-08-16, 11:13 PM
  3. How to stop crackberry from email notifying?
    By Juwoon in forum Site Feedback & Help
    Replies: 6
    Last Post: 01-04-16, 03:57 AM
  4. How to install Google maps on BlackBerry 10??
    By yash choudhary1 in forum Ask a Question
    Replies: 2
    Last Post: 01-02-16, 11:07 AM
  5. Why does my blackberry sometimes stop working right?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-01-16, 04:47 PM
LINK TO POST COPIED TO CLIPBOARD