1. maxpowerxiii's Avatar
    I hope this isn't premature, but I believe I was able to fix the focus problems on my Passport camera!
    I've had the issue since I received this RMA unit from BlackBerry back in April, where the camera couldn't focus and I was literally rigorously tapping the rear camera with my finger to get it to focus. It worked intermittently but I got tired of doing that every time I wanted to take a picture.

    I thought about changing the camera module itself and found some on ebay for $50 usd, but I thought I'd open up the phone and check if there were any loose connections.

    Finally, this morning I opened it up and took off and put the camera module back on. I tried using the camera while all of the back housing was off and I could hear it moving and trying to focus to take a picture. It definitely moves a lot trying to focus, which is good. The mechanism was working.
    I put the back cover on without putting the screws in and the camera seemed to be focusing fine. Great!

    Then I put in all the screws tightly then tried the camera again. Same problem as before. Damn thing couldn't focus!!

    I think the back cover was too tightly screwed on preventing the camera lens from actually moving to focus. I slightly loosened the 3 screws around the camera and lo and behold it's focusing again!!

    So, long story short, if you've got a Torx-4 screwdriver and having camera focusing issues try loosening the 3 screws around the back cover of the camera and see if that helps. You just need to pop off the sim/sd card cover to see the 2 silver screws and 1 black stickered screw.

    This may or may not work for you but if it does, then it's a really quick and easy fix! Good luck!!

    Posted via CB10
    littlebuff and hoppysfave like this.
    08-20-16 11:10 AM
  2. mofoahh's Avatar
    Great job, yeah if you were to remove the cover and open the camera app, it goes crazy trying to focus and makes vibration sounds.
    08-20-16 11:18 AM
  3. mofoahh's Avatar
    Great job, yeah if you were to remove the cover and open the camera app, it goes crazy trying to focus and makes vibration sounds.
    Forget to add, I removed the torx to the right of the camera module. So I would have three torx screwed in instead of the four.
    Last edited by mofoahh; 08-20-16 at 02:34 PM.
    08-20-16 11:19 AM
  4. maxpowerxiii's Avatar
    Great job, yeah if you were to remove the cover and open the camera app, it goes crazy trying to focus and makes vibration sounds.
    Yep, it does make a crazy sound. That's how I knew my camera actually worked. Lol. So you tried this too? And you've had no issues with it since the fix? I'm pretty happy I was able to save myself $50usd and got my passport working as it should!

    Posted via CB10
    08-20-16 11:34 AM
  5. mofoahh's Avatar
    So far so good, but I hardly take pictures. I guess when it's too tight it restricts the focusing.
    08-20-16 02:35 PM
  6. Arjun Sahota's Avatar
    I am currently having the issue of my camera not focuing as well, but this is one year into my passport camera working perfectly.

    Is it possible the solution will work? I can hear and feel the autofocus motor going wild as well...

    Just wondering since I don't want to buy a torx, would be nice to know if this happened to someone down the road after buying their device

    Posted via BlackBerry Passport
    08-20-16 09:43 PM
  7. Cortizo5's Avatar
    I've got the same problem but my camera worked well for a year.
    Where can I get this tool?

    Posted via CB10
    08-21-16 12:00 AM
  8. maxpowerxiii's Avatar
    You can find a precision Torx screwdriver set online or your local hardware store. They'll range from $2-$15 usd or so.

    Not sure if your situation varies since your camera used to work, but it's worth a shot.

    Posted via CB10
    08-21-16 06:35 AM
  9. mofoahh's Avatar
    You can try it, like maxpower said, its only a few bucks to buy a set of these torx screwdriver set. If not it is possible that your lens is failing.
    08-21-16 03:46 PM

Similar Threads

  1. Replies: 14
    Last Post: 09-17-16, 02:41 PM
  2. I am not able to send emails from my Blackberry Q10
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-20-16, 05:32 AM
  3. My BB 9220 Curve is not starting only red light is blinking 4 time
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-20-16, 01:57 AM
  4. How do I order the Spigen magnetic clasp for my cell phone cover ?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 08-19-16, 10:31 PM
  5. I just installed Marshmallow 6.0.1 on my Priv and now having wifi issues.
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-19-16, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD