1. quigley0's Avatar
    I have a TMO Passport. I have been using an iPhone as a daily driver until the KEYone is released. My iPhone died, and i am using my passport again. For some reason, this time when i put my SIM in, it enabled WIFI calling. I can't figure out how to turn it off, and it is driving me crazy because the WIFI calling doesnt really work. I cant find how to turn it off in settings anywhere. Anyone know how to disable this in settings?
    05-07-17 02:48 PM
  2. naeempriv's Avatar
    you need to have the wifi calling app from TMo to disable it. you can download from the link below.

    http://appworld.blackberry.com/webst...tent/35524900/

    Once this app is downloaded you can turn off wifi calling from this app.
    It worked for me on my passport to disable wifi calling.
    crd2016 likes this.
    05-07-17 02:57 PM
  3. quigley0's Avatar
    Thanks! That did the trick! Interestingly, i read somewhere that i would have to down load the app. I searched for the app, but nothing came up. Your direct link saved me much headache. Thanks!
    05-07-17 03:05 PM
  4. drpr's Avatar
    This is the only solution I've seen for this issue, but I have MetroPCS (a tmobile subsidiary) and the app doesn't show up for me. Does anyone have any other ideas? WiFi calling and texting is incredibly unreliable for me.

    Posted via CB10
    crd2016 likes this.
    05-20-17 03:44 PM
  5. NikkoCharger's Avatar
    Try opening the link posted above on another device. Once the page is open, scan the qr code on the page with your Passport. That's how I had to do it on my Passport SE that's also on MetroPCS
    crd2016 likes this.
    05-21-17 11:28 PM
  6. Jack Lope's Avatar
    Weird thing, WiFi calling just started working on my passport. I never installed an app or anything. Is ok unless the WiFi connection sucks and I get a staticy call, or when I walk out of a building and lose connection because the WiFi service is lost.
    05-23-17 08:39 AM
  7. drpr's Avatar
    Brilliant! The QR Code trick worked perfectly. Thanks a ton.

    Posted via CB10
    05-23-17 07:28 PM
  8. Lilyville's Avatar
    Thank you so much!! I just found out that my MMS wasn't working due to WiFi calling being enabled. I was about to return my 3-day-old phone until I saw this thread... You saved my Passport's life!

    Posted via CB10
    06-28-17 07:27 PM
  9. crd2016's Avatar
    All of a sudden today I couldn't send text messages. I have a passport purchased directly from BB. I am on t-mobile. The BB team there couldn't help me. This app fixed the problem. I had to use the QR code because the app does not show up in blackberry world. I had to restart the phone. Now it seems to be working. Fingers crossed that this is a permanent fix.
    09-25-17 12:14 AM

Similar Threads

  1. How to turn off Wifi Calling on Classic?
    By lilituc in forum T-Mobile
    Replies: 6
    Last Post: 06-29-17, 07:41 PM
  2. Disable Android Messages?
    By patapoof in forum BlackBerry Priv
    Replies: 27
    Last Post: 05-10-17, 06:30 PM
  3. Can I disable the Keyboard change button
    By claytargets in forum BlackBerry DTEK60
    Replies: 5
    Last Post: 05-08-17, 05:16 PM
  4. Wifi annoyance?
    By forrestishmael in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 05-08-17, 09:57 AM
  5. Call quality and keyboard question
    By 1TIME in forum BlackBerry KEYone
    Replies: 2
    Last Post: 05-03-17, 08:25 AM
LINK TO POST COPIED TO CLIPBOARD